Skip Menu |
 

This queue is for tickets about the Crypt-Random-Source CPAN distribution.

Report information
The Basics
Id: 128218
Status: open
Priority: 0/
Queue: Crypt-Random-Source

People
Owner: Nobody in particular
Requestors: MITHALDU [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: 0.14 fails to install
Download (untitled) / with headers
text/plain 3.8k
The below log happened on a fresh perl, trying to install with CPAN.pm. After installing v0.12, then v0.13, v0.14 started installing fine though, so maybe the tests have something missing without a previous version installed. t/00-report-prereqs.t .. # # Versions for all modules listed in MYMETA.json (including optional ones): # # === Configure Requires === # # Module Want Have # ------------------- ----- ----- # ExtUtils::MakeMaker any 7.34 # Module::Build::Tiny 0.034 0.039 # # === Test Requires === # # Module Want Have # ---------------- ---- -------- # File::Spec any 3.74 # IO::Select any 1.39 # Module::Metadata any 1.000033 # Test::Fatal any 0.014 # Test::More 0.88 1.302136 # ok any 1.302136 # # === Test Recommends === # # Module Want Have # ---------- -------- -------- # CPAN::Meta 2.120900 2.150010 # # === Runtime Requires === # # Module Want Have # ---------------- -------- -------- # Capture::Tiny 0.08 0.48 # Carp any 1.50 # File::Spec any 3.74 # IO::File 1.14 1.39 # IO::Handle any 1.39 # Module::Find any 0.13 # Module::Runtime any 0.016 # Moo 1.002000 2.003004 # Sub::Exporter any 0.987 # Types::Standard any 1.004004 # namespace::clean 0.11 0.27 # strict any 1.11 # warnings any 1.42 # # === Other Modules === # # Module Have # --------- ------- # Encode 2.98 # JSON::PP 2.97001 # Sub::Name 0.21 # YAML 1.26 # autodie 2.29 # t/00-report-prereqs.t .. ok t/blocking.t ........... ok t/dev_random.t ......... skipped: no /dev/random and /dev/urandom t/factory.t ............ 1/? Undef did not pass type constraint "ClassName" (in $self->{"weak_source"}) at t/factory.t line 11 "ClassName" is a subtype of "Str" "Str" is a subtype of "Value" "Value" is a subtype of "Defined" Undef did not pass type constraint "Defined" (in $self->{"weak_source"}) "Defined" is defined as: (defined($_)) # Tests were run but no plan was declared and done_testing() was not seen. # Looks like your test exited with 255 just after 1. t/factory.t ............ Dubious, test returned 255 (wstat 65280, 0xff00) All 1 subtests passed t/proc.t ............... ok t/reread.t ............. ok t/sugar.t .............. 1/? Undef did not pass type constraint "ClassName" (in $self->{"weak_source"}) at (eval 84) line 17 "ClassName" is a subtype of "Str" "Str" is a subtype of "Value" "Value" is a subtype of "Defined" Undef did not pass type constraint "Defined" (in $self->{"weak_source"}) "Defined" is defined as: (defined($_)) # Tests were run but no plan was declared and done_testing() was not seen. # Looks like your test exited with 255 just after 3. t/sugar.t .............. Dubious, test returned 255 (wstat 65280, 0xff00) All 3 subtests passed Test Summary Report ------------------- t/factory.t (Wstat: 65280 Tests: 1 Failed: 0) Non-zero exit status: 255 Parse errors: No plan found in TAP output t/sugar.t (Wstat: 65280 Tests: 3 Failed: 0) Non-zero exit status: 255 Parse errors: No plan found in TAP output Files=7, Tests=17, 3 wallclock secs ( 0.03 usr + 0.03 sys = 0.06 CPU) Result: FAIL ETHER/Crypt-Random-Source-0.14.tar.gz C:\Strawberry\perl\bin\perl.exe ./Build test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports ETHER/Crypt-Random-Source-0.14.tar.gz Stopping: 'install' failed for 'E/ET/ETHER/Crypt-Random-Source-0.14.tar.gz'. D:\cpan\Crypt-Random-Source-Strong-Win32>perl -v This is perl 5, version 28, subversion 0 (v5.28.0) built for MSWin32-x64-multi-thread
Download (untitled) / with headers
text/plain 757b
On 2019-01-11 14:35:32, MITHALDU wrote: Show quoted text
> The below log happened on a fresh perl, trying to install with > CPAN.pm. After installing v0.12, then v0.13, v0.14 started installing > fine though, so maybe the tests have something missing without a > previous version installed.
Not reproducible for me (on darwin) - even in a fresh perl with no other modules, Crypt-Random-Source-0.14 passes its tests. This was the only consequential change in 0.14. https://metacpan.org/diff/file?target=ETHER/Crypt-Random-Source-0.14/&source=ETHER%2FCrypt-Random-Source-0.13#lib/Crypt/Random/Source/Factory.pm It appears that devurandom and openssl aren't suitable weak sources on your platform, and you're falling back to the ::rand source that was removed in 0.14.
Subject: Re: [rt.cpan.org #128218] 0.14 fails to install
Date: Sat, 12 Jan 2019 06:15:28 +0100
To: bug-Crypt-Random-Source [...] rt.cpan.org
From: Christian Walde <walde.christian [...] gmail.com>
Download (untitled) / with headers
text/plain 971b
well yeah, I'm on Windows On Sat, Jan 12, 2019, 05:49 Karen Etheridge via RT < bug-Crypt-Random-Source@rt.cpan.org wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=128218 > > > On 2019-01-11 14:35:32, MITHALDU wrote:
> > The below log happened on a fresh perl, trying to install with > > CPAN.pm. After installing v0.12, then v0.13, v0.14 started installing > > fine though, so maybe the tests have something missing without a > > previous version installed.
> > Not reproducible for me (on darwin) - even in a fresh perl with no other > modules, Crypt-Random-Source-0.14 passes its tests. > > This was the only consequential change in 0.14. > > > https://metacpan.org/diff/file?target=ETHER/Crypt-Random-Source-0.14/&source=ETHER%2FCrypt-Random-Source-0.13#lib/Crypt/Random/Source/Factory.pm > > It appears that devurandom and openssl aren't suitable weak sources on > your platform, > and you're falling back to the ::rand source that was removed in 0.14. >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.