Skip Menu |
 

This queue is for tickets about the Imager CPAN distribution.

Report information
The Basics
Id: 128145
Status: open
Priority: 0/
Queue: Imager

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: T1 tests fail on darwin (1.008)
Download (untitled) / with headers
text/plain 2.8k
If t1lib 5.1.2 from homebrew is installed, then the Imager test suite fails: ... PERL_DL_NONLAZY=1 "/usr/local/bin/perl5.12.3" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, '../blib/lib', '../blib/arch')" t/*.t # Failed test 'i_t1_cp' # at t/t10type1.t line 52. # Failed test 'i_t1_text' # at t/t10type1.t line 69. # Failed test 'draw hand-encoded UTF8' # at t/t10type1.t line 90. # Failed test 'cp hand-encoded UTF8' # at t/t10type1.t line 92. # Failed test 'draw UTF8' # at t/t10type1.t line 113. # Failed test 'cp UTF8' # at t/t10type1.t line 115. # Failed test 'more complex output' # at t/t10type1.t line 122. t/t10type1.t ... Failed 97/110 subtests # Failed test 'draw text' # at t/t20oo.t line 28. # Failed test 'draw 'utf8' hand-encoded text' # at t/t20oo.t line 41. # Failed test 'channel 'utf8' hand-encoded text' # at t/t20oo.t line 45. # Failed test 'draw native UTF8 text' # at t/t20oo.t line 54. # Failed test 'channel native UTF8 text' # at t/t20oo.t line 57. # Failed test 'draw with default color' # at t/t20oo.t line 74. # Failed test 'make sure something was drawn' # at t/t20oo.t line 80. # Failed test 'draw with default color' # at t/t20oo.t line 74. # Failed test 'make sure something was drawn' # at t/t20oo.t line 80. # Looks like you failed 9 tests of 14. t/t20oo.t ...... Dubious, test returned 9 (wstat 2304, 0x900) Failed 9/14 subtests t/t30thread.t .. skipped: can't test Imager's threads support with no threads # Failed test 'magic: make a base image' # at /Users/slaven.rezic/.cpan/build/2018123115/Imager-1.008-4/T1/../blib/lib/Imager/Test.pm line 773. # Failed test 'magic: draw with overload' # at /Users/slaven.rezic/.cpan/build/2018123115/Imager-1.008-4/T1/../blib/lib/Imager/Test.pm line 782. # Failed test 'magic: make a base image (channel)' # at /Users/slaven.rezic/.cpan/build/2018123115/Imager-1.008-4/T1/../blib/lib/Imager/Test.pm line 799. # Failed test 'magic: draw with overload (channel)' # at /Users/slaven.rezic/.cpan/build/2018123115/Imager-1.008-4/T1/../blib/lib/Imager/Test.pm line 808. # Looks like you failed 4 tests of 21. t/t90std.t ..... Dubious, test returned 4 (wstat 1024, 0x400) Failed 4/21 subtests Test Summary Report ------------------- t/t10type1.t (Wstat: 11 Tests: 20 Failed: 7) Failed tests: 6, 8, 12-13, 16-17, 20 Non-zero wait status: 11 Parse errors: Bad plan. You planned 110 tests but ran 20. t/t20oo.t (Wstat: 2304 Tests: 14 Failed: 9) Failed tests: 3, 5-8, 10-13 Non-zero exit status: 9 t/t90std.t (Wstat: 1024 Tests: 21 Failed: 4) Failed tests: 1-2, 4-5 Non-zero exit status: 4 Files=4, Tests=55, 0 wallclock secs ( 0.03 usr 0.02 sys + 0.27 cusr 0.10 csys = 0.42 CPU) Result: FAIL ... Some of the failures (t10type1.t) look like segfaults.
Download (untitled) / with headers
text/plain 428b
On Mon Dec 31 09:18:40 2018, SREZIC wrote: Show quoted text
> If t1lib 5.1.2 from homebrew is installed, then the Imager test suite > fails: >
... Show quoted text
> > Some of the failures (t10type1.t) look like segfaults.
I've reproduced this, both with the homebrew t1lib and one I built myself. I have no idea what the cause is, T1lib is aborting output of the glyphs, complaining: (E) T1_SetString(): t1_abort: Reason: unable to fix subpath break? Tony


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.