This queue is for tickets about the Imager-File-WEBP CPAN distribution.

Report information
The Basics
Id:
127894
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
SREZIC [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
0.002
Fixed in:
(no value)



Subject: Undefined symbol "WebPFree"
With older webp installations (e.g. freebsd 9, debian/wheezy, debian/jessie, CentOS6) the test suite fails: ... # Failed test 'use Imager::File::WEBP;' # at t/00use.t line 5. # Tried to use 'Imager::File::WEBP'. # Error: Can't load '/usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002-QElZ5u/blib/arch/auto/Imager/File/WEBP/WEBP.so' for module Imager::File::WEBP: /usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002-QElZ5u/blib/arch/auto/Imager/File/WEBP/WEBP.so: Undefined symbol "WebPFree" at /usr/local/lib/perl5/5.20/mach/DynaLoader.pm line 193. # at /usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002-QElZ5u/blib/lib/Imager/File/WEBP.pm line 11. # BEGIN failed--compilation aborted at /usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002-QElZ5u/blib/lib/Imager/File/WEBP.pm line 11. # Compilation failed in require at t/00use.t line 5. # BEGIN failed--compilation aborted at t/00use.t line 5. # Looks like you failed 1 test of 1. t/00use.t ...... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests ... etc ...
On 2018-12-03 16:29:25, SREZIC wrote:
Show quoted text
> With older webp installations (e.g. freebsd 9, debian/wheezy, > debian/jessie, CentOS6)
... and Ubuntu 16.04 ...
Show quoted text
> the test suite fails: > > ... > # Failed test 'use Imager::File::WEBP;' > # at t/00use.t line 5. > # Tried to use 'Imager::File::WEBP'. > # Error: Can't load > '/usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002- > QElZ5u/blib/arch/auto/Imager/File/WEBP/WEBP.so' for module > Imager::File::WEBP: /usr/home/eserte/.cpan/build/2018120322/Imager- > File-WEBP-0.002-QElZ5u/blib/arch/auto/Imager/File/WEBP/WEBP.so: > Undefined symbol "WebPFree" at > /usr/local/lib/perl5/5.20/mach/DynaLoader.pm line 193. > # at /usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002- > QElZ5u/blib/lib/Imager/File/WEBP.pm line 11. > # BEGIN failed--compilation aborted at > /usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002- > QElZ5u/blib/lib/Imager/File/WEBP.pm line 11. > # Compilation failed in require at t/00use.t line 5. > # BEGIN failed--compilation aborted at t/00use.t line 5. > # Looks like you failed 1 test of 1. > t/00use.t ...... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests > ... etc ...
I see successful tests on: - FreeBSD 10 .. 13 - Debian/stretch and /buster - Ubuntu 16.04 - Fedora 28
On Mon Dec 03 16:30:52 2018, SREZIC wrote:
Show quoted text
> On 2018-12-03 16:29:25, SREZIC wrote:
> > With older webp installations (e.g. freebsd 9, debian/wheezy, > > debian/jessie, CentOS6)
> > ... and Ubuntu 16.04 ... >
> > the test suite fails: > > > > ... > > # Failed test 'use Imager::File::WEBP;' > > # at t/00use.t line 5. > > # Tried to use 'Imager::File::WEBP'. > > # Error: Can't load > > '/usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002- > > QElZ5u/blib/arch/auto/Imager/File/WEBP/WEBP.so' for module > > Imager::File::WEBP: /usr/home/eserte/.cpan/build/2018120322/Imager- > > File-WEBP-0.002-QElZ5u/blib/arch/auto/Imager/File/WEBP/WEBP.so: > > Undefined symbol "WebPFree" at > > /usr/local/lib/perl5/5.20/mach/DynaLoader.pm line 193. > > # at /usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002- > > QElZ5u/blib/lib/Imager/File/WEBP.pm line 11. > > # BEGIN failed--compilation aborted at > > /usr/home/eserte/.cpan/build/2018120322/Imager-File-WEBP-0.002- > > QElZ5u/blib/lib/Imager/File/WEBP.pm line 11. > > # Compilation failed in require at t/00use.t line 5. > > # BEGIN failed--compilation aborted at t/00use.t line 5. > > # Looks like you failed 1 test of 1. > > t/00use.t ...... > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/1 subtests > > ... etc ...
> > I see successful tests on: > - FreeBSD 10 .. 13 > - Debian/stretch and /buster > - Ubuntu 16.04 > - Fedora 28
This should also be fixed by Imager::File::WEBP 0.003 (by rejecting older library versions.) Tony


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.