Skip Menu |
 

This queue is for tickets about the MooseX-DataModel CPAN distribution.

Report information
The Basics
Id: 127757
Status: new
Priority: 0/
Queue: MooseX-DataModel

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.01
Fixed in: (no value)



Subject: Modern package construct used
Download (untitled) / with headers
text/plain 653b
The test suite fails with older perls, e.g. 5.10.1: ... PERL_DL_NONLAZY=1 "/usr/perl5.10.1/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t syntax error at t/02_requiredness.t line 7, near "package TestKeyNotRequired { " Execution of t/02_requiredness.t aborted due to compilation errors. t/02_requiredness.t ......... Dubious, test returned 255 (wstat 65280, 0xff00) No subtests run ... (etc) ... Either the modern "package" form shouldn't be used (it looks like it's used just in the test suite anyway), or the minimum perl version should be increased.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.