Skip Menu |
 

This queue is for tickets about the App-githook-perltidy CPAN distribution.

Report information
The Basics
Id: 127725
Status: patched
Priority: 0/
Queue: App-githook-perltidy

People
Owner: MLAWREN [...] cpan.org
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.12.2
Fixed in: (no value)



Subject: Path::Tiny is a configure_requires prerequisite
Download (untitled) / with headers
text/plain 426b
Automatic build fails if Path::Tiny is not installed: ... Output from '/usr/local/bin/perl Makefile.PL': git version 2.19.1 Can't locate Path/Tiny.pm in @INC (you may need to install the Path::Tiny module) (@INC contains: ... .) at Makefile.PL line 49. BEGIN failed--compilation aborted at Makefile.PL line 49. ... Path::Tiny is already listed as a normal prereq, but it should additionally be a configure_requires prereq.
Subject: Re: [rt.cpan.org #127725] Path::Tiny is a configure_requires prerequisite
Date: Tue, 20 Nov 2018 11:47:10 +0100
To: Slaven_Rezic via RT <bug-App-githook-perltidy [...] rt.cpan.org>
From: nomad [...] null.net
Download (untitled) / with headers
text/plain 357b
Show quoted text
> Path::Tiny is already listed as a normal prereq, but it should > additionally be a configure_requires prereq.
Thanks for the report. I actually already have Path::Tiny as a configure requirement in the cpanfile, but it seems that doesn't get carried over to the MYMETA.json file. I'll need to go do some hunting for why that is... :-( -- Mark Lawrence
RT-Send-CC: nomad [...] null.net
Download (untitled) / with headers
text/plain 445b
On 2018-11-20 05:54:05, nomad@null.net wrote: Show quoted text
> > Path::Tiny is already listed as a normal prereq, but it should > > additionally be a configure_requires prereq.
> > Thanks for the report. I actually already have Path::Tiny as a > configure requirement in the cpanfile, but it seems that doesn't get > carried over to the MYMETA.json
I see. But you surely mean META.json. Show quoted text
> file. I'll need to go do some hunting > for why that is... :-( >
Subject: Re: [rt.cpan.org #127725] Path::Tiny is a configure_requires prerequisite
Date: Wed, 21 Nov 2018 12:46:12 +0100
To: Slaven_Rezic via RT <bug-App-githook-perltidy [...] rt.cpan.org>
From: nomad [...] null.net
Download (untitled) / with headers
text/plain 835b
On Tue Nov 20, 2018 at 03:11:38PM -0500, Slaven_Rezic via RT wrote: Show quoted text
> Queue: App-githook-perltidy > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=127725 > > > On 2018-11-20 05:54:05, nomad@null.net wrote:
> > > Path::Tiny is already listed as a normal prereq, but it should > > > additionally be a configure_requires prereq.
> > > > Thanks for the report. I actually already have Path::Tiny as a > > configure requirement in the cpanfile, but it seems that doesn't get > > carried over to the MYMETA.json
> > I see. But you surely mean META.json.
To be honest I'm not real clear on the differences between the two, but I assume from your comment that META.json is the one generated for distribution. In any event the the requirement doesn't make it into that file either... to be investigated. -- Mark Lawrence
RT-Send-CC: nomad [...] null.net
Download (untitled) / with headers
text/plain 1.2k
On 2018-11-21 06:46:44, nomad@null.net wrote: Show quoted text
> On Tue Nov 20, 2018 at 03:11:38PM -0500, Slaven_Rezic via RT wrote:
> > Queue: App-githook-perltidy > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=127725 > > > > > On 2018-11-20 05:54:05, nomad@null.net wrote:
> > > > Path::Tiny is already listed as a normal prereq, but it should > > > > additionally be a configure_requires prereq.
> > > > > > Thanks for the report. I actually already have Path::Tiny as a > > > configure requirement in the cpanfile, but it seems that doesn't get > > > carried over to the MYMETA.json
> > > > I see. But you surely mean META.json.
> > To be honest I'm not real clear on the differences between the two, but > I assume from your comment that META.json is the one generated for > distribution.
META.json is generated for the distribution, yes. But as sometimes it's necessary to add OS-dependent dependencies, Makefile.PL or Build.PL may amend the prerequisite list. The final dependency list after applying these changes goes to MYMETA.json, and this is what CPAN.pm or other installers use for the prerequisite resolution. Show quoted text
> In any event the the requirement doesn't make it into > that file either... to be investigated. >
Download (untitled) / with headers
text/plain 240b
Ah, a non-syntax error in my cpanfile, but an error none-the-less: requires => 'Path::Tiny'; Is not at all the same as: requires 'Path::Tiny'; the next release has this fixed. Thanks again for the report. Mark -- Mark Lawrence


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.