Skip Menu |
 

This queue is for tickets about the DBI CPAN distribution.

Report information
The Basics
Id: 127501
Status: open
Priority: 0/
Queue: DBI

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: SIGABRT in test suite (DBI-1.641_90)
Download (untitled) / with headers
text/plain 383b
Two tests fail with signal 6 on Ubuntu 18.04 systems: Test Summary Report ------------------- t/zvg_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) Non-zero wait status: 6 t/zvxgp_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) Non-zero wait status: 6 I don't see the problem on any other of smokers (freebsd 9, 10, 11, 12, 13; debian wheezy - stretch, centos6).
Download (untitled) / with headers
text/plain 650b
On 2018-10-28 12:12:08, SREZIC wrote: Show quoted text
> Two tests fail with signal 6 on Ubuntu 18.04 systems: > > Test Summary Report > ------------------- > t/zvg_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) > Non-zero wait status: 6 > t/zvxgp_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) > Non-zero wait status: 6 > > I don't see the problem on any other of smokers (freebsd 9, 10, 11, > 12, 13; debian wheezy - stretch, centos6).
I misinterpreted the osvers information. It's osvers=4.9.0, that is debian/stretch (debian 9), not Ubuntu 18.04. Investigating further if there are other dependencies (SQL::Statement? MLDBM?) required...
RT-Send-CC: garu [...] cpan.org
Download (untitled) / with headers
text/plain 1.6k
On 2018-10-28 12:23:19, SREZIC wrote: Show quoted text
> On 2018-10-28 12:12:08, SREZIC wrote:
> > Two tests fail with signal 6 on Ubuntu 18.04 systems: > > > > Test Summary Report > > ------------------- > > t/zvg_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) > > Non-zero wait status: 6 > > t/zvxgp_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) > > Non-zero wait status: 6 > > > > I don't see the problem on any other of smokers (freebsd 9, 10, 11, > > 12, 13; debian wheezy - stretch, centos6).
> > I misinterpreted the osvers information. It's osvers=4.9.0, that is > debian/stretch (debian 9), not Ubuntu 18.04. > > Investigating further if there are other dependencies (SQL::Statement? > MLDBM?) required...
The problem is caused by the problematic Clone-0.40 release. See below for a Dockerfile to reproduce the problem. The fixed Clone-0.41 is already available on CPAN.pm. So what's the best solution now? Clone-0.40 was the latest Clone release for about two days, so some users (and apparantly some of my smoker machines) might have it still installed. DBI's Makefile.PL could detect its presence, and force an upgrade. Or this task could be done by SQL-Statement, which is probably the direct user of Clone.pm. Or we assume that there are not so many users with this Clone version installed, and ignore the problem. # Save this as Dockerfile and run the next line: # docker build -t perl-test . && docker run perl-test FROM debian:stretch RUN echo "cache invalidation #20181028" RUN apt-get -y update RUN apt-get -y install perl-modules RUN apt-get -y install make gcc RUN apt-get -y install libsql-statement-perl libmldbm-perl RUN cpan GARU/Clone-0.40.tar.gz CMD cpan -t TIMB/DBI-1.641_90.tar.gz
Subject: Re: [rt.cpan.org #127501] SIGABRT in test suite (DBI-1.641_90)
Date: Mon, 29 Oct 2018 10:40:51 +0000
To: Slaven_Rezic via RT <bug-DBI [...] rt.cpan.org>
From: Tim Bunce <Tim.Bunce [...] pobox.com>
Download (untitled) / with headers
text/plain 1.2k
On Sun, Oct 28, 2018 at 12:39:44PM -0400, Slaven_Rezic via RT wrote: Show quoted text
> Queue: DBI > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=127501 > >
> > > Two tests fail with signal 6 on Ubuntu 18.04 systems: > > > > > > Test Summary Report > > > ------------------- > > > t/zvg_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) > > > Non-zero wait status: 6 > > > t/zvxgp_52dbm_complex.t (Wstat: 6 Tests: 246 Failed: 0) > > > Non-zero wait status: 6
> > The problem is caused by the problematic Clone-0.40 release. See below for a Dockerfile to reproduce the problem. The fixed Clone-0.41 is already available on CPAN.pm. > > So what's the best solution now? Clone-0.40 was the latest Clone release for about two days, so some users (and apparantly some of my smoker machines) might have it still installed. DBI's Makefile.PL could detect its presence, and force an upgrade. Or this task could be done by SQL-Statement, which is probably the direct user of Clone.pm. Or we assume that there are not so many users with this Clone version installed, and ignore the problem.
I'll take the path of least resistance, and effort, by ignoring it. Thank you Slaven for your thorough testing and prompt investigation! Much appreciated. Tim.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.