Skip Menu |
 

This queue is for tickets about the Net-LastFM CPAN distribution.

Report information
The Basics
Id: 127446
Status: open
Priority: 0/
Queue: Net-LastFM

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.36
Fixed in: (no value)



Subject: t/pod_coverage.t fails
Download (untitled) / with headers
text/plain 323b
t/pod_coverage.t fails: # Failed test 'Pod coverage on Net::LastFM' # at /usr/perl5.24.4p/lib/site_perl/5.24.4/Test/Pod/Coverage.pm line 133. # Net::LastFM: requiring 'Net::LastFM' failed # Looks like you failed 1 test of 1. t/pod_coverage.t ......... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests
Download (untitled) / with headers
text/plain 564b
On 2018-10-25 06:45:02, SREZIC wrote: Show quoted text
> t/pod_coverage.t fails: > > # Failed test 'Pod coverage on Net::LastFM' > # at /usr/perl5.24.4p/lib/site_perl/5.24.4/Test/Pod/Coverage.pm line 133. > # Net::LastFM: requiring 'Net::LastFM' failed > # Looks like you failed 1 test of 1. > t/pod_coverage.t ......... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests
And maybe the log line before this is also interesting: Variable "$VERSION" is not imported at /home/cpansand/.cpan/build/2018102512/Net-LastFM-0.36-3/blib/lib/Net/LastFM.pm line 28.
Download (untitled) / with headers
text/plain 1014b
On 2018-10-25 03:45:02, SREZIC wrote: Show quoted text
> t/pod_coverage.t fails: > > # Failed test 'Pod coverage on Net::LastFM' > # at /usr/perl5.24.4p/lib/site_perl/5.24.4/Test/Pod/Coverage.pm line 133. > # Net::LastFM: requiring 'Net::LastFM' failed > # Looks like you failed 1 test of 1. > t/pod_coverage.t ......... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests
While this test failure is indeed an issue that should be corrected, please don't allow pod, critic, coverage or kwalitee tests to run for normal user installs, as they make the installation fail unnecessarily when newer versions of the tester module introduces errors that you cannot anticipate. Also spelling tests are dependent on what dictionaries are installed locally, and critic tests use all plugins that are installed, neither of which can be predicted in advance. Either move these tests to xt/, or guard them with: plan skip_all => "These tests are for authors only!" unless $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING};


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.