Skip Menu |
 

This queue is for tickets about the RT-Extension-CommandByMail CPAN distribution.

Report information
The Basics
Id: 127421
Status: rejected
Priority: 0/
Queue: RT-Extension-CommandByMail

People
Owner: Nobody in particular
Requestors: ray [...] ksu.edu
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: PERL INC issue
Date: Mon, 22 Oct 2018 07:51:55 -0500
To: <bug-RT-Extension-CommandByMail [...] rt.cpan.org>
From: Raymond Clotfelter <ray [...] ksu.edu>
Download (untitled) / with headers
text/plain 1.3k
I'm hoping that this is simply a bug with my RT installation and not with this module, but I'm not a perl expert and cannot figure out how to change the include path for RT. Once I've installed CommandByMail and restart apache2, I get this error in my rt.log: [error]: Couldn't load RT::Interface::Email::Action::CommandByMail: Can't locate RT/Interface/Email/Action/CommandByMail.pm in @INC (you may need to install the RT::Interface::Email::Action::CommandByMail module) (@INC contains: /usr/local/share/request-tracker4/lib /usr/local/share/request-tracker4/plugins/RT-Extension-MandatoryFields/lib /usr/share/request-tracker4/lib /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.2 /usr/local/share/perl/5.26.2 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /etc/apache2) at /usr/share/request-tracker4/lib/RT/Interface/Email.pm line 290, <DATA> line 755. (/usr/share/request-tracker4/lib/RT/Interface/Email.pm:290) I'm on RT 4.4.3, using CommandByMail 3.0, I've tried both the CPAN install and direct download. Both are giving me this same error. I think its odd that the MandatoryFields extension is explicitly in my path, but it does work. Perhaps it somehow corrupted my path during its install? I don't know. Any advice is welcome. -- ray Raymond Clotfelter
Download (untitled) / with headers
text/plain 1024b
On 2018-10-22T08:52:53-04:00, ray@ksu.edu wrote: Show quoted text
> I'm hoping that this is simply a bug with my RT installation and not with > this module, but I'm not a perl expert and cannot figure out how to change > the include path for RT. Once I've installed CommandByMail and restart > apache2
How did you install it? I suspect you did not follow the instructions in the README. Specifically you likely missed the addition of: Plugin('RT::Extension::CommandByMail'); ...to your RT_SiteConfig.pm. Show quoted text
> I think its odd that the MandatoryFields extension is explicitly in my > path, but it does work. Perhaps it somehow corrupted my path during its > install?
Nope -- that's expected, actually, based on how RT's plugin system works. That CommandByMail does _not_ show up in there implies it's not enabled as a plugin correctly. You'll possibly find the forums, at https://forum.bestpractical.com/ , to be a helpful resource. If my suspicions above aren't correct, and the forums are no help, please re-open this issue. - Alex
Subject: Re: [rt.cpan.org #127421] PERL INC issue
Date: Tue, 23 Oct 2018 07:04:30 -0500
To: <bug-RT-Extension-CommandByMail [...] rt.cpan.org>
From: Raymond Clotfelter <ray [...] ksu.edu>
Download (untitled) / with headers
text/plain 1.7k
Sorry, I should have included the RT_SiteConfig.d file: Plugin('RT::Extension::CommandByMail'); #Set(@MailPlugins, qw(Auth::MailFrom Filter::TakeAction)); Set(@MailPlugins, qw(Auth::MailFrom Action::CommandByMail)); I did read the README. I also ensured that the 4.4 patch was in place, it already was, I'm guessing the Debian RT maintainers did that for me already since it was already in place. I've tried the the TakeAction line commented out and not commented out, I get the same error in my rt.log file. -- ray Raymond Clotfelter On Tue, Oct 23, 2018 at 2:09 AM Alex Vandiver via RT < bug-RT-Extension-CommandByMail@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=127421 > > > On 2018-10-22T08:52:53-04:00, ray@ksu.edu wrote:
> > I'm hoping that this is simply a bug with my RT installation and not with > > this module, but I'm not a perl expert and cannot figure out how to
> change
> > the include path for RT. Once I've installed CommandByMail and restart > > apache2
> > How did you install it? I suspect you did not follow the instructions in > the README. Specifically you likely missed the addition of: > Plugin('RT::Extension::CommandByMail'); > ...to your RT_SiteConfig.pm. >
> > I think its odd that the MandatoryFields extension is explicitly in my > > path, but it does work. Perhaps it somehow corrupted my path during its > > install?
> > Nope -- that's expected, actually, based on how RT's plugin system works. > That CommandByMail does _not_ show up in there implies it's not enabled as > a plugin correctly. > > You'll possibly find the forums, at https://forum.bestpractical.com/ , to > be a helpful resource. If my suspicions above aren't correct, and the > forums are no help, please re-open this issue. > - Alex >
Subject: Re: [rt.cpan.org #127421] PERL INC issue
Date: Tue, 23 Oct 2018 07:08:10 -0500
To: <bug-RT-Extension-CommandByMail [...] rt.cpan.org>
From: Raymond Clotfelter <ray [...] ksu.edu>
Download (untitled) / with headers
text/plain 2.2k
Wow, my reporting skills suck. I should also mention that it was working fine in version 4.0 and only stopped working when I upgraded to 4.4. I followed the webpage so it would work on 4.4, or so I thought. But it has not worked for me since the upgrade. -- ray Raymond Clotfelter, IT Director College of Engineering, Kansas State University ray@ksu.edu (785) 532-3017 0012 Seaton Hall 920 N. 17th St. On Tue, Oct 23, 2018 at 7:04 AM Raymond Clotfelter <ray@ksu.edu> wrote: Show quoted text
> Sorry, I should have included the RT_SiteConfig.d file: > > Plugin('RT::Extension::CommandByMail'); > #Set(@MailPlugins, qw(Auth::MailFrom Filter::TakeAction)); > Set(@MailPlugins, qw(Auth::MailFrom Action::CommandByMail)); > > I did read the README. I also ensured that the 4.4 patch was in place, it > already was, I'm guessing the Debian RT maintainers did that for me already > since it was already in place. > > I've tried the the TakeAction line commented out and not commented out, I > get the same error in my rt.log file. > > -- ray > > Raymond Clotfelter > > On Tue, Oct 23, 2018 at 2:09 AM Alex Vandiver via RT < > bug-RT-Extension-CommandByMail@rt.cpan.org> wrote: >
>> <URL: https://rt.cpan.org/Ticket/Display.html?id=127421 > >> >> On 2018-10-22T08:52:53-04:00, ray@ksu.edu wrote:
>> > I'm hoping that this is simply a bug with my RT installation and not
>> with
>> > this module, but I'm not a perl expert and cannot figure out how to
>> change
>> > the include path for RT. Once I've installed CommandByMail and restart >> > apache2
>> >> How did you install it? I suspect you did not follow the instructions in >> the README. Specifically you likely missed the addition of: >> Plugin('RT::Extension::CommandByMail'); >> ...to your RT_SiteConfig.pm. >>
>> > I think its odd that the MandatoryFields extension is explicitly in my >> > path, but it does work. Perhaps it somehow corrupted my path during its >> > install?
>> >> Nope -- that's expected, actually, based on how RT's plugin system >> works. That CommandByMail does _not_ show up in there implies it's not >> enabled as a plugin correctly. >> >> You'll possibly find the forums, at https://forum.bestpractical.com/ , >> to be a helpful resource. If my suspicions above aren't correct, and the >> forums are no help, please re-open this issue. >> - Alex >>
>


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.