Skip Menu |
 

This queue is for tickets about the GD CPAN distribution.

Report information
The Basics
Id: 127049
Status: stalled
Priority: 0/
Queue: GD

People
Owner: RURBAN [...] cpan.org
Requestors: ppisar [...] redhat.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.69
Fixed in: (no value)



Subject: gdlib-config: warning: this script is deprecated; please use the pkg-config file instead
Download (untitled) / with headers
text/plain 311b
When building GD against libgd 2.2.5, gdlib-config reports this warning: gdlib-config: warning: this script is deprecated; please use the pkg-config file instead. I can see Makefile.PL prefers gdlib-config and falls back to pkg-config. I think it would be better to reverse the order and try pkg-config first.
Download (untitled) / with headers
text/plain 778b
On Thu Sep 06 10:46:32 2018, ppisar wrote: Show quoted text
> When building GD against libgd 2.2.5, gdlib-config reports this > warning: > > gdlib-config: warning: this script is deprecated; please use the pkg- > config file instead. > > I can see Makefile.PL prefers gdlib-config and falls back to pkg- > config. I think it would be better to reverse the order and try pkg- > config first.
Sure. But in fact we first try $prefix/lib/pkgconfig/gdlib.pc for the prefix given with the --lib_gd_path option or defaulting to /usr. Only when gdlib.pc is not found there, we call gdlib-config, and if that is not found we search for gdlib.pc via ExtUtils::PkgConfig. I'll rather add another path to the .pc than requiring another external lib. What is the path of your gdlib.pc? -- Reini Urban
Subject: Re: [rt.cpan.org #127049] gdlib-config: warning: this script is deprecated; please use the pkg-config file instead
Date: Thu, 6 Sep 2018 17:07:56 +0200
To: Reini Urban via RT <bug-GD [...] rt.cpan.org>
From: Petr Pisar <ppisar [...] redhat.com>
Download (untitled) / with headers
text/plain 995b
On Thu, Sep 06, 2018 at 11:01:05AM -0400, Reini Urban via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=127049 > > > On Thu Sep 06 10:46:32 2018, ppisar wrote:
> > When building GD against libgd 2.2.5, gdlib-config reports this > > warning: > > > > gdlib-config: warning: this script is deprecated; please use the pkg- > > config file instead. > > > > I can see Makefile.PL prefers gdlib-config and falls back to pkg- > > config. I think it would be better to reverse the order and try pkg- > > config first.
> > Sure. > But in fact we first try $prefix/lib/pkgconfig/gdlib.pc for the prefix given with the > --lib_gd_path option or defaulting to /usr. > > Only when gdlib.pc is not found there, we call gdlib-config, and if that is not found > we search for gdlib.pc via ExtUtils::PkgConfig. I'll rather add another path to the .pc than requiring another external lib. > > What is the path of your gdlib.pc?
I see. It's /usr/lib64/pkgconfig/gdlib.pc in my case. -- Petr
Download signature.asc
application/pgp-signature 228b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 312b
Another problem with the .pc: features is not defined there, only in the gdlib-config. So I rather stay with this deprecation warning, and only fallback to the .pc if is gone. E.g. there could be no GD_GIF support without me even knowing, and don't really want to probe the library for symbols. -- Reini Urban
Download (untitled) / with headers
text/plain 168b
I added this feature in the rt127049-pkg-config branch, but it's worse than master, as explained above. We'll reconsider when gdlib-config is removed. -- Reini Urban


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.