Skip Menu |
 

This queue is for tickets about the Net-SSLeay CPAN distribution.

Report information
The Basics
Id: 126989
Status: resolved
Priority: 0/
Queue: Net-SSLeay

People
Owner: RADIATOR [...] cpan.org
Requestors: dam [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 1.86_06

Attachments


From: dam [...] cpan.org
Subject: [PATCH] adjust minimum openssl version for set_num_tickets() etc
Download (untitled) / with headers
text/plain 577b
In Debian we are currently applying the following patch to Net-SSLeay. We thought you might be interested in it too. Description: adjust minimum openssl version for set_num_tickets() support SSL_CTX_set_num_tickets() & co are available since 0x10101009 . Requires Adapt-to-OpenSSL-1.1.1.patch Author: Damyan Ivanov <dmn@debian.org> The patch is tracked in our Git repository at https://salsa.debian.org/perl-team/modules/packages/libnet-ssleay-perl/raw/master/debian/patches/set_num_tickets-min-version.patch Thanks for considering, Damyan Ivanov, Debian Perl Group
Here's the patch.

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 1.3k
On Wed 29.elokuu 2018 16:33:18, DAM wrote: Show quoted text
> In Debian we are currently applying the following patch to > Net-SSLeay. > We thought you might be interested in it too. > > Description: adjust minimum openssl version for set_num_tickets() > support > SSL_CTX_set_num_tickets() & co are available since 0x10101009
Thanks! SSL_CTX_set_num_tickets() is now in the github master branch. The actual patch was a bit different: #if OPENSSL_VERSION_NUMBER >= 0x10101007L && !defined(LIBRESSL_VERSION_NUMBER) Just like your patch it lower the requirement to 1.1.1-pre version, but I think it was already included with pre7. SSLeay.xs also aims to work with LibreSSL and that's why it would be good to have all conditional complications, such as above, be LibreSSL aware. The test in 07_sslecho.t is 'unless defined (&Net::SSLeay::CTX_set_num_tickets);' so that it is independent of the library and its version. Show quoted text
> . > Requires Adapt-to-OpenSSL-1.1.1.patch > Author: Damyan Ivanov <dmn@debian.org> > > > The patch is tracked in our Git repository at > https://salsa.debian.org/perl-team/modules/packages/libnet-ssleay- > perl/raw/master/debian/patches/set_num_tickets-min-version.patch
Looks like a lot of patches you have have been recently updated but please keep us posted if there's something that has not been yet addressed with a RT ticket or github issue. -- Heikki


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.