Skip Menu |
 

This queue is for tickets about the Dist-Zilla-Plugin-EnsureLatestPerl CPAN distribution.

Report information
The Basics
Id: 125632
Status: resolved
Priority: 0/
Queue: Dist-Zilla-Plugin-EnsureLatestPerl

People
Owner: Nobody in particular
Requestors: skaji [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.008



Subject: Cannot install Dist::Zilla::Plugin::EnsureLatestPerl because of Module::CoreList
Download (untitled) / with headers
text/plain 713b
Because Module::CoreList has not been released for two months, we cannot install Dist::Zilla::Plugin::EnsureLatestPerl. ``` ❯ cpanm -n --reinstall Dist::Zilla::Plugin::EnsureLatestPerl --> Working on Dist::Zilla::Plugin::EnsureLatestPerl Fetching http://www.cpan.org/authors/id/E/ET/ETHER/Dist-Zilla-Plugin-EnsureLatestPerl-0.007.tar.gz ... OK Configuring Dist-Zilla-Plugin-EnsureLatestPerl-0.007 ... OK ==> Found dependencies: Module::CoreList Found Module::CoreList 5.20180420 which doesn't satisfy 5.20180421. ! Installing the dependencies failed: Installed version (5.20180420) of Module::CoreList is not in range '5.20180421' ! Bailing out the installation for Dist-Zilla-Plugin-EnsureLatestPerl-0.007. ```
Download (untitled) / with headers
text/plain 496b
On 2018-06-19 06:46:06, SKAJI wrote: Show quoted text
> Because Module::CoreList has not been released for two months, > we cannot install Dist::Zilla::Plugin::EnsureLatestPerl.
How serious is this problem for you? perl 5.28.0 should be released very soon, so in the meantime, you should be able to --force this installation. I am hoping we would never have this problem again. But if it is breaking some of your important infrastructure, I will release an update today to soften the version requirement a bit.
Download (untitled) / with headers
text/plain 1.1k
@ETHER Thanks for your reply. Show quoted text
> How serious is this problem for you?
I regularly install 700+ modules with a clean perl environment, and Dist::Zilla::Plugin::EnsureLatestPerl is one of them. So for me, this is a problem. But if you think this should be fixed very soon and do not think we need to fix it now, that’s fine and I'm going to find some workaround. Show quoted text
> you should be able to --force this installation
"--force" means "Force install modules even when testing failed" according to "perldoc cpanm". Here, because prereqs are not met, "--force" does not help. On 2018-06-19T11:34:28-04:00, ETHER wrote: Show quoted text
> On 2018-06-19 06:46:06, SKAJI wrote:
> > Because Module::CoreList has not been released for two months, > > we cannot install Dist::Zilla::Plugin::EnsureLatestPerl.
> > How serious is this problem for you? perl 5.28.0 should be released > very soon, so in the meantime, you should be able to --force this > installation. I am hoping we would never have this problem again. But > if it is breaking some of your important infrastructure, I will > release an update today to soften the version requirement a bit.
Download (untitled) / with headers
text/plain 583b
On 2018-06-19 14:57:18, SKAJI wrote: Show quoted text
> > you should be able to --force this installation
> > "--force" means "Force install modules even when testing failed" > according to "perldoc cpanm". > Here, because prereqs are not met, "--force" does not help.
Right, I forgot there was a prereq as well as just a check in the tests! Show quoted text
> I regularly install 700+ modules with a clean perl environment, > and Dist::Zilla::Plugin::EnsureLatestPerl is one of them. > So for me, this is a problem.
I checked with p5p and 5.28.0 might be a few days off still... so I have released version 0.008.
Download (untitled) / with headers
text/plain 669b
Thanks! On 2018-06-19T19:06:28-04:00, ETHER wrote: Show quoted text
> On 2018-06-19 14:57:18, SKAJI wrote:
> > > you should be able to --force this installation
> > > > "--force" means "Force install modules even when testing failed" > > according to "perldoc cpanm". > > Here, because prereqs are not met, "--force" does not help.
> > Right, I forgot there was a prereq as well as just a check in the > tests! >
> > I regularly install 700+ modules with a clean perl environment, > > and Dist::Zilla::Plugin::EnsureLatestPerl is one of them. > > So for me, this is a problem.
> > I checked with p5p and 5.28.0 might be a few days off still... so I > have released version 0.008.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.