Skip Menu |
 

This queue is for tickets about the XML-GrammarBase CPAN distribution.

Report information
The Basics
Id: 125264
Status: resolved
Priority: 0/
Queue: XML-GrammarBase

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.2.4
Fixed in: (no value)



Subject: Undeclared dependency MooX::late
Download (untitled) / with headers
text/plain 609b
... at least the test suite fails if MooX::late is not installed: Output from './Build test': # Failed test 'XML/GrammarBase/Role/DataDir.pm loaded ok' # at t/00-compile.t line 47. # got: '512' # expected: '0' Can't locate MooX/late.pm in @INC (you may need to install the MooX::late module) (@INC contains: ... .) at /usr/perl5.26.2p/lib/site_perl/5.26.2/Module/Runtime.pm line 314. BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2018050218/XML-GrammarBase-0.2.4-0/blib/lib/XML/GrammarBase/Role/DataDir.pm line 7. Compilation failed in require at -e line 1. ... etc. ...
Download (untitled) / with headers
text/plain 709b
On 2018-05-02 15:36:49, SREZIC wrote: Show quoted text
> ... at least the test suite fails if MooX::late is not installed: > > Output from './Build test': > > > # Failed test 'XML/GrammarBase/Role/DataDir.pm loaded ok' > # at t/00-compile.t line 47. > # got: '512' > # expected: '0' > Can't locate MooX/late.pm in @INC (you may need to install the > MooX::late module) (@INC contains: ... .) at > /usr/perl5.26.2p/lib/site_perl/5.26.2/Module/Runtime.pm line 314. > BEGIN failed--compilation aborted at > /home/cpansand/.cpan/build/2018050218/XML-GrammarBase-0.2.4- > 0/blib/lib/XML/GrammarBase/Role/DataDir.pm line 7. > Compilation failed in require at -e line 1. > ... etc. ...
Happens also with 0.2.5.
Download (untitled) / with headers
text/plain 821b
Fixed in 0.2.6, thanks. On Wed May 02 17:02:13 2018, SREZIC wrote: Show quoted text
> On 2018-05-02 15:36:49, SREZIC wrote:
> > ... at least the test suite fails if MooX::late is not installed: > > > > Output from './Build test': > > > > > > # Failed test 'XML/GrammarBase/Role/DataDir.pm loaded ok' > > # at t/00-compile.t line 47. > > # got: '512' > > # expected: '0' > > Can't locate MooX/late.pm in @INC (you may need to install the > > MooX::late module) (@INC contains: ... .) at > > /usr/perl5.26.2p/lib/site_perl/5.26.2/Module/Runtime.pm line 314. > > BEGIN failed--compilation aborted at > > /home/cpansand/.cpan/build/2018050218/XML-GrammarBase-0.2.4- > > 0/blib/lib/XML/GrammarBase/Role/DataDir.pm line 7. > > Compilation failed in require at -e line 1. > > ... etc. ...
> > Happens also with 0.2.5. >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.