Skip Menu |
 

This queue is for tickets about the IO-Async-SSL CPAN distribution.

Report information
The Basics
Id: 125220
Status: resolved
Priority: 0/
Queue: IO-Async-SSL

People
Owner: Nobody in particular
Requestors: richard [...] matrix.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.22



Subject: tests fail when run against IO::Socket::SSL <= 2.002
Date: Fri, 27 Apr 2018 00:57:17 +0100
To: bug-IO-Async-SSL [...] rt.cpan.org
From: Richard van der Hoff <richard [...] matrix.org>
Download (untitled) / with headers
text/plain 527b
Given that this was fixed in IO::Socket::SSL 3.5 years ago, you may consider this somewhat irrelevant, but if so you may like to bump the version specifier on the 'use' directive. It's been quite a job to figure out exactly what I had to upgrade to fix my install error. Anyway, the "erroneous SSL_upgrade" test in t/01upgrade.t fails, apparently because IO::Socket::SSL used to swallow errors when the cert wasn't found, as per https://github.com/noxxi/p5-io-socket-ssl/commit/a09f29f423859565bc0384dcfbbc75811d9e4e4a.
Download (untitled) / with headers
text/plain 444b
On Thu Apr 26 20:07:28 2018, richard@matrix.org wrote: Show quoted text
> Given that this was fixed in IO::Socket::SSL 3.5 years ago, you may > consider this somewhat irrelevant, but if so you may like to bump the > version specifier on the 'use' directive. It's been quite a job to > figure out exactly what I had to upgrade to fix my install error.
Oops. I bumped that and released it some time ago and just forgot to close this bug. Fixed. -- Paul Evans


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.