Skip Menu |
 

This queue is for tickets about the Authen-Passphrase CPAN distribution.

Report information
The Basics
Id: 125064
Status: new
Priority: 0/
Queue: Authen-Passphrase

People
Owner: Nobody in particular
Requestors: abraxxa [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.008
Fixed in: (no value)



Subject: Add API to use additional modules in the Authen::Passphrase namespace
Download (untitled) / with headers
text/plain 402b
I'm in the process of writing Authen::Passphrase::Argon2 (https://github.com/abraxxa/Authen-Passphrase-Argon2) and it fails to get used by DBIx::Class::InflateColumn::Authen::Passphrase because there is no way to extend/register crypt_scheme_handler and rfc2307_scheme_handler. As they aren't class but instance variables monkeypatching isn't an option either. Please suggest an API to do so, thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.