Skip Menu |
 

This queue is for tickets about the Fuse CPAN distribution.

Report information
The Basics
Id: 125020
Status: new
Priority: 0/
Queue: Fuse

People
Owner: Nobody in particular
Requestors: jkeenan [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Test failures on FreeBSD-11.0 with perl-5.27.10
Download (untitled) / with headers
text/plain 763b
In preparation for the upcoming release of perl-5.28.0, I have been testing a selected subset of CPAN distributions against development release perl-5.27.10 on FreeBSD-11.0, using 'cpanm' as the installer. Today I attempted to install Fuse on this platform. According to https://en.wikipedia.org/wiki/Filesystem_in_Userspace, Fuse is supported on FreeBSD, and I was able to say: ##### pkg install fusefs-libs ##### ... successfully. I got no build-time warnings or exceptions, but did get test failures. Please find attached a digest of the output from the cpanm 'build.log'. Also find attached the relevant 'perl -V' information. Do you have any suggestions re how I can get this distribution to install on this platform? Thank you very much. Jim Keenan
Subject: DPATES.Fuse-0.16.log.txt
{ author => "DPATES", dist => "Fuse", distname => "Fuse-0.16", distversion => 0.16, grade => "FAIL", prereqs => undef, test_output => [ "Building and testing Fuse-0.16", "cp Fuse.pm blib/lib/Fuse.pm", "AutoSplitting blib/lib/Fuse.pm (blib/lib/auto/Fuse)", "Running Mkbootstrap for Fuse ()", "chmod 644 \"Fuse.bs\"", "\"/usr/home/jkeenan/prep528/testing/perl-5.27.10/bin/perl\" -MExtUtils::Command::MM -e 'cp_nonempty' -- Fuse.bs blib/arch/auto/Fuse/Fuse.bs 644", "\"/usr/home/jkeenan/prep528/testing/perl-5.27.10/bin/perl\" \"/home/jkeenan/prep528/testing/perl-5.27.10/lib/5.27.10/ExtUtils/xsubpp\" -typemap '/home/jkeenan/prep528/testing/perl-5.27.10/lib/5.27.10/ExtUtils/typemap' Fuse.xs > Fuse.xsc", "mv Fuse.xsc Fuse.c", "cc -c -I/usr/local/include/fuse -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2 -g -ggdb -DVERSION=\\\"0.16\\\" -DXS_VERSION=\\\"0.16\\\" -DPIC -fPIC \"-I/home/jkeenan/prep528/testing/perl-5.27.10/lib/5.27.10/amd64-freebsd-thread-multi/CORE\" -Wall -DFUSE_USE_VERSION=26 -D_FILE_OFFSET_BITS=64 -pthread -DPERL_HAS_64BITINT -DFUSE_FOUND_MAJOR_VER=2 -DFUSE_FOUND_MINOR_VER=9 -DFUSE_FOUND_MICRO_VER=5 Fuse.c", "rm -f blib/arch/auto/Fuse/Fuse.so", "LD_RUN_PATH=\"/usr/local/lib\" cc -shared -L/usr/local/lib -fstack-protector-strong Fuse.o -o blib/arch/auto/Fuse/Fuse.so -L/usr/local/lib -lfuse ", "chmod 755 blib/arch/auto/Fuse/Fuse.so", "\"/usr/home/jkeenan/prep528/testing/perl-5.27.10/bin/perl\" -MExtUtils::Command::MM -e 'cp_nonempty' -- Fuse.bs blib/arch/auto/Fuse/Fuse.bs 644", "PERL_DL_NONLAZY=1 \"/usr/home/jkeenan/prep528/testing/perl-5.27.10/bin/perl\" \"-Iblib/lib\" \"-Iblib/arch\" test.pl", "# mounting examples/loopback.pl to /tmp/fusemnt-jkeenan", "# Mounted in 5.1 secs", "", "# Failed test 'mount succeeded'", "# at test/s/mount.t line 34.", "cat: /usr/home/jkeenan/prep528/testing/perl-5.27.10/.cpanm/work/1522931957.2831/Fuse-0.16/test/s/mounted.pid: No such file or directory", "# Looks like you failed 1 test of 3.", "test/s/mount.t ... ", "Dubious, test returned 1 (wstat 256, 0x100)", "Failed 1/3 subtests ", "not properly mounted", "Compilation failed in require at test/chmod.t line 2.", "BEGIN failed--compilation aborted at test/chmod.t line 2.", "test/chmod.t ..... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/chown.t line 2.", "BEGIN failed--compilation aborted at test/chown.t line 2.", "test/chown.t ..... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/getattr.t line 2.", "BEGIN failed--compilation aborted at test/getattr.t line 2.", "test/getattr.t ... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/getdir.t line 2.", "BEGIN failed--compilation aborted at test/getdir.t line 2.", "test/getdir.t .... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/link.t line 2.", "BEGIN failed--compilation aborted at test/link.t line 2.", "test/link.t ...... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/mkdir.t line 2.", "BEGIN failed--compilation aborted at test/mkdir.t line 2.", "test/mkdir.t ..... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/mknod.t line 2.", "BEGIN failed--compilation aborted at test/mknod.t line 2.", "test/mknod.t ..... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/open.t line 2.", "BEGIN failed--compilation aborted at test/open.t line 2.", "test/open.t ...... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "test/pod.t ....... ok", "not properly mounted", "Compilation failed in require at test/read.t line 2.", "BEGIN failed--compilation aborted at test/read.t line 2.", "test/read.t ...... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/readlink.t line 2.", "BEGIN failed--compilation aborted at test/readlink.t line 2.", "test/readlink.t .. ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/rename.t line 2.", "BEGIN failed--compilation aborted at test/rename.t line 2.", "test/rename.t .... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/rmdir.t line 2.", "BEGIN failed--compilation aborted at test/rmdir.t line 2.", "test/rmdir.t ..... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/statfs.t line 2.", "BEGIN failed--compilation aborted at test/statfs.t line 2.", "test/statfs.t .... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/symlink.t line 2.", "BEGIN failed--compilation aborted at test/symlink.t line 2.", "test/symlink.t ... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/truncate.t line 2.", "BEGIN failed--compilation aborted at test/truncate.t line 2.", "test/truncate.t .. ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/unlink.t line 2.", "BEGIN failed--compilation aborted at test/unlink.t line 2.", "test/unlink.t .... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/utime.t line 2.", "BEGIN failed--compilation aborted at test/utime.t line 2.", "test/utime.t ..... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "not properly mounted", "Compilation failed in require at test/write.t line 2.", "BEGIN failed--compilation aborted at test/write.t line 2.", "test/write.t ..... ", "Dubious, test returned 2 (wstat 512, 0x200)", "No subtests run ", "Can't exec \"fusermount\": No such file or directory at test/s/umount.t line 6.", "umount: /tmp/fusemnt-jkeenan: not a file system root directory", "", "# Failed test 'unmount'", "# at test/s/umount.t line 10.", "# Looks like you failed 1 test of 1.", "test/s/umount.t .. ", "Dubious, test returned 1 (wstat 256, 0x100)", "Failed 1/1 subtests ", "", "Test Summary Report", "-------------------", "test/s/mount.t (Wstat: 256 Tests: 3 Failed: 1)", " Failed test: 3", " Non-zero exit status: 1", "test/chmod.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/chown.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/getattr.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/getdir.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/link.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/mkdir.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/mknod.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/open.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/read.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/readlink.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/rename.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/rmdir.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/statfs.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/symlink.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/truncate.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/unlink.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/utime.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/write.t (Wstat: 512 Tests: 0 Failed: 0)", " Non-zero exit status: 2", " Parse errors: No plan found in TAP output", "test/s/umount.t (Wstat: 256 Tests: 1 Failed: 1)", " Failed test: 1", " Non-zero exit status: 1", "Files=21, Tests=5, 6 wallclock secs ( 0.05 usr 0.04 sys + 0.48 cusr 0.22 csys = 0.78 CPU)", "Result: FAIL", ], via => "App::cpanminus::reporter 0.17 (1.7043)", }
Subject: freebsd-11.0.perl-5.27.10_V.txt
Summary of my perl5 (revision 5 version 27 subversion 10) configuration: Platform: osname=freebsd osvers=11.0-release-p1 archname=amd64-freebsd-thread-multi uname='freebsd kid51-freebsd-11-install-3 11.0-release-p1 freebsd 11.0-release-p1 #0 r306420: thu sep 29 01:43:23 utc 2016 root@releng2.nyi.freebsd.org:usrobjusrsrcsysgeneric amd64 ' config_args='-des -Dusedevel -Duseithreads -Doptimize=-O2 -pipe -fstack-protector -fno-strict-aliasing -Uversiononly -Dman1dir=none -Dman3dir=none -Dprefix=/home/jkeenan/prep528/testing/perl-5.27.10' hint=recommended useposix=true d_sigaction=define useithreads=define usemultiplicity=define use64bitint=define use64bitall=define uselongdouble=undef usemymalloc=n default_inc_excludes_dot=define bincompat5005=undef Compiler: cc='cc' ccflags ='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2' optimize='-O2 -pipe -fstack-protector -fno-strict-aliasing' cppflags='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include' ccversion='' gccversion='4.2.1 Compatible FreeBSD Clang 3.8.0 (tags/RELEASE_380/final 262564)' gccosandvers='' intsize=4 longsize=8 ptrsize=8 doublesize=8 byteorder=12345678 doublekind=3 d_longlong=define longlongsize=8 d_longdbl=define longdblsize=16 longdblkind=3 ivtype='long' ivsize=8 nvtype='double' nvsize=8 Off_t='off_t' lseeksize=8 alignbytes=8 prototype=define Linker and Libraries: ld='cc' ldflags ='-pthread -Wl,-E -fstack-protector-strong -L/usr/local/lib' libpth=/usr/lib /usr/local/lib /usr/bin/../lib/clang/3.8.0/lib /usr/lib libs=-lpthread -lgdbm -lm -lcrypt -lutil perllibs=-lpthread -lm -lcrypt -lutil libc= so=so useshrplib=false libperl=libperl.a gnulibc_version='' Dynamic Linking: dlsrc=dl_dlopen.xs dlext=so d_dlsymun=undef ccdlflags=' ' cccdlflags='-DPIC -fPIC' lddlflags='-shared -L/usr/local/lib -fstack-protector-strong' Characteristics of this binary (from libperl): Compile-time options: HAS_TIMES MULTIPLICITY PERLIO_LAYERS PERL_COPY_ON_WRITE PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP PERL_OP_PARENT PERL_PRESERVE_IVUV PERL_USE_DEVEL USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_LOCALE USE_LOCALE_COLLATE USE_LOCALE_CTYPE USE_LOCALE_NUMERIC USE_LOCALE_TIME USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API Built under freebsd Compiled at Mar 21 2018 12:59:59 %ENV: PERL2DIR="/home/jkeenan/gitwork/perl2" PERL_WORKDIR="/home/jkeenan/gitwork/perl" @INC: lib/5.27.10/amd64-freebsd-thread-multi lib/5.27.10 lib /home/jkeenan/prep528/testing/perl-5.27.10/lib/site_perl/5.27.10/amd64-freebsd-thread-multi /home/jkeenan/prep528/testing/perl-5.27.10/lib/site_perl/5.27.10 /home/jkeenan/prep528/testing/perl-5.27.10/lib/5.27.10/amd64-freebsd-thread-multi /home/jkeenan/prep528/testing/perl-5.27.10/lib/5.27.10


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.