Skip Menu |
 

This queue is for tickets about the Filter-Crypto CPAN distribution.

Report information
The Basics
Id: 124967
Status: open
Priority: 0/
Queue: Filter-Crypto

People
Owner: shay [...] cpan.org
Requestors: petercj [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 2.07
Fixed in: (no value)



Subject: failing build with newer GCC versions
Download (untitled) / with headers
text/plain 1019b
see perlmonks thread https://perlmonks.org/?node_id=1211979 for discussion. The Filter::Crytpo CPAN Testers matrix (http://matrix.cpantesters.org/?dist=Filter-Crypto+2.07) show similar results on any mswin with perl newer than 5.25.10. Looking at the difference between 5.25.10 passing (http://www.cpantesters.org/cpan/report/10ec89b6-6c05-1014-979c-fa6c0e81c406) and 5.26.0 failing (http://www.cpantesters.org/cpan/report/a22c4806-9721-11e7-8c1c-eb41070190a6), the thing that jumps out at me is the change from gcc 4.9.2 jumping to gcc 7.1.0. This 5.26.1 linux fail (http://www.cpantesters.org/cpan/report/2cd46618-020d-11e8-88a0-8d67e75bcb2f) uses gcc 6.3.0 and gives the same error messages during compilation, whereas this 5.26.1 linux pass (http://www.cpantesters.org/cpan/report/ad1b2ee0-0034-11e8-99c9-b6f8919c57b8) uses gcc 5.4.0. This all seems to point to the version of gcc. If gcc version is 4.9.2 or 5.4.0, it compiles; if version is 6.3.0 or 7.1.0, it does not compile, and the module doesn't install.
Download (untitled) / with headers
text/plain 116b
Same error as https://rt.cpan.org/Public/Bug/Display.html?id=123204, so probably will be resolved on next release...


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.