This queue is for tickets about the XML-XSH2 CPAN distribution.

Report information
The Basics
Id:
124931
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
SREZIC [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
2.1.26
Fixed in:
2.1.27



Subject: '.' is no longer in @INC
The build fails for newer perls if run from the command line: Output from '/usr/bin/make': "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_grammar.pl src/xsh_grammar.xml > lib/XML/XSH2/Grammar.pm "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_commands.pl src/xsh_grammar.xml > lib/XML/XSH2/Commands.pm "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_help.pl src/xsh_grammar.xml > lib/XML/XSH2/Help.pm "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_pod.pl src/xsh_grammar.xml > XSH2.pod "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_completions.pl src/xsh_grammar.xml > lib/XML/XSH2/CompletionList.pm "/opt/perl-5.26.2-RC1/bin/perl" -e "chdir q(lib/XML/XSH2); require Grammar; XML::XSH2::Grammar::compile()" Can't locate Grammar.pm in @INC (you may need to install the Grammar module) (@INC contains: /opt/perl-5.26.2-RC1/lib/site_perl/5.26.2/x86_64-linux /opt/perl-5.26.2-RC1/lib/site_perl/5.26.2 /opt/perl-5.26.2-RC1/lib/5.26.2/x86_64-linux /opt/perl-5.26.2-RC1/lib/5.26.2) at -e line 1. Makefile:1009: recipe for target 'xml' failed make: *** [xml] Error 2 Probably the chdir should be replaced by a 'use lib "lib/..."' or so.
Subject: Re: [rt.cpan.org #124931] '.' is no longer in @INC
Date: Thu, 29 Mar 2018 22:00:47 +0200 (CEST)
To: Slaven_Rezic via RT <bug-XML-XSH2@rt.cpan.org>
From: "E. Choroba" <choroba@matfyz.cz>
Thanks for the report. Can you try with 2.1.27 once it exists for you? Ch. ============================================================================== On Mon, 26 Mar 2018, Slaven_Rezic via RT wrote:
Show quoted text
>Date: Mon, 26 Mar 2018 16:47:20 -0400 >From: Slaven_Rezic via RT <bug-XML-XSH2@rt.cpan.org> >To: undisclosed-recipients: ; >Subject: [rt.cpan.org #124931] '.' is no longer in @INC > > Mon Mar 26 16:47:19 2018: Request 124931 was acted upon. > Transaction: Ticket created by SREZIC > Queue: XML-XSH2 > Subject: '.' is no longer in @INC > Broken in: 2.1.26 > Severity: (no value) > Owner: Nobody > Requestors: SREZIC@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124931 > > > > The build fails for newer perls if run from the command line: > > > Output from '/usr/bin/make': > > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_grammar.pl src/xsh_grammar.xml > lib/XML/XSH2/Grammar.pm > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_commands.pl src/xsh_grammar.xml > lib/XML/XSH2/Commands.pm > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_help.pl src/xsh_grammar.xml > lib/XML/XSH2/Help.pm > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_pod.pl src/xsh_grammar.xml > XSH2.pod > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_completions.pl src/xsh_grammar.xml > lib/XML/XSH2/CompletionList.pm > "/opt/perl-5.26.2-RC1/bin/perl" -e "chdir q(lib/XML/XSH2); require Grammar; XML::XSH2::Grammar::compile()" > Can't locate Grammar.pm in @INC (you may need to install the Grammar module) (@INC contains: /opt/perl-5.26.2-RC1/lib/site_perl/5.26.2/x86_64-linux /opt/perl-5.26.2-RC1/lib/site_perl/5.26.2 /opt/perl-5.26.2-RC1/lib/5.26.2/x86_64-linux /opt/perl-5.26.2-RC1/lib/5.26.2) at -e line 1. > Makefile:1009: recipe for target 'xml' failed > make: *** [xml] Error 2 > > > Probably the chdir should be replaced by a 'use lib "lib/..."' or so. >
On 2018-03-29 16:14:49, choroba@matfyz.cz wrote:
Show quoted text
> Thanks for the report. Can you try with 2.1.27 once it exists for you?
Seems to be fixed with 2.1.27.
Show quoted text
> Ch. > > ============================================================================== > On Mon, 26 Mar 2018, Slaven_Rezic via RT wrote:
> > Date: Mon, 26 Mar 2018 16:47:20 -0400 > > From: Slaven_Rezic via RT <bug-XML-XSH2@rt.cpan.org> > > To: undisclosed-recipients: ; > > Subject: [rt.cpan.org #124931] '.' is no longer in @INC > > > > Mon Mar 26 16:47:19 2018: Request 124931 was acted upon. > > Transaction: Ticket created by SREZIC > > Queue: XML-XSH2 > > Subject: '.' is no longer in @INC > > Broken in: 2.1.26 > > Severity: (no value) > > Owner: Nobody > > Requestors: SREZIC@cpan.org > > Status: new > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124931 > > > > > > > The build fails for newer perls if run from the command line: > > > > > > Output from '/usr/bin/make': > > > > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_grammar.pl > > src/xsh_grammar.xml > lib/XML/XSH2/Grammar.pm > > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_commands.pl > > src/xsh_grammar.xml > lib/XML/XSH2/Commands.pm > > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_help.pl src/xsh_grammar.xml
> > > lib/XML/XSH2/Help.pm
> > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_pod.pl src/xsh_grammar.xml
> > > XSH2.pod
> > "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_completions.pl > > src/xsh_grammar.xml > lib/XML/XSH2/CompletionList.pm > > "/opt/perl-5.26.2-RC1/bin/perl" -e "chdir q(lib/XML/XSH2); require > > Grammar; XML::XSH2::Grammar::compile()" > > Can't locate Grammar.pm in @INC (you may need to install the Grammar > > module) (@INC contains: /opt/perl-5.26.2- > > RC1/lib/site_perl/5.26.2/x86_64-linux /opt/perl-5.26.2- > > RC1/lib/site_perl/5.26.2 /opt/perl-5.26.2-RC1/lib/5.26.2/x86_64-linux > > /opt/perl-5.26.2-RC1/lib/5.26.2) at -e line 1. > > Makefile:1009: recipe for target 'xml' failed > > make: *** [xml] Error 2 > > > > > > Probably the chdir should be replaced by a 'use lib "lib/..."' or so. > >
Subject: Re: [rt.cpan.org #124931] '.' is no longer in @INC
Date: Sat, 31 Mar 2018 17:54:52 +0200 (CEST)
To: Slaven_Rezic via RT <bug-XML-XSH2@rt.cpan.org>
From: "E. Choroba" <choroba@matfyz.cz>
Thanks a lot. Ch. ============================================================================== On Fri, 30 Mar 2018, Slaven_Rezic via RT wrote:
Show quoted text
>Date: Fri, 30 Mar 2018 05:28:53 -0400 >From: Slaven_Rezic via RT <bug-XML-XSH2@rt.cpan.org> >To: undisclosed-recipients: ; >Subject: [rt.cpan.org #124931] '.' is no longer in @INC > > Queue: XML-XSH2 > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124931 > > > On 2018-03-29 16:14:49, choroba@matfyz.cz wrote:
>> Thanks for the report. Can you try with 2.1.27 once it exists for you?
> > Seems to be fixed with 2.1.27. >
>> Ch. >> >> ============================================================================== >> On Mon, 26 Mar 2018, Slaven_Rezic via RT wrote:
>>> Date: Mon, 26 Mar 2018 16:47:20 -0400 >>> From: Slaven_Rezic via RT <bug-XML-XSH2@rt.cpan.org> >>> To: undisclosed-recipients: ; >>> Subject: [rt.cpan.org #124931] '.' is no longer in @INC >>> >>> Mon Mar 26 16:47:19 2018: Request 124931 was acted upon. >>> Transaction: Ticket created by SREZIC >>> Queue: XML-XSH2 >>> Subject: '.' is no longer in @INC >>> Broken in: 2.1.26 >>> Severity: (no value) >>> Owner: Nobody >>> Requestors: SREZIC@cpan.org >>> Status: new >>> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124931 > >>> >>> >>> The build fails for newer perls if run from the command line: >>> >>> >>> Output from '/usr/bin/make': >>> >>> "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_grammar.pl >>> src/xsh_grammar.xml > lib/XML/XSH2/Grammar.pm >>> "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_commands.pl >>> src/xsh_grammar.xml > lib/XML/XSH2/Commands.pm >>> "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_help.pl src/xsh_grammar.xml
>>>> lib/XML/XSH2/Help.pm
>>> "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_pod.pl src/xsh_grammar.xml
>>>> XSH2.pod
>>> "/opt/perl-5.26.2-RC1/bin/perl" tools/gen_completions.pl >>> src/xsh_grammar.xml > lib/XML/XSH2/CompletionList.pm >>> "/opt/perl-5.26.2-RC1/bin/perl" -e "chdir q(lib/XML/XSH2); require >>> Grammar; XML::XSH2::Grammar::compile()" >>> Can't locate Grammar.pm in @INC (you may need to install the Grammar >>> module) (@INC contains: /opt/perl-5.26.2- >>> RC1/lib/site_perl/5.26.2/x86_64-linux /opt/perl-5.26.2- >>> RC1/lib/site_perl/5.26.2 /opt/perl-5.26.2-RC1/lib/5.26.2/x86_64-linux >>> /opt/perl-5.26.2-RC1/lib/5.26.2) at -e line 1. >>> Makefile:1009: recipe for target 'xml' failed >>> make: *** [xml] Error 2 >>> >>> >>> Probably the chdir should be replaced by a 'use lib "lib/..."' or so. >>>
>


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.