Skip Menu |
 

This queue is for tickets about the Data-Validate-Japanese CPAN distribution.

Report information
The Basics
Id: 124819
Status: new
Priority: 0/
Queue: Data-Validate-Japanese

People
Owner: Nobody in particular
Requestors: nreeve [...] kingston.net
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: bug report: Data-Validate-Japanese-0.01001
Date: Sun, 18 Mar 2018 13:20:54 -0400
To: bug-Data-Validate-Japanese [...] rt.cpan.org
From: Noelle Reeve <nreeve [...] kingston.net>
Download (untitled) / with headers
text/plain 814b
今日は I was playing around with Data-Validate-Japanese-0.01001 <http://search.cpan.org/~dmaki/Data-Validate-Japanese-0.01001/> on OS X 10.12.6 perlbrew distribution version 5.24.1 and I I got an error when testing and the test wouldn’t compile. The error was: Assuming NOT a POSIX class since there is no terminating ':' in regex; marked by <-- HERE in m/[[:ascii <-- HERE ]]/ at /Users/dadmin/perl5/perlbrew/perls/perl-5.24.1/lib/site_perl/5.24.1/Data/Validate/Japanese.pm line 19. I looked in Japanese.pm and at line 19 there is: 19 ascii => qr([[:ascii]]) which I think should be: ascii => qr([[:ascii:]]) # add the second : The module hasn’t been updated in a while, so I guess between 5.05 and 5.24 things got a little stricter. Best regards Michael Reeve


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.