Skip Menu |
 

This queue is for tickets about the Net-Frame CPAN distribution.

Report information
The Basics
Id: 124780
Status: resolved
Priority: 0/
Queue: Net-Frame

People
Owner: gomor [...] cpan.org
Requestors: felipe [...] felipegasper.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 1.19



Subject: macOS compilation fails
Date: Thu, 15 Mar 2018 08:32:48 -0400
To: bug-Net-Frame [...] rt.cpan.org
From: Felipe Gasper <felipe [...] felipegasper.com>
Download (untitled) / with headers
text/plain 1.7k
Show quoted text
> sudo cpan Net::Frame
Loading internal null logger. Install Log::Log4perl for logging messages Reading '/Users/felipe/.cpan/Metadata' Database was generated on Wed, 14 Mar 2018 05:17:03 GMT Running install for module 'Net::Frame' Checksum for /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net-Frame-1.17.tar.gz ok 'YAML' not installed, will not store persistent state Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Net-Frame' version '1.17' GOMOR/Net-Frame-1.17.tar.gz /opt/local/bin/perl5.26 Build.PL -- OK Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz Building Net-Frame GOMOR/Net-Frame-1.17.tar.gz ./Build -- OK Running Build test t/01-use.t ........... ok t/02-pod-coverage.t .. ok t/03-test-pod.t ...... ok t/04-eth.t ........... ok t/05-arp.t ........... ok t/06-ipv4.t .......... ok t/07-raw.t ........... ok t/08-sll.t ........... ok t/09-tcp.t ........... ok t/10-null.t .......... ok t/11-udp.t ........... ok t/12-ppp.t ........... ok t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t at line 68) # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- invalid IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame-1.17-4/blib/lib/Net/Frame/Layer.pm line 303. #) # t/13-gethostsubs.t line 68 is: 1, t/13-gethostsubs.t ... Failed 1/6 subtests Test Summary Report ------------------- t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) Failed test: 4 Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + 0.67 cusr 0.10 csys = 0.85 CPU) Result: FAIL Failed 1/13 test programs. 1/28 subtests failed. GOMOR/Net-Frame-1.17.tar.gz ./Build test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports GOMOR/Net-Frame-1.17.tar.gz
Download (untitled) / with headers
text/plain 2.1k
Hi, that's strange. But it looks more like a bug in Net::IPv6Addr with its is_ipv6() routine. Which version of Net::IPv6Addr do you have? Would you mind trying upgrading it? Thanks, On Thu Mar 15 09:16:01 2018, felipe@felipegasper.com wrote: Show quoted text
> > sudo cpan Net::Frame
> Loading internal null logger. Install Log::Log4perl for logging > messages > Reading '/Users/felipe/.cpan/Metadata' > Database was generated on Wed, 14 Mar 2018 05:17:03 GMT > Running install for module 'Net::Frame' > Checksum for /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net- > Frame-1.17.tar.gz ok > 'YAML' not installed, will not store persistent state > Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL > Created MYMETA.yml and MYMETA.json > Creating new 'Build' script for 'Net-Frame' version '1.17' > GOMOR/Net-Frame-1.17.tar.gz > /opt/local/bin/perl5.26 Build.PL -- OK > Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz > Building Net-Frame > GOMOR/Net-Frame-1.17.tar.gz > ./Build -- OK > Running Build test > t/01-use.t ........... ok > t/02-pod-coverage.t .. ok > t/03-test-pod.t ...... ok > t/04-eth.t ........... ok > t/05-arp.t ........... ok > t/06-ipv4.t .......... ok > t/07-raw.t ........... ok > t/08-sll.t ........... ok > t/09-tcp.t ........... ok > t/10-null.t .......... ok > t/11-udp.t ........... ok > t/12-ppp.t ........... ok > t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t at > line 68) > # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- invalid > IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame-1.17- > 4/blib/lib/Net/Frame/Layer.pm line 303. > #) > # t/13-gethostsubs.t line 68 is: 1, > t/13-gethostsubs.t ... Failed 1/6 subtests > > Test Summary Report > ------------------- > t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) > Failed test: 4 > Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + 0.67 > cusr 0.10 csys = 0.85 CPU) > Result: FAIL > Failed 1/13 test programs. 1/28 subtests failed. > GOMOR/Net-Frame-1.17.tar.gz > ./Build test -- NOT OK > //hint// to see the cpan-testers results for installing this module, > try: > reports GOMOR/Net-Frame-1.17.tar.gz
Subject: Re: [rt.cpan.org #124780] macOS compilation fails
Date: Thu, 15 Mar 2018 10:01:20 -0400
To: bug-Net-Frame [...] rt.cpan.org
From: Felipe Gasper <felipe [...] felipegasper.com>
Download (untitled) / with headers
text/plain 2.5k
Show quoted text
> sudo cpan Net::IPv6Addr
Password: Loading internal null logger. Install Log::Log4perl for logging messages Reading '/Users/felipe/.cpan/Metadata' Database was generated on Wed, 14 Mar 2018 05:17:03 GMT Net::IPv6Addr is up to date (0.91). Show quoted text
> On Mar 15, 2018, at 9:34 AM, Patrice Auffret via RT <bug-Net-Frame@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > > Hi, > > that's strange. But it looks more like a bug in Net::IPv6Addr with its is_ipv6() routine. Which version of Net::IPv6Addr do you have? Would you mind trying upgrading it? > > Thanks, > > > On Thu Mar 15 09:16:01 2018, felipe@felipegasper.com wrote:
>>> sudo cpan Net::Frame
>> Loading internal null logger. Install Log::Log4perl for logging >> messages >> Reading '/Users/felipe/.cpan/Metadata' >> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT >> Running install for module 'Net::Frame' >> Checksum for /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net- >> Frame-1.17.tar.gz ok >> 'YAML' not installed, will not store persistent state >> Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL >> Created MYMETA.yml and MYMETA.json >> Creating new 'Build' script for 'Net-Frame' version '1.17' >> GOMOR/Net-Frame-1.17.tar.gz >> /opt/local/bin/perl5.26 Build.PL -- OK >> Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz >> Building Net-Frame >> GOMOR/Net-Frame-1.17.tar.gz >> ./Build -- OK >> Running Build test >> t/01-use.t ........... ok >> t/02-pod-coverage.t .. ok >> t/03-test-pod.t ...... ok >> t/04-eth.t ........... ok >> t/05-arp.t ........... ok >> t/06-ipv4.t .......... ok >> t/07-raw.t ........... ok >> t/08-sll.t ........... ok >> t/09-tcp.t ........... ok >> t/10-null.t .......... ok >> t/11-udp.t ........... ok >> t/12-ppp.t ........... ok >> t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t at >> line 68) >> # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- invalid >> IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame-1.17- >> 4/blib/lib/Net/Frame/Layer.pm line 303. >> #) >> # t/13-gethostsubs.t line 68 is: 1, >> t/13-gethostsubs.t ... Failed 1/6 subtests >> >> Test Summary Report >> ------------------- >> t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) >> Failed test: 4 >> Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + 0.67 >> cusr 0.10 csys = 0.85 CPU) >> Result: FAIL >> Failed 1/13 test programs. 1/28 subtests failed. >> GOMOR/Net-Frame-1.17.tar.gz >> ./Build test -- NOT OK >> //hint// to see the cpan-testers results for installing this module, >> try: >> reports GOMOR/Net-Frame-1.17.tar.gz
> > >
Ok, would you mind trying this oneliner? perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") ? 1 : 0, "\n"' If you have anything else than "0", you should open a bug on Net::IPv6Addr module. Regards, On Thu Mar 15 10:01:56 2018, felipe@felipegasper.com wrote: Show quoted text
> > sudo cpan Net::IPv6Addr
> Password: > Loading internal null logger. Install Log::Log4perl for logging > messages > Reading '/Users/felipe/.cpan/Metadata' > Database was generated on Wed, 14 Mar 2018 05:17:03 GMT > Net::IPv6Addr is up to date (0.91). >
> > On Mar 15, 2018, at 9:34 AM, Patrice Auffret via RT <bug-Net- > > Frame@rt.cpan.org> wrote: > > > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > > > > Hi, > > > > that's strange. But it looks more like a bug in Net::IPv6Addr with > > its is_ipv6() routine. Which version of Net::IPv6Addr do you have? > > Would you mind trying upgrading it? > > > > Thanks, > > > > > > On Thu Mar 15 09:16:01 2018, felipe@felipegasper.com wrote:
> >>> sudo cpan Net::Frame
> >> Loading internal null logger. Install Log::Log4perl for logging > >> messages > >> Reading '/Users/felipe/.cpan/Metadata' > >> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT > >> Running install for module 'Net::Frame' > >> Checksum for /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net- > >> Frame-1.17.tar.gz ok > >> 'YAML' not installed, will not store persistent state > >> Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL > >> Created MYMETA.yml and MYMETA.json > >> Creating new 'Build' script for 'Net-Frame' version '1.17' > >> GOMOR/Net-Frame-1.17.tar.gz > >> /opt/local/bin/perl5.26 Build.PL -- OK > >> Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz > >> Building Net-Frame > >> GOMOR/Net-Frame-1.17.tar.gz > >> ./Build -- OK > >> Running Build test > >> t/01-use.t ........... ok > >> t/02-pod-coverage.t .. ok > >> t/03-test-pod.t ...... ok > >> t/04-eth.t ........... ok > >> t/05-arp.t ........... ok > >> t/06-ipv4.t .......... ok > >> t/07-raw.t ........... ok > >> t/08-sll.t ........... ok > >> t/09-tcp.t ........... ok > >> t/10-null.t .......... ok > >> t/11-udp.t ........... ok > >> t/12-ppp.t ........... ok > >> t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t at > >> line 68) > >> # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- > >> invalid > >> IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame-1.17- > >> 4/blib/lib/Net/Frame/Layer.pm line 303. > >> #) > >> # t/13-gethostsubs.t line 68 is: 1, > >> t/13-gethostsubs.t ... Failed 1/6 subtests > >> > >> Test Summary Report > >> ------------------- > >> t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) > >> Failed test: 4 > >> Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + 0.67 > >> cusr 0.10 csys = 0.85 CPU) > >> Result: FAIL > >> Failed 1/13 test programs. 1/28 subtests failed. > >> GOMOR/Net-Frame-1.17.tar.gz > >> ./Build test -- NOT OK > >> //hint// to see the cpan-testers results for installing this module, > >> try: > >> reports GOMOR/Net-Frame-1.17.tar.gz
> > > > > >
Subject: Re: [rt.cpan.org #124780] macOS compilation fails
Date: Thu, 15 Mar 2018 23:16:40 -0400
To: bug-Net-Frame [...] rt.cpan.org
From: Felipe Gasper <felipe [...] felipegasper.com>
Download (untitled) / with headers
text/plain 3.3k
All I see is “0”: Show quoted text
> perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") ? 1 : 0, "\n"'
0 -FG Show quoted text
> On Mar 15, 2018, at 10:55 AM, Patrice Auffret via RT <bug-Net-Frame@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > > Ok, would you mind trying this oneliner? > > perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") ? 1 : 0, "\n"' > > If you have anything else than "0", you should open a bug on Net::IPv6Addr module. > > Regards, > > > On Thu Mar 15 10:01:56 2018, felipe@felipegasper.com wrote:
>>> sudo cpan Net::IPv6Addr
>> Password: >> Loading internal null logger. Install Log::Log4perl for logging >> messages >> Reading '/Users/felipe/.cpan/Metadata' >> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT >> Net::IPv6Addr is up to date (0.91). >>
>>> On Mar 15, 2018, at 9:34 AM, Patrice Auffret via RT <bug-Net- >>> Frame@rt.cpan.org> wrote: >>> >>> <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > >>> >>> Hi, >>> >>> that's strange. But it looks more like a bug in Net::IPv6Addr with >>> its is_ipv6() routine. Which version of Net::IPv6Addr do you have? >>> Would you mind trying upgrading it? >>> >>> Thanks, >>> >>> >>> On Thu Mar 15 09:16:01 2018, felipe@felipegasper.com wrote:
>>>>> sudo cpan Net::Frame
>>>> Loading internal null logger. Install Log::Log4perl for logging >>>> messages >>>> Reading '/Users/felipe/.cpan/Metadata' >>>> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT >>>> Running install for module 'Net::Frame' >>>> Checksum for /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net- >>>> Frame-1.17.tar.gz ok >>>> 'YAML' not installed, will not store persistent state >>>> Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL >>>> Created MYMETA.yml and MYMETA.json >>>> Creating new 'Build' script for 'Net-Frame' version '1.17' >>>> GOMOR/Net-Frame-1.17.tar.gz >>>> /opt/local/bin/perl5.26 Build.PL -- OK >>>> Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz >>>> Building Net-Frame >>>> GOMOR/Net-Frame-1.17.tar.gz >>>> ./Build -- OK >>>> Running Build test >>>> t/01-use.t ........... ok >>>> t/02-pod-coverage.t .. ok >>>> t/03-test-pod.t ...... ok >>>> t/04-eth.t ........... ok >>>> t/05-arp.t ........... ok >>>> t/06-ipv4.t .......... ok >>>> t/07-raw.t ........... ok >>>> t/08-sll.t ........... ok >>>> t/09-tcp.t ........... ok >>>> t/10-null.t .......... ok >>>> t/11-udp.t ........... ok >>>> t/12-ppp.t ........... ok >>>> t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t at >>>> line 68) >>>> # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- >>>> invalid >>>> IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame-1.17- >>>> 4/blib/lib/Net/Frame/Layer.pm line 303. >>>> #) >>>> # t/13-gethostsubs.t line 68 is: 1, >>>> t/13-gethostsubs.t ... Failed 1/6 subtests >>>> >>>> Test Summary Report >>>> ------------------- >>>> t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) >>>> Failed test: 4 >>>> Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + 0.67 >>>> cusr 0.10 csys = 0.85 CPU) >>>> Result: FAIL >>>> Failed 1/13 test programs. 1/28 subtests failed. >>>> GOMOR/Net-Frame-1.17.tar.gz >>>> ./Build test -- NOT OK >>>> //hint// to see the cpan-testers results for installing this module, >>>> try: >>>> reports GOMOR/Net-Frame-1.17.tar.gz
>>> >>> >>>
> > >
Download (untitled) / with headers
text/plain 3.8k
Really strange. Could you try IPv6 DNS resolution from your shell like this: host -t aaaa gomor.org Then (after forcing Net::Frame installation): perl -MNet::Frame::Layer -e 'print Net::Frame::Layer::getHostIpv6Addr("gomor.org")' On Thu Mar 15 23:16:58 2018, felipe@felipegasper.com wrote: Show quoted text
> All I see is “0”: >
> > perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") ? > > 1 : 0, "\n"'
> 0 > > > -FG > >
> > On Mar 15, 2018, at 10:55 AM, Patrice Auffret via RT <bug-Net- > > Frame@rt.cpan.org> wrote: > > > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > > > > Ok, would you mind trying this oneliner? > > > > perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") ? > > 1 : 0, "\n"' > > > > If you have anything else than "0", you should open a bug on > > Net::IPv6Addr module. > > > > Regards, > > > > > > On Thu Mar 15 10:01:56 2018, felipe@felipegasper.com wrote:
> >>> sudo cpan Net::IPv6Addr
> >> Password: > >> Loading internal null logger. Install Log::Log4perl for logging > >> messages > >> Reading '/Users/felipe/.cpan/Metadata' > >> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT > >> Net::IPv6Addr is up to date (0.91). > >>
> >>> On Mar 15, 2018, at 9:34 AM, Patrice Auffret via RT <bug-Net- > >>> Frame@rt.cpan.org> wrote: > >>> > >>> <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > >>> > >>> Hi, > >>> > >>> that's strange. But it looks more like a bug in Net::IPv6Addr with > >>> its is_ipv6() routine. Which version of Net::IPv6Addr do you have? > >>> Would you mind trying upgrading it? > >>> > >>> Thanks, > >>> > >>> > >>> On Thu Mar 15 09:16:01 2018, felipe@felipegasper.com wrote:
> >>>>> sudo cpan Net::Frame
> >>>> Loading internal null logger. Install Log::Log4perl for logging > >>>> messages > >>>> Reading '/Users/felipe/.cpan/Metadata' > >>>> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT > >>>> Running install for module 'Net::Frame' > >>>> Checksum for > >>>> /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net- > >>>> Frame-1.17.tar.gz ok > >>>> 'YAML' not installed, will not store persistent state > >>>> Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL > >>>> Created MYMETA.yml and MYMETA.json > >>>> Creating new 'Build' script for 'Net-Frame' version '1.17' > >>>> GOMOR/Net-Frame-1.17.tar.gz > >>>> /opt/local/bin/perl5.26 Build.PL -- OK > >>>> Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz > >>>> Building Net-Frame > >>>> GOMOR/Net-Frame-1.17.tar.gz > >>>> ./Build -- OK > >>>> Running Build test > >>>> t/01-use.t ........... ok > >>>> t/02-pod-coverage.t .. ok > >>>> t/03-test-pod.t ...... ok > >>>> t/04-eth.t ........... ok > >>>> t/05-arp.t ........... ok > >>>> t/06-ipv4.t .......... ok > >>>> t/07-raw.t ........... ok > >>>> t/08-sll.t ........... ok > >>>> t/09-tcp.t ........... ok > >>>> t/10-null.t .......... ok > >>>> t/11-udp.t ........... ok > >>>> t/12-ppp.t ........... ok > >>>> t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t > >>>> at > >>>> line 68) > >>>> # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- > >>>> invalid > >>>> IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame- > >>>> 1.17- > >>>> 4/blib/lib/Net/Frame/Layer.pm line 303. > >>>> #) > >>>> # t/13-gethostsubs.t line 68 is: 1, > >>>> t/13-gethostsubs.t ... Failed 1/6 subtests > >>>> > >>>> Test Summary Report > >>>> ------------------- > >>>> t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) > >>>> Failed test: 4 > >>>> Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + 0.67 > >>>> cusr 0.10 csys = 0.85 CPU) > >>>> Result: FAIL > >>>> Failed 1/13 test programs. 1/28 subtests failed. > >>>> GOMOR/Net-Frame-1.17.tar.gz > >>>> ./Build test -- NOT OK > >>>> //hint// to see the cpan-testers results for installing this > >>>> module, > >>>> try: > >>>> reports GOMOR/Net-Frame-1.17.tar.gz
> >>> > >>> > >>>
> > > > > >
Subject: Re: [rt.cpan.org #124780] macOS compilation fails
Date: Fri, 16 Mar 2018 22:02:03 -0400
To: bug-Net-Frame [...] rt.cpan.org
From: Felipe Gasper <felipe [...] felipegasper.com>
Download (untitled) / with headers
text/plain 4.8k
felipe@Felipes-MacBook-Pro 21:12:32 ~/Documents Show quoted text
> host -t aaaa gomor.org
gomor.org has IPv6 address 2001:41d0:2:1a47::2 felipe@Felipes-MacBook-Pro 21:56:52 ~/Documents Show quoted text
> perl -MNet::Frame::Layer -e 'print Net::Frame::Layer::getHostIpv6Addr("gomor.org")'
::ffff:94.23.25.71 ----- In other news, your one-liner from before is now printing nothing: Show quoted text
> perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org")'
I do wonder if there could be interference from my VPN setup. Honestly I don’t remember if I’ve had it up before. Right now it doesn’t seem to make a difference with the one-liner. I’ve gone ahead and just forced install of the relevant modules that I needed, so this isn’t blocking me. If you want to keep digging, I’m happy to try things to see if there’s something worth discovering here. -FG Show quoted text
> On Mar 16, 2018, at 3:09 AM, Patrice Auffret via RT <bug-Net-Frame@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > > Really strange. Could you try IPv6 DNS resolution from your shell like this: > > host -t aaaa gomor.org > > Then (after forcing Net::Frame installation): > > perl -MNet::Frame::Layer -e 'print Net::Frame::Layer::getHostIpv6Addr("gomor.org")' > > > On Thu Mar 15 23:16:58 2018, felipe@felipegasper.com wrote:
>> All I see is “0”: >>
>>> perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") ? >>> 1 : 0, "\n"'
>> 0 >> >> >> -FG >> >>
>>> On Mar 15, 2018, at 10:55 AM, Patrice Auffret via RT <bug-Net- >>> Frame@rt.cpan.org> wrote: >>> >>> <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > >>> >>> Ok, would you mind trying this oneliner? >>> >>> perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") ? >>> 1 : 0, "\n"' >>> >>> If you have anything else than "0", you should open a bug on >>> Net::IPv6Addr module. >>> >>> Regards, >>> >>> >>> On Thu Mar 15 10:01:56 2018, felipe@felipegasper.com wrote:
>>>>> sudo cpan Net::IPv6Addr
>>>> Password: >>>> Loading internal null logger. Install Log::Log4perl for logging >>>> messages >>>> Reading '/Users/felipe/.cpan/Metadata' >>>> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT >>>> Net::IPv6Addr is up to date (0.91). >>>>
>>>>> On Mar 15, 2018, at 9:34 AM, Patrice Auffret via RT <bug-Net- >>>>> Frame@rt.cpan.org> wrote: >>>>> >>>>> <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > >>>>> >>>>> Hi, >>>>> >>>>> that's strange. But it looks more like a bug in Net::IPv6Addr with >>>>> its is_ipv6() routine. Which version of Net::IPv6Addr do you have? >>>>> Would you mind trying upgrading it? >>>>> >>>>> Thanks, >>>>> >>>>> >>>>> On Thu Mar 15 09:16:01 2018, felipe@felipegasper.com wrote:
>>>>>>> sudo cpan Net::Frame
>>>>>> Loading internal null logger. Install Log::Log4perl for logging >>>>>> messages >>>>>> Reading '/Users/felipe/.cpan/Metadata' >>>>>> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT >>>>>> Running install for module 'Net::Frame' >>>>>> Checksum for >>>>>> /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net- >>>>>> Frame-1.17.tar.gz ok >>>>>> 'YAML' not installed, will not store persistent state >>>>>> Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL >>>>>> Created MYMETA.yml and MYMETA.json >>>>>> Creating new 'Build' script for 'Net-Frame' version '1.17' >>>>>> GOMOR/Net-Frame-1.17.tar.gz >>>>>> /opt/local/bin/perl5.26 Build.PL -- OK >>>>>> Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz >>>>>> Building Net-Frame >>>>>> GOMOR/Net-Frame-1.17.tar.gz >>>>>> ./Build -- OK >>>>>> Running Build test >>>>>> t/01-use.t ........... ok >>>>>> t/02-pod-coverage.t .. ok >>>>>> t/03-test-pod.t ...... ok >>>>>> t/04-eth.t ........... ok >>>>>> t/05-arp.t ........... ok >>>>>> t/06-ipv4.t .......... ok >>>>>> t/07-raw.t ........... ok >>>>>> t/08-sll.t ........... ok >>>>>> t/09-tcp.t ........... ok >>>>>> t/10-null.t .......... ok >>>>>> t/11-udp.t ........... ok >>>>>> t/12-ppp.t ........... ok >>>>>> t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t >>>>>> at >>>>>> line 68) >>>>>> # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- >>>>>> invalid >>>>>> IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame- >>>>>> 1.17- >>>>>> 4/blib/lib/Net/Frame/Layer.pm line 303. >>>>>> #) >>>>>> # t/13-gethostsubs.t line 68 is: 1, >>>>>> t/13-gethostsubs.t ... Failed 1/6 subtests >>>>>> >>>>>> Test Summary Report >>>>>> ------------------- >>>>>> t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) >>>>>> Failed test: 4 >>>>>> Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + 0.67 >>>>>> cusr 0.10 csys = 0.85 CPU) >>>>>> Result: FAIL >>>>>> Failed 1/13 test programs. 1/28 subtests failed. >>>>>> GOMOR/Net-Frame-1.17.tar.gz >>>>>> ./Build test -- NOT OK >>>>>> //hint// to see the cpan-testers results for installing this >>>>>> module, >>>>>> try: >>>>>> reports GOMOR/Net-Frame-1.17.tar.gz
>>>>> >>>>> >>>>>
>>> >>> >>>
> > >
Download (untitled) / with headers
text/plain 5.3k
Hi, would you mind trying the attached patch to t/13-gethostsubs.t and tell me if that fixes the issue? Thanks, On Fri Mar 16 22:03:28 2018, felipe@felipegasper.com wrote: Show quoted text
> felipe@Felipes-MacBook-Pro 21:12:32 ~/Documents
> > host -t aaaa gomor.org
> gomor.org has IPv6 address 2001:41d0:2:1a47::2 > > > felipe@Felipes-MacBook-Pro 21:56:52 ~/Documents
> > perl -MNet::Frame::Layer -e 'print > > Net::Frame::Layer::getHostIpv6Addr("gomor.org")'
> ::ffff:94.23.25.71 > > ----- > In other news, your one-liner from before is now printing nothing: >
> > perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org")'
> > > I do wonder if there could be interference from my VPN setup. Honestly > I don’t remember if I’ve had it up before. Right now it doesn’t seem > to make a difference with the one-liner. > > > I’ve gone ahead and just forced install of the relevant modules that I > needed, so this isn’t blocking me. If you want to keep digging, I’m > happy to try things to see if there’s something worth discovering > here. > > -FG > >
> > On Mar 16, 2018, at 3:09 AM, Patrice Auffret via RT <bug-Net- > > Frame@rt.cpan.org> wrote: > > > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > > > > Really strange. Could you try IPv6 DNS resolution from your shell > > like this: > > > > host -t aaaa gomor.org > > > > Then (after forcing Net::Frame installation): > > > > perl -MNet::Frame::Layer -e 'print > > Net::Frame::Layer::getHostIpv6Addr("gomor.org")' > > > > > > On Thu Mar 15 23:16:58 2018, felipe@felipegasper.com wrote:
> >> All I see is “0”: > >>
> >>> perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") > >>> ? > >>> 1 : 0, "\n"'
> >> 0 > >> > >> > >> -FG > >> > >>
> >>> On Mar 15, 2018, at 10:55 AM, Patrice Auffret via RT <bug-Net- > >>> Frame@rt.cpan.org> wrote: > >>> > >>> <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > >>> > >>> Ok, would you mind trying this oneliner? > >>> > >>> perl -MNet::IPv6Addr -e 'print Net::IPv6Addr::is_ipv6("gomor.org") > >>> ? > >>> 1 : 0, "\n"' > >>> > >>> If you have anything else than "0", you should open a bug on > >>> Net::IPv6Addr module. > >>> > >>> Regards, > >>> > >>> > >>> On Thu Mar 15 10:01:56 2018, felipe@felipegasper.com wrote:
> >>>>> sudo cpan Net::IPv6Addr
> >>>> Password: > >>>> Loading internal null logger. Install Log::Log4perl for logging > >>>> messages > >>>> Reading '/Users/felipe/.cpan/Metadata' > >>>> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT > >>>> Net::IPv6Addr is up to date (0.91). > >>>>
> >>>>> On Mar 15, 2018, at 9:34 AM, Patrice Auffret via RT <bug-Net- > >>>>> Frame@rt.cpan.org> wrote: > >>>>> > >>>>> <URL: https://rt.cpan.org/Ticket/Display.html?id=124780 > > >>>>> > >>>>> Hi, > >>>>> > >>>>> that's strange. But it looks more like a bug in Net::IPv6Addr > >>>>> with > >>>>> its is_ipv6() routine. Which version of Net::IPv6Addr do you > >>>>> have? > >>>>> Would you mind trying upgrading it? > >>>>> > >>>>> Thanks, > >>>>> > >>>>> > >>>>> On Thu Mar 15 09:16:01 2018, felipe@felipegasper.com wrote:
> >>>>>>> sudo cpan Net::Frame
> >>>>>> Loading internal null logger. Install Log::Log4perl for logging > >>>>>> messages > >>>>>> Reading '/Users/felipe/.cpan/Metadata' > >>>>>> Database was generated on Wed, 14 Mar 2018 05:17:03 GMT > >>>>>> Running install for module 'Net::Frame' > >>>>>> Checksum for > >>>>>> /Users/felipe/.cpan/sources/authors/id/G/GO/GOMOR/Net- > >>>>>> Frame-1.17.tar.gz ok > >>>>>> 'YAML' not installed, will not store persistent state > >>>>>> Configuring G/GO/GOMOR/Net-Frame-1.17.tar.gz with Build.PL > >>>>>> Created MYMETA.yml and MYMETA.json > >>>>>> Creating new 'Build' script for 'Net-Frame' version '1.17' > >>>>>> GOMOR/Net-Frame-1.17.tar.gz > >>>>>> /opt/local/bin/perl5.26 Build.PL -- OK > >>>>>> Running Build for G/GO/GOMOR/Net-Frame-1.17.tar.gz > >>>>>> Building Net-Frame > >>>>>> GOMOR/Net-Frame-1.17.tar.gz > >>>>>> ./Build -- OK > >>>>>> Running Build test > >>>>>> t/01-use.t ........... ok > >>>>>> t/02-pod-coverage.t .. ok > >>>>>> t/03-test-pod.t ...... ok > >>>>>> t/04-eth.t ........... ok > >>>>>> t/05-arp.t ........... ok > >>>>>> t/06-ipv4.t .......... ok > >>>>>> t/07-raw.t ........... ok > >>>>>> t/08-sll.t ........... ok > >>>>>> t/09-tcp.t ........... ok > >>>>>> t/10-null.t .......... ok > >>>>>> t/11-udp.t ........... ok > >>>>>> t/12-ppp.t ........... ok > >>>>>> t/13-gethostsubs.t ... 1/6 # Test 4 got: "0" (t/13-gethostsubs.t > >>>>>> at > >>>>>> line 68) > >>>>>> # Expected: "1" (Net::IPv6Addr::Net::IPv6Addr::ipv6_parse -- > >>>>>> invalid > >>>>>> IPv6 address gomor.org at /Users/felipe/.cpan/build/Net-Frame- > >>>>>> 1.17- > >>>>>> 4/blib/lib/Net/Frame/Layer.pm line 303. > >>>>>> #) > >>>>>> # t/13-gethostsubs.t line 68 is: 1, > >>>>>> t/13-gethostsubs.t ... Failed 1/6 subtests > >>>>>> > >>>>>> Test Summary Report > >>>>>> ------------------- > >>>>>> t/13-gethostsubs.t (Wstat: 0 Tests: 6 Failed: 1) > >>>>>> Failed test: 4 > >>>>>> Files=13, Tests=28, 1 wallclock secs ( 0.05 usr 0.03 sys + > >>>>>> 0.67 > >>>>>> cusr 0.10 csys = 0.85 CPU) > >>>>>> Result: FAIL > >>>>>> Failed 1/13 test programs. 1/28 subtests failed. > >>>>>> GOMOR/Net-Frame-1.17.tar.gz > >>>>>> ./Build test -- NOT OK > >>>>>> //hint// to see the cpan-testers results for installing this > >>>>>> module, > >>>>>> try: > >>>>>> reports GOMOR/Net-Frame-1.17.tar.gz
> >>>>> > >>>>> > >>>>>
> >>> > >>> > >>>
> > > > > >
Subject: t13.patch
Download t13.patch
text/x-diff 515b
diff -r f07070e54f2a t/13-gethostsubs.t --- a/t/13-gethostsubs.t Thu Mar 15 16:17:40 2018 +0100 +++ b/t/13-gethostsubs.t Mon Mar 19 08:50:30 2018 +0100 @@ -5,6 +5,7 @@ my $host = 'gomor.org'; my $ip6 = '2001:41d0:2:1a47::2'; +my $ip6v4mapping = '::ffff:94.23.25.71'; my $ip4 = '94.23.25.71'; # @@ -58,7 +59,7 @@ ok( sub { my $ip = getHostIpv6Addr($host); - if ($ip eq $ip6) { + if ($ip eq $ip6 || $ip eq $ip6v4mapping) { print "[+] $ip\n"; return 1; # OK }
Fixed in 1.19


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.