Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI CPAN distribution.

Report information
The Basics
Id: 12474
Status: resolved
Priority: 0/
Queue: CGI

People
Owner: Nobody in particular
Requestors: bart [...] grafikon.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: upload fails under mod_perl
Download (untitled) / with headers
text/plain 1.2k
Hi, Recently upgraded my mod_perl2 environment and switched to Perl 5.8.3 and as such upgraded CGI to version 3.01. Since then the upload from a webform running under mod_perl failed. Strangely enough moving the same testprogram from the mod_perl folder into the /cgi-bin folder did 'cure' the problem. I've tracked down the error to a change in line 3753 in the 'find_tempdir' routine of CGI.pm: line 3753 reads: undef $TMPDIRECTORY; Having this removes the possibility to set your own $TMPDIRECTORY in case of a 'special' user environment. Normally this could be done using line 26: #$CGITempFile::TMPDIRECTORY = '/usr/tmp'; which is normally commented out. I would ask that line 3753 is removed. (don't know what the logic was behind it) So that the possibility to set your own fixed TMPDIRECTORY is restored. Remark: In case you wonder what is special to my user environment, well here is the explanaition: in my case the $ENV{TMPDIR} did not work as on my machine this reads as: C:\DOCUME~1\bart\LOCALS~1\Temp. And I was logged in as bart.grafikon, but $ENV{TMPDIR} was pointing to the local user 'bart' and not the domain user 'bart' My environment is: - Win2000 SP2 - Apache 2.0.47 - mod_perl 1.999.22 - perl 5.8.3 Kind Regards, Bart
Download CGI.pm
text/x-perl 233.3k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 1.5k
Thanks for the report. I've confirmed with 3.43 that the mentioned line "undef $TMPDIRECTORY" is no longer there. Thus, I believe this bug has been fixed, and this bug can be considered resolved. Mark On Sat Apr 30 07:44:22 2005, guest wrote: Show quoted text
> Hi, > > Recently upgraded my mod_perl2 environment and switched to Perl 5.8.3 > and as such upgraded CGI to version 3.01. > Since then the upload from a webform running under mod_perl failed. > Strangely enough moving the same testprogram from the mod_perl folder > into the /cgi-bin folder did 'cure' the problem. > > I've tracked down the error to a change in line 3753 in the > 'find_tempdir' routine of CGI.pm: > line 3753 reads: undef $TMPDIRECTORY; > > Having this removes the possibility to set your own $TMPDIRECTORY in > case of a 'special' user environment. > Normally this could be done using line 26: > #$CGITempFile::TMPDIRECTORY = '/usr/tmp'; > which is normally commented out. > > I would ask that line 3753 is removed. > (don't know what the logic was behind it) > So that the possibility to set your own fixed TMPDIRECTORY is > restored. > > Remark: In case you wonder what is special to my user environment, > well here is the explanaition: > in my case the $ENV{TMPDIR} did not work as on my machine this reads > as: C:\DOCUME~1\bart\LOCALS~1\Temp. And I was logged in as > bart.grafikon, but $ENV{TMPDIR} was pointing to the local user > 'bart' and not the domain user 'bart' > > > My environment is: > - Win2000 SP2 > - Apache 2.0.47 > - mod_perl 1.999.22 > - perl 5.8.3 > > Kind Regards, > > Bart


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.