Skip Menu |
 

This queue is for tickets about the Net-SSLeay CPAN distribution.

Report information
The Basics
Id: 124388
Status: resolved
Priority: 0/
Queue: Net-SSLeay

People
Owner: chrisn [...] cpan.org
Requestors: craigberry [...] mac.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 1.86_04

Attachments


Subject: [PATCH] VMS build update
Date: Sat, 10 Feb 2018 13:46:42 -0600
To: bug-Net-SSLeay [...] rt.cpan.org
From: "Craig A. Berry" <craigberry [...] mac.com>
Download (untitled) / with headers
text/plain 387b
The attached patch updates README.VMS and has a fix to locate up-to-date vendor-supplied libraries. The vendors have released kits with "SSL1" in the names of the libraries for code based on OpenSSL 1.0.x to allow them to co-exist with the older kits with just "SSL" in the name that were based on 0.9.x. This patch makes Net::SSLeay prefer the newer libraries if it can find them.
Download vmsupdate.patch
text/x-diff 4.9k

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 916b
On Sat Feb 10 20:47:00 2018, craigberry@mac.com wrote: Show quoted text
> The attached patch updates README.VMS and has a fix to locate up-to- > date vendor-supplied libraries. The vendors have released kits with > "SSL1" in the names of the libraries for code based on OpenSSL 1.0.x > to allow them to co-exist with the older kits with just "SSL" in the > name that were based on 0.9.x. This patch makes Net::SSLeay prefer > the newer libraries if it can find them.
Thanks for this, Craig. We recently (as of 1.86_03) switched to a simpler build system based solely on ExtUtils::MakeMaker. The patch to inc/Module/Install/PRIVATE/Net/SSLeay.pm applies straightforwardly to Makefile.PL. Could you take another look at README.VMS and see what's still relevant? Hopefully it's just a case of removing the section on Module::Install (which will shorten the instructions considerably), but I don't have a VMS system to test this on...
Subject: Re: [rt.cpan.org #124388] [PATCH] VMS build update
Date: Wed, 25 Jul 2018 07:16:14 -0500
To: bug-Net-SSLeay [...] rt.cpan.org
From: Craig Berry <craigberry [...] mac.com>
Download (untitled) / with headers
text/plain 1.3k
Show quoted text
> On Jul 25, 2018, at 5:21 AM, Chris Novakovic via RT <bug-Net-SSLeay@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124388 > > > On Sat Feb 10 20:47:00 2018, craigberry@mac.com wrote:
>> The attached patch updates README.VMS and has a fix to locate up-to- >> date vendor-supplied libraries. The vendors have released kits with >> "SSL1" in the names of the libraries for code based on OpenSSL 1.0.x >> to allow them to co-exist with the older kits with just "SSL" in the >> name that were based on 0.9.x. This patch makes Net::SSLeay prefer >> the newer libraries if it can find them.
> > Thanks for this, Craig. We recently (as of 1.86_03) switched to a simpler build system based solely on ExtUtils::MakeMaker. The patch to inc/Module/Install/PRIVATE/Net/SSLeay.pm applies straightforwardly to Makefile.PL. Could you take another look at README.VMS and see what's still relevant? Hopefully it's just a case of removing the section on Module::Install (which will shorten the instructions considerably), but I don't have a VMS system to test this on...
I'll be happy to take a look, but where can I get the current sources? MetaCPAN is serving up 1.85 and the link to the SVN repository is dead. Show quoted text
________________________________________ Craig A. Berry "... getting out of a sonnet is much more difficult than getting in." Brad Leithauser
Download (untitled) / with headers
text/plain 1.7k
On Wed Jul 25 14:16:28 2018, craigberry@mac.com wrote: Show quoted text
> >
> > On Jul 25, 2018, at 5:21 AM, Chris Novakovic via RT <bug-Net- > > SSLeay@rt.cpan.org> wrote: > > > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124388 > > > > > On Sat Feb 10 20:47:00 2018, craigberry@mac.com wrote:
> >> The attached patch updates README.VMS and has a fix to locate up-to- > >> date vendor-supplied libraries. The vendors have released kits with > >> "SSL1" in the names of the libraries for code based on OpenSSL 1.0.x > >> to allow them to co-exist with the older kits with just "SSL" in the > >> name that were based on 0.9.x. This patch makes Net::SSLeay prefer > >> the newer libraries if it can find them.
> > > > Thanks for this, Craig. We recently (as of 1.86_03) switched to a > > simpler build system based solely on ExtUtils::MakeMaker. The patch > > to inc/Module/Install/PRIVATE/Net/SSLeay.pm applies straightforwardly > > to Makefile.PL. Could you take another look at README.VMS and see > > what's still relevant? Hopefully it's just a case of removing the > > section on Module::Install (which will shorten the instructions > > considerably), but I don't have a VMS system to test this on...
> > I'll be happy to take a look, but where can I get the current sources? > MetaCPAN is serving up 1.85 and the link to the SVN repository is > dead.
The SVN repository Mike used to use for development shut down, so Heikki, Tuure and I (as the new maintainers) have switched to Git and the sources are now hosted on GitHub: https://github.com/radiator-software/p5-net-ssleay On MetaCPAN, developer releases are hidden away in the version dropdown menu at the top of the page, just below the search bar. Here's the latest developer release: https://metacpan.org/release/RADIATOR/Net-SSLeay-1.86_03
Subject: Re: [rt.cpan.org #124388] [PATCH] VMS build update
Date: Thu, 26 Jul 2018 15:12:57 -0500
To: bug-Net-SSLeay [...] rt.cpan.org
From: Craig Berry <craigberry [...] mac.com>
Download (untitled) / with headers
text/plain 1.1k
Show quoted text
> On Jul 25, 2018, at 8:22 AM, Chris Novakovic via RT <bug-Net-SSLeay@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124388 > > > On Wed Jul 25 14:16:28 2018, craigberry@mac.com wrote:
>> >> I'll be happy to take a look, but where can I get the current sources? >> MetaCPAN is serving up 1.85 and the link to the SVN repository is >> dead.
> > The SVN repository Mike used to use for development shut down, so Heikki, Tuure and I (as the new maintainers) have switched to Git and the sources are now hosted on GitHub: > > https://github.com/radiator-software/p5-net-ssleay > > On MetaCPAN, developer releases are hidden away in the version dropdown menu at the top of the page, just below the search bar. Here's the latest developer release: > > https://metacpan.org/release/RADIATOR/Net-SSLeay-1.86_03
Aha, thanks for the info. I have attached a new patch against current git that gets things building and passing tests on current VMS and SSL versions, and updates README.VMS to reflect this and the absence of Module::Install in the current distro. Let me know if you'd rather have a PR on GitHub.

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 1.5k
On Thu Jul 26 21:13:10 2018, craigberry@mac.com wrote: Show quoted text
> >
> > On Jul 25, 2018, at 8:22 AM, Chris Novakovic via RT <bug-Net- > > SSLeay@rt.cpan.org> wrote: > > > > <URL: https://rt.cpan.org/Ticket/Display.html?id=124388 > > > > > On Wed Jul 25 14:16:28 2018, craigberry@mac.com wrote:
> >> > >> I'll be happy to take a look, but where can I get the current > >> sources? > >> MetaCPAN is serving up 1.85 and the link to the SVN repository is > >> dead.
> > > > The SVN repository Mike used to use for development shut down, so > > Heikki, Tuure and I (as the new maintainers) have switched to Git and > > the sources are now hosted on GitHub: > > > > https://github.com/radiator-software/p5-net-ssleay > > > > On MetaCPAN, developer releases are hidden away in the version > > dropdown menu at the top of the page, just below the search bar. > > Here's the latest developer release: > > > > https://metacpan.org/release/RADIATOR/Net-SSLeay-1.86_03
> > Aha, thanks for the info. I have attached a new patch against current > git that gets things building and passing tests on current VMS and SSL > versions, and updates README.VMS to reflect this and the absence of > Module::Install in the current distro. Let me know if you'd rather > have a PR on GitHub.
Either's fine, so I'll take it from here - patch applied, with minor modifications crediting you in Changes: https://github.com/radiator-software/p5-net-ssleay/pull/18 This will be included in the next developer release (1.86_04) and the next stable release after that. Thanks for the update!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.