Skip Menu |
 

This queue is for tickets about the Net-SSLeay CPAN distribution.

Report information
The Basics
Id: 124101
Status: resolved
Priority: 0/
Queue: Net-SSLeay

People
Owner: MIKEM [...] cpan.org
Requestors: JBERGER [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.83
Fixed in: 1.84



Download (untitled) / with headers
text/plain 635b
I'm seeing a test failure in Net::SSLeay, I'm getting the following output: Test Summary Report ------------------- t/local/04_basic.t (Wstat: 65280 Tests: 13 Failed: 0) Non-zero exit status: 255 Parse errors: Bad plan. You planned 14 tests but ran 13. Looking at that test it appears that you have miscounted the skip if Test::Exception is not loadable https://metacpan.org/source/MIKEM/Net-SSLeay-1.83/t/local/04_basic.t#L11 . That count should be 6 not 5. Hopefully this should be a quick fix. In the meantime I think installing that test module should get us through our build process. Cheers, Joel Berger
Subject: Re: [rt.cpan.org #124101]
Date: Wed, 17 Jan 2018 08:00:25 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1.4k
Hello Joel, Hmmm, we dontr see that behaviour here: the test suite runs completley correctly. Can you send me the output of: perl -w -I blib/lib -I blib/arch t/local/04_basic.t Cheers. On Wednesday, 17 January 2018 02:21:16 AEST you wrote: Show quoted text
> Tue Jan 16 11:21:14 2018: Request 124101 was acted upon. > Transaction: Ticket created by JBERGER > Queue: Net-SSLeay > Subject: (No subject given) > Broken in: 1.83 > Severity: Important > Owner: Nobody > Requestors: JBERGER@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124101 > > > > I'm seeing a test failure in Net::SSLeay, I'm getting the following output: > > Test Summary Report > ------------------- > t/local/04_basic.t (Wstat: 65280 Tests: 13 Failed: 0) > Non-zero exit status: 255 > Parse errors: Bad plan. You planned 14 tests but ran 13. > > Looking at that test it appears that you have miscounted the skip if > Test::Exception is not loadable > https://metacpan.org/source/MIKEM/Net-SSLeay-1.83/t/local/04_basic.t#L11 . > That count should be 6 not 5. Hopefully this should be a quick fix. In the > meantime I think installing that test module should get us through our > build process. > > Cheers, > Joel Berger
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Download (untitled) / with headers
text/plain 1.6k
On Tue Jan 16 17:21:32 2018, mikem@airspayce.com wrote: Show quoted text
> Hello Joel, > > > Hmmm, we dontr see that behaviour here: the test suite runs completley > correctly. > > Can you send me the output of: > > perl -w -I blib/lib -I blib/arch t/local/04_basic.t
It was deep from within our Jenkins build, but just counting the number of tests following the skip it seems fairly obvious that you've miscounted. Can you confirm that you have tested without Test::Exception? If not I can try to reproduce elsewhere myself. Show quoted text
> > Cheers. > > On Wednesday, 17 January 2018 02:21:16 AEST you wrote:
> > Tue Jan 16 11:21:14 2018: Request 124101 was acted upon. > > Transaction: Ticket created by JBERGER > > Queue: Net-SSLeay > > Subject: (No subject given) > > Broken in: 1.83 > > Severity: Important > > Owner: Nobody > > Requestors: JBERGER@cpan.org > > Status: new > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124101 > > > > > > > I'm seeing a test failure in Net::SSLeay, I'm getting the following > > output: > > > > Test Summary Report > > ------------------- > > t/local/04_basic.t (Wstat: 65280 Tests: 13 Failed: > > 0) > > Non-zero exit status: 255 > > Parse errors: Bad plan. You planned 14 tests but ran 13. > > > > Looking at that test it appears that you have miscounted the skip if > > Test::Exception is not loadable > > https://metacpan.org/source/MIKEM/Net-SSLeay- > > 1.83/t/local/04_basic.t#L11 . > > That count should be 6 not 5. Hopefully this should be a quick fix. > > In the > > meantime I think installing that test module should get us through > > our > > build process. > > > > Cheers, > > Joel Berger
Download (untitled) / with headers
text/plain 3.2k
On Tue Jan 16 17:25:49 2018, JBERGER wrote: Show quoted text
> On Tue Jan 16 17:21:32 2018, mikem@airspayce.com wrote:
> > Hello Joel, > > > > > > Hmmm, we dontr see that behaviour here: the test suite runs > > completley > > correctly. > > > > Can you send me the output of: > > > > perl -w -I blib/lib -I blib/arch t/local/04_basic.t
> > It was deep from within our Jenkins build, but just counting the > number of tests following the skip it seems fairly obvious that you've > miscounted. Can you confirm that you have tested without > Test::Exception? If not I can try to reproduce elsewhere myself.
Oh well, here it is anyway. Manually removed Test::Exception (cpanm -U Test::Exception) on an otherwise fairly standard Perl 5.26.0. $ prove -vb t/local/04_basic.t t/local/04_basic.t .. 1..14 ok 1 # skip Need Test::Exception for the some tests ok 2 # skip Need Test::Exception for the some tests ok 3 # skip Need Test::Exception for the some tests ok 4 # skip Need Test::Exception for the some tests ok 5 # skip Need Test::Exception for the some tests ok 6 - hello world ok 7 # skip Only on OpenSSL 1.1.0 or later ok 8 # skip Only on OpenSSL 1.1.0 or later ok 9 # skip Only on OpenSSL 1.1.0 or later ok 10 # skip Only on OpenSSL 1.1.0 or later ok 11 # skip Only on OpenSSL 1.1.0 or later ok 12 # skip Only on OpenSSL 1.1.0 or later ok 13 # skip Only on OpenSSL 1.1.0 or later # Looks like you planned 14 tests but ran 13. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 1/14 subtests (less 12 skipped subtests: 1 okay) Test Summary Report ------------------- t/local/04_basic.t (Wstat: 65280 Tests: 13 Failed: 0) Non-zero exit status: 255 Parse errors: Bad plan. You planned 14 tests but ran 13. Files=1, Tests=13, 0 wallclock secs ( 0.03 usr 0.01 sys + 0.04 cusr 0.00 csys = 0.08 CPU) Result: FAIL As I said in the initial message, you see that it issues 5 skip tests for Test::Exception but your SKIP block contains 6 tests. The plan clearly expects there to be 6 tests. I believe that you've miscounted the number of test skips to emit. Show quoted text
>
> > > > Cheers. > > > > On Wednesday, 17 January 2018 02:21:16 AEST you wrote:
> > > Tue Jan 16 11:21:14 2018: Request 124101 was acted upon. > > > Transaction: Ticket created by JBERGER > > > Queue: Net-SSLeay > > > Subject: (No subject given) > > > Broken in: 1.83 > > > Severity: Important > > > Owner: Nobody > > > Requestors: JBERGER@cpan.org > > > Status: new > > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124101 > > > > > > > > > > I'm seeing a test failure in Net::SSLeay, I'm getting the following > > > output: > > > > > > Test Summary Report > > > ------------------- > > > t/local/04_basic.t (Wstat: 65280 Tests: 13 > > > Failed: > > > 0) > > > Non-zero exit status: 255 > > > Parse errors: Bad plan. You planned 14 tests but ran 13. > > > > > > Looking at that test it appears that you have miscounted the skip > > > if > > > Test::Exception is not loadable > > > https://metacpan.org/source/MIKEM/Net-SSLeay- > > > 1.83/t/local/04_basic.t#L11 . > > > That count should be 6 not 5. Hopefully this should be a quick fix. > > > In the > > > meantime I think installing that test module should get us through > > > our > > > build process. > > > > > > Cheers, > > > Joel Berger
Subject: Re: [rt.cpan.org #124101]
Date: Wed, 17 Jan 2018 08:56:13 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 3.9k
Thanks Joel, Ive now been able to reproduce and fix this error. Fix is now in SVN 515. Cheers. On Wednesday, 17 January 2018 08:36:33 AEST you wrote: Show quoted text
> Queue: Net-SSLeay > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124101 > > > On Tue Jan 16 17:25:49 2018, JBERGER wrote:
> > On Tue Jan 16 17:21:32 2018, mikem@airspayce.com wrote:
> > > Hello Joel, > > > > > > > > > Hmmm, we dontr see that behaviour here: the test suite runs > > > completley > > > correctly. > > > > > > Can you send me the output of: > > > > > > perl -w -I blib/lib -I blib/arch t/local/04_basic.t
> > > > It was deep from within our Jenkins build, but just counting the > > number of tests following the skip it seems fairly obvious that you've > > miscounted. Can you confirm that you have tested without > > Test::Exception? If not I can try to reproduce elsewhere myself.
> > Oh well, here it is anyway. Manually removed Test::Exception (cpanm -U > Test::Exception) on an otherwise fairly standard Perl 5.26.0. > > $ prove -vb t/local/04_basic.t > t/local/04_basic.t .. > 1..14 > ok 1 # skip Need Test::Exception for the some tests > ok 2 # skip Need Test::Exception for the some tests > ok 3 # skip Need Test::Exception for the some tests > ok 4 # skip Need Test::Exception for the some tests > ok 5 # skip Need Test::Exception for the some tests > ok 6 - hello world > ok 7 # skip Only on OpenSSL 1.1.0 or later > ok 8 # skip Only on OpenSSL 1.1.0 or later > ok 9 # skip Only on OpenSSL 1.1.0 or later > ok 10 # skip Only on OpenSSL 1.1.0 or later > ok 11 # skip Only on OpenSSL 1.1.0 or later > ok 12 # skip Only on OpenSSL 1.1.0 or later > ok 13 # skip Only on OpenSSL 1.1.0 or later > # Looks like you planned 14 tests but ran 13. > Dubious, test returned 255 (wstat 65280, 0xff00) > Failed 1/14 subtests > (less 12 skipped subtests: 1 okay) > > Test Summary Report > ------------------- > t/local/04_basic.t (Wstat: 65280 Tests: 13 Failed: 0) > Non-zero exit status: 255 > Parse errors: Bad plan. You planned 14 tests but ran 13. > Files=1, Tests=13, 0 wallclock secs ( 0.03 usr 0.01 sys + 0.04 cusr 0.00 > csys = 0.08 CPU) Result: FAIL > > As I said in the initial message, you see that it issues 5 skip tests for > Test::Exception but your SKIP block contains 6 tests. The plan clearly > expects there to be 6 tests. I believe that you've miscounted the number of > test skips to emit.
> > > Cheers. > > > > > > On Wednesday, 17 January 2018 02:21:16 AEST you wrote:
> > > > Tue Jan 16 11:21:14 2018: Request 124101 was acted upon. > > > > Transaction: Ticket created by JBERGER > > > > > > > > Queue: Net-SSLeay > > > > > > > > Subject: (No subject given) > > > > > > > > Broken in: 1.83 > > > > > > > > Severity: Important > > > > > > > > Owner: Nobody > > > > > > > > Requestors: JBERGER@cpan.org > > > > > > > > Status: new > > > > > > > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=124101 > > > > > > > > > I'm seeing a test failure in Net::SSLeay, I'm getting the following > > > > output: > > > > > > > > Test Summary Report > > > > ------------------- > > > > t/local/04_basic.t (Wstat: 65280 Tests: 13 > > > > Failed: > > > > 0) > > > > > > > > Non-zero exit status: 255 > > > > Parse errors: Bad plan. You planned 14 tests but ran 13. > > > > > > > > Looking at that test it appears that you have miscounted the skip > > > > if > > > > Test::Exception is not loadable > > > > https://metacpan.org/source/MIKEM/Net-SSLeay-> > > > 1.83/t/local/04_basic.t#L11 . > > > > That count should be 6 not 5. Hopefully this should be a quick fix. > > > > In the > > > > meantime I think installing that test module should get us through > > > > our > > > > build process. > > > > > > > > Cheers, > > > > Joel Berger
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.