Skip Menu |
 

This queue is for tickets about the DBIx-DataModel CPAN distribution.

Report information
The Basics
Id: 123991
Status: open
Priority: 0/
Queue: DBIx-DataModel

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Can't locate MyApp/Schema (2.47_01)
Download (untitled) / with headers
text/plain 513b
t/v2_generator.t fails in the latest devel version: ... DBIx::DataModel::Schema::Generator::parse_DBIx_Class(): Can't locate MyApp/Schema.pm in @INC (@INC contains: ... .) at /usr/perl5.16.3t/lib/site_perl/5.16.3/Module/Load.pm line 77. Can't locate MyApp/Schema in @INC (@INC contains: ... .) at /usr/perl5.16.3t/lib/site_perl/5.16.3/Module/Load.pm line 77. # Looks like your test exited with 2 just after 7. t/v2_generator.t .............. Dubious, test returned 2 (wstat 512, 0x200) Failed 2/9 subtests ...
Download (untitled) / with headers
text/plain 1.7k
On 2018-01-01 15:03:17, SREZIC wrote: Show quoted text
> t/v2_generator.t fails in the latest devel version: > > ... > DBIx::DataModel::Schema::Generator::parse_DBIx_Class(): Can't locate > MyApp/Schema.pm in @INC (@INC contains: ... .) at > /usr/perl5.16.3t/lib/site_perl/5.16.3/Module/Load.pm line 77. > Can't locate MyApp/Schema in @INC (@INC contains: ... .) at > /usr/perl5.16.3t/lib/site_perl/5.16.3/Module/Load.pm line 77. > # Looks like your test exited with 2 just after 7. > t/v2_generator.t .............. > Dubious, test returned 2 (wstat 512, 0x200) > Failed 2/9 subtests > ...
On some of my smokers there are additional test failures: DBIx::DataModel::Source::__ANON__(): didn't find any ResultAs subclass to implement -result_as => 'hashref' at t/v1_DBIx-DataModel.t line 386 # Looks like your test exited with 2 just after 53. t/v1_DBIx-DataModel.t ......... Dubious, test returned 2 (wstat 512, 0x200) Failed 70/123 subtests DBIx::DataModel::Source::__ANON__(): didn't find any ResultAs subclass to implement -result_as => 'hashref' at t/v2_Dbix-DataModel.t line 375 # Looks like your test exited with 2 just after 48. t/v2_Dbix-DataModel.t ......... Dubious, test returned 2 (wstat 512, 0x200) Failed 72/120 subtests # No tests run! # Failed test 'No tests run for subtest "hashref"' # at t/v2_result_as.t line 141. DBIx::DataModel::ConnectedSource::AUTOLOAD(): didn't find any ResultAs subclass to implement -result_as => 'hashref' at t/v2_result_as.t line 138 # Tests were run but no plan was declared and done_testing() was not seen. # Looks like your test exited with 255 just after 7. t/v2_result_as.t .............. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 1/7 subtests (less 2 skipped subtests: 4 okay)
Subject: Re: [rt.cpan.org #123991] Can't locate MyApp/Schema (2.47_01)
Date: Tue, 2 Jan 2018 14:55:03 +0100 (CET)
To: bug-DBIx-DataModel [...] rt.cpan.org
From: laurent.dami [...] free.fr
Thanks for warning me. v2.47_03, just published to CPAN, should solve both problems. Laurent D. Show quoted text
----- Mail original ----- De: "Slaven_Rezic via RT" <bug-DBIx-DataModel@rt.cpan.org> Envoyé: Lundi 1 Janvier 2018 21:04:54 Objet: [rt.cpan.org #123991] Can't locate MyApp/Schema (2.47_01) Queue: DBIx-DataModel Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=123991 > On 2018-01-01 15:03:17, SREZIC wrote:
> t/v2_generator.t fails in the latest devel version: > > ... > DBIx::DataModel::Schema::Generator::parse_DBIx_Class(): Can't locate > MyApp/Schema.pm in @INC (@INC contains: ... .) at > /usr/perl5.16.3t/lib/site_perl/5.16.3/Module/Load.pm line 77. > Can't locate MyApp/Schema in @INC (@INC contains: ... .) at > /usr/perl5.16.3t/lib/site_perl/5.16.3/Module/Load.pm line 77. > # Looks like your test exited with 2 just after 7. > t/v2_generator.t .............. > Dubious, test returned 2 (wstat 512, 0x200) > Failed 2/9 subtests > ...
On some of my smokers there are additional test failures: DBIx::DataModel::Source::__ANON__(): didn't find any ResultAs subclass to implement -result_as => 'hashref' at t/v1_DBIx-DataModel.t line 386 # Looks like your test exited with 2 just after 53. t/v1_DBIx-DataModel.t ......... Dubious, test returned 2 (wstat 512, 0x200) Failed 70/123 subtests DBIx::DataModel::Source::__ANON__(): didn't find any ResultAs subclass to implement -result_as => 'hashref' at t/v2_Dbix-DataModel.t line 375 # Looks like your test exited with 2 just after 48. t/v2_Dbix-DataModel.t ......... Dubious, test returned 2 (wstat 512, 0x200) Failed 72/120 subtests # No tests run! # Failed test 'No tests run for subtest "hashref"' # at t/v2_result_as.t line 141. DBIx::DataModel::ConnectedSource::AUTOLOAD(): didn't find any ResultAs subclass to implement -result_as => 'hashref' at t/v2_result_as.t line 138 # Tests were run but no plan was declared and done_testing() was not seen. # Looks like your test exited with 255 just after 7. t/v2_result_as.t .............. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 1/7 subtests (less 2 skipped subtests: 4 okay)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.