Skip Menu |
 

This queue is for tickets about the Hash-Merge CPAN distribution.

Report information
The Basics
Id: 123915
Status: resolved
Priority: 0/
Queue: Hash-Merge

People
Owner: Nobody in particular
Requestors: William.Wilson [...] nau.edu
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.300



Subject: Error with compile and install of Hash::Merge
Date: Tue, 19 Dec 2017 20:34:31 +0000
To: "bug-Hash-Merge [...] rt.cpan.org" <bug-Hash-Merge [...] rt.cpan.org>
From: William Edward Wilson <William.Wilson [...] nau.edu>
Download (untitled) / with headers
text/plain 2.3k
When using cpan to install Hash::Merge, the install fails with the following output: CPAN: Storable loaded ok (v2.51) Going to read '/root/.cpan/Metadata' Database was generated on Tue, 19 Dec 2017 18:53:49 GMT Running install for module 'Hash::Merge' CPAN: YAML loaded ok (v1.24) Running make for H/HE/HERMES/Hash-Merge-0.299.tar.gz CPAN: Digest::SHA loaded ok (v5.47) CPAN: Compress::Zlib loaded ok (v2.021) Checksum for /root/.cpan/sources/authors/id/H/HE/HERMES/Hash-Merge-0.299.tar.gz ok CPAN: Archive::Tar loaded ok (v1.58) Hash-Merge-0.299/ Hash-Merge-0.299/MANIFEST Hash-Merge-0.299/MANIFEST.SKIP Hash-Merge-0.299/MAINTAINER.md Hash-Merge-0.299/META.yml Hash-Merge-0.299/Changes Hash-Merge-0.299/Makefile.PL Hash-Merge-0.299/t/ Hash-Merge-0.299/t/ClonePP/ Hash-Merge-0.299/t/ClonePP/00-load.t Hash-Merge-0.299/t/ClonePP/01-merge.t Hash-Merge-0.299/t/ClonePP/02-oo.t Hash-Merge-0.299/t/Auto/ Hash-Merge-0.299/t/Auto/00-load.t Hash-Merge-0.299/t/Auto/01-merge.t Hash-Merge-0.299/t/Auto/02-oo.t Hash-Merge-0.299/t/Clone/ Hash-Merge-0.299/t/Clone/00-load.t Hash-Merge-0.299/t/Clone/01-merge.t Hash-Merge-0.299/t/Clone/02-oo.t Hash-Merge-0.299/t/inline/ Hash-Merge-0.299/t/inline/00-load.t Hash-Merge-0.299/t/inline/01-merge.t Hash-Merge-0.299/t/inline/02-oo.t Hash-Merge-0.299/t/Storable/ Hash-Merge-0.299/t/Storable/00-load.t Hash-Merge-0.299/t/Storable/01-merge.t Hash-Merge-0.299/t/Storable/02-oo.t Hash-Merge-0.299/META.json Hash-Merge-0.299/README.md Hash-Merge-0.299/lib/ Hash-Merge-0.299/lib/Hash/ Hash-Merge-0.299/lib/Hash/Merge.pm CPAN: File::Temp loaded ok (v0.22) CPAN.pm: Going to build H/HE/HERMES/Hash-Merge-0.299.tar.gz WARNING: TEST_REQUIRES is not a known parameter. WARNING: AUTHOR takes a string/number not a ARRAY reference. Please inform the author. Checking if your kit is complete... Looks good 'TEST_REQUIRES' is not a known MakeMaker parameter name. only nested arrays of non-refs are supported at /usr/share/perl5/ExtUtils/MakeMaker.pm line 684. Warning: No success on command[/usr/bin/perl Makefile.PL INSTALLDIRS=site] HERMES/Hash-Merge-0.299.tar.gz /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK Running make test Make had some problems, won't test Running make install Make had some problems, won't install We are on a Centos 6 machine. We have not had issues installing other perl modules.
Download (untitled) / with headers
text/plain 2.8k
Hello William, at a first glace this looks like your version of ExtUtils::MakeMaker is too old. What is the output of the following command: perl -MExtUtils::MakeMaker -e 'print $ExtUtils::MakeMaker::VERSION' If the output is something less than 6.64 you need to update ExtUtils::MakeMaker before trying to install Hash::Merge. Best regards, Stefan Am Di 19. Dez 2017, 15:34:50, William.Wilson@nau.edu schrieb: Show quoted text
> When using cpan to install Hash::Merge, the install fails with the > following output: > > CPAN: Storable loaded ok (v2.51) > Going to read '/root/.cpan/Metadata' > Database was generated on Tue, 19 Dec 2017 18:53:49 GMT > Running install for module 'Hash::Merge' > CPAN: YAML loaded ok (v1.24) > Running make for H/HE/HERMES/Hash-Merge-0.299.tar.gz > CPAN: Digest::SHA loaded ok (v5.47) > CPAN: Compress::Zlib loaded ok (v2.021) > Checksum for /root/.cpan/sources/authors/id/H/HE/HERMES/Hash-Merge- > 0.299.tar.gz ok > CPAN: Archive::Tar loaded ok (v1.58) > Hash-Merge-0.299/ > Hash-Merge-0.299/MANIFEST > Hash-Merge-0.299/MANIFEST.SKIP > Hash-Merge-0.299/MAINTAINER.md > Hash-Merge-0.299/META.yml > Hash-Merge-0.299/Changes > Hash-Merge-0.299/Makefile.PL > Hash-Merge-0.299/t/ > Hash-Merge-0.299/t/ClonePP/ > Hash-Merge-0.299/t/ClonePP/00-load.t > Hash-Merge-0.299/t/ClonePP/01-merge.t > Hash-Merge-0.299/t/ClonePP/02-oo.t > Hash-Merge-0.299/t/Auto/ > Hash-Merge-0.299/t/Auto/00-load.t > Hash-Merge-0.299/t/Auto/01-merge.t > Hash-Merge-0.299/t/Auto/02-oo.t > Hash-Merge-0.299/t/Clone/ > Hash-Merge-0.299/t/Clone/00-load.t > Hash-Merge-0.299/t/Clone/01-merge.t > Hash-Merge-0.299/t/Clone/02-oo.t > Hash-Merge-0.299/t/inline/ > Hash-Merge-0.299/t/inline/00-load.t > Hash-Merge-0.299/t/inline/01-merge.t > Hash-Merge-0.299/t/inline/02-oo.t > Hash-Merge-0.299/t/Storable/ > Hash-Merge-0.299/t/Storable/00-load.t > Hash-Merge-0.299/t/Storable/01-merge.t > Hash-Merge-0.299/t/Storable/02-oo.t > Hash-Merge-0.299/META.json > Hash-Merge-0.299/README.md > Hash-Merge-0.299/lib/ > Hash-Merge-0.299/lib/Hash/ > Hash-Merge-0.299/lib/Hash/Merge.pm > CPAN: File::Temp loaded ok (v0.22) > > CPAN.pm: Going to build H/HE/HERMES/Hash-Merge-0.299.tar.gz > > WARNING: TEST_REQUIRES is not a known parameter. > WARNING: AUTHOR takes a string/number not a ARRAY reference. > Please inform the author. > Checking if your kit is complete... > Looks good > 'TEST_REQUIRES' is not a known MakeMaker parameter name. > only nested arrays of non-refs are supported at > /usr/share/perl5/ExtUtils/MakeMaker.pm line 684. > Warning: No success on command[/usr/bin/perl Makefile.PL > INSTALLDIRS=site] > HERMES/Hash-Merge-0.299.tar.gz > /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK > Running make test > Make had some problems, won't test > Running make install > Make had some problems, won't install > > > We are on a Centos 6 machine. We have not had issues installing other > perl modules.
Subject: Re: [rt.cpan.org #123915] Error with compile and install of Hash::Merge
Date: Wed, 20 Dec 2017 15:01:59 +0000
To: "bug-Hash-Merge [...] rt.cpan.org" <bug-Hash-Merge [...] rt.cpan.org>
From: William Edward Wilson <William.Wilson [...] nau.edu>
Download (untitled) / with headers
text/plain 228b
I ran the suggested command and the version we have is 6.98. On 12/20/17, 1:38 AM, "Stefan Hermes via RT" <bug-Hash-Merge@rt.cpan.org> wrote: perl -MExtUtils::MakeMaker -e 'print $ExtUtils::MakeMaker::VERSION'
Download (untitled) / with headers
text/plain 1.1k
On Wed Dec 20 10:02:25 2017, William.Wilson@nau.edu wrote: Show quoted text
> On 12/20/17, 1:38 AM, "Stefan Hermes via RT" <bug-Hash-Merge@rt.cpan.org> wrote: >
> > perl -MExtUtils::MakeMaker -e 'print $ExtUtils::MakeMaker::VERSION'
> > I ran the suggested command and the version we have is 6.98.
Smells as if there is a discrepancy between the ExtUtils::MakeMaker used when installing Hash::Merge via CPAN and the ExtUtils::MakeMaker in your perl include path (Scan https://metacpan.org/source/BINGOS/ExtUtils-MakeMaker-7.30/Changes for TEST_REQUIRES if you need to guess why). Please run also a $ perl -MExtUtils::MakeMaker -le 'print $INC{"ExtUtils/MakeMaker.pm"}' In doubt, there are two independent issues. The first one is the missing ExtUtils::MakeMaker prereq definition in the META.yml - the other one is your grown and weird environment. While we can fix the first issue in not to distant future, but this will likely not help you in your particular situation. I suggest to go to #perl-help channel on irc.perl.org and try to get your environment fixed soon. This will help you directly and you can go ahead instead of waiting for a fix.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.