Skip Menu |
 

This queue is for tickets about the Net-SMTP-SSL CPAN distribution.

Report information
The Basics
Id: 123853
Status: new
Priority: 0/
Queue: Net-SMTP-SSL

People
Owner: Nobody in particular
Requestors: KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Deprecation notes leave version confusion around Net::SMTP

The deprecation notes state that native SSL/STARTLS support have been available since Net::SMTP 1.28, however, Net::SMTP never existed with a version lower than 2.0

https://metacpan.org/pod/release/GBARR/libnet-1.00/Net/SMTP.pm

This is of course due to the discrepancy between the version stated on the libnet distribution and on Net::SMTP itself.

Perhaps its intended that it means libnet-1.28 , which was released around the date stated in the deprecation notice.

But this would mean the appropriate notice would be:

 

"Since Net::SMTP 2.35 ( libnet 1.28 @ 2014-10-08 )"

 

Or similar.

https://metacpan.org/source/SHAY/libnet-1.28/lib/Net/SMTP.pm#L23


The difference is demonstrable here:

 

 cpanm --look --dev 'Net::SMTP@1.28'
! Finding Net::SMTP (== 1.28) on cpanmetadb failed.
Found Net::SMTP 3.11 which doesn't satisfy == 1.28.

 
 cpanm --look --dev 'Net::SMTP@2.35'
--> Working on Net::SMTP
Fetching http://backpan.perl.org/authors/id/S/SH/SHAY/libnet-1.28.tar.gz ... OK
Entering /home/kent/.cpanm/work/1512906359.15340/libnet-1.28 with /bin/bash

-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
 

 


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.