Skip Menu |
 

This queue is for tickets about the Win32-IPC CPAN distribution.

Report information
The Basics
Id: 123720
Status: open
Priority: 0/
Queue: Win32-IPC

People
Owner: Nobody in particular
Requestors: tom.moreau [...] live.ca
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Problem Installing Module
Date: Thu, 23 Nov 2017 11:18:51 +0000
To: "bug-Win32-IPC [...] rt.cpan.org" <bug-Win32-IPC [...] rt.cpan.org>
From: Tom Moreau <tom.moreau [...] live.ca>
Download (untitled) / with headers
text/plain 261b
I am having a problem installing the module on a particular server. It installs fine on my PC. Attached is the log file. Tom Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCITP, MCTS Cambridge, ON Canada tom.moreau@live.ca<mailto:tom.moreau@live.ca>
Download .cpanm.7z
application/octet-stream 53.8k

Message body not shown because it is not plain text.

Subject: [rt.cpan.org #123720] Problem Installing Module
Date: Fri, 24 Nov 2017 14:43:44 +0000
To: "bug-Win32-IPC [...] rt.cpan.org" <bug-Win32-IPC [...] rt.cpan.org>
From: Tom Moreau <tom.moreau [...] live.ca>
Download (untitled) / with headers
text/plain 365b
I have found a workaround. 1. Extracted the .tar file from the .gz file. 2. Extracted the Win32-IPC-1.11 folder from the .tar file. 3. Tried to run perl Build.pl. It failed. Long story short, I added... use lib '.'; ... to Build.pl and ran it successfully. 4. Followed the steps in the README file: a) .\Build b) .\Build test c) .\Build install
Subject: Re: [rt.cpan.org #123720] Problem Installing Module
Date: Sat, 25 Nov 2017 20:06:32 -0800
To: bug-Win32-IPC [...] rt.cpan.org
From: Jan Dubois <jan [...] jandubois.com>
Download (untitled) / with headers
text/plain 932b
Hi Thomas, Thank you for your bug report, and the workaround. The problem happens because in Perl 5.26 and later '.' is no longer included in @INC by default. I suspect that on your PC you have an older version of Perl installed, which is why you don't see the problem there. Cheers, -Jan On Fri, Nov 24, 2017 at 6:43 AM, Tom Moreau via RT < bug-Win32-IPC@rt.cpan.org> wrote: Show quoted text
> Queue: Win32-IPC > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=123720 > > > I have found a workaround. > > 1. Extracted the .tar file from the .gz file. > 2. Extracted the Win32-IPC-1.11 folder from the .tar file. > 3. Tried to run perl Build.pl. It failed. Long story short, I > added... > use lib '.'; > ... to Build.pl and ran it successfully. > 4. Followed the steps in the README file: > a) .\Build > b) .\Build test > c) .\Build install >
Subject: RE: [rt.cpan.org #123720] Problem Installing Module
Date: Sun, 26 Nov 2017 12:03:49 +0000
To: "bug-Win32-IPC [...] rt.cpan.org" <bug-Win32-IPC [...] rt.cpan.org>
From: Tom Moreau <tom.moreau [...] live.ca>
I'm using version v5.26.1 of Strawberry Perl. I used to have an older copy of ActiveState but I had removed it.      Tom     Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCITP, MCTS Cambridge, ON Canada    tom.moreau@live.ca Show quoted text
-----Original Message----- From: Jan Dubois via RT [mailto:bug-Win32-IPC@rt.cpan.org] Sent: November 25, 2017 23:07 To: tom.moreau@live.ca Subject: Re: [rt.cpan.org #123720] Problem Installing Module <URL: https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Frt.cpan.org%2FTicket%2FDisplay.html%3Fid%3D123720&data=02%7C01%7Ctom.moreau%40live.ca%7Cf13099cb152d4663e4bb08d534831f72%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636472660125121792&sdata=3tUxj0kJWZES%2FbdLpwYlr%2F0vsNQNkmu257ddZLK70GE%3D&reserved=0 > Hi Thomas, Thank you for your bug report, and the workaround. The problem happens because in Perl 5.26 and later '.' is no longer included in @INC by default. I suspect that on your PC you have an older version of Perl installed, which is why you don't see the problem there. Cheers, -Jan


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.