Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 123588
Status: rejected
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: Robert.Graf [...] s-itsolutions.at
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Bug ... required modules going round in circles
Date: Fri, 10 Nov 2017 17:10:32 +0100
To: "bug-Module-Build [...] rt.cpan.org" <bug-Module-Build [...] rt.cpan.org>
From: Graf Robert 6318 sIT <Robert.Graf [...] s-itsolutions.at>
Download (untitled) / with headers
text/plain 1.3k
Hi, perl Build.PL install_base=/home/sm9ac/Perl/v1 => [sm9ac@sec001d Module-Build-0.4224]$ perl Build.PL install_base=/home/sm9ac/Perl/v1 *** BOOTSTRAPPING Perl::OSType *** *** BOOTSTRAPPING version *** *** BOOTSTRAPPING Module::Metadata *** Can't locate ExtUtils/Manifest.pm in @INC (@INC contains: t/lib t/bundled lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at lib/Module/Build/Base.pm line 1975. These additional prerequisites must be installed: requires: ! Perl::OSType (we need version 1.00) ! version (we need version 0.87) ! Module::Metadata (we need version 1.000002) -) Want to install DBI.pm .. MakeMaker.PL (=ExtUtils::MakeMaker) required -) Want to install ExtUtils::MakeMaker ... "make test" requires Test::Harness -) Want to install Test::Harness ... =ExtUtils::MakeMaker required .. funny (a requires b and vice versa - reported it) -) Tried to build Test::Harness with Module::Build .. -) Want to install Module-Build (see above) .. ExtUtils::Manifest required -) Want to install ExtUtils::Manifest .. =ExtUtils::MakeMaker required again ... Sorry - but I'm going round in circles .. So can someone explain how to install a module from cpan without circle dependencies? I'm using RH 7.3 with Perl 5.16.3.
Subject: Re: [rt.cpan.org #123588] Bug ... required modules going round in circles
Date: Fri, 10 Nov 2017 17:31:02 +0100
To: bug-Module-Build [...] rt.cpan.org
From: Leon Timmermans <leont [...] cpan.org>
Download (untitled) / with headers
text/plain 1.6k
On Fri, Nov 10, 2017 at 5:26 PM, Graf Robert SECA sIT via RT < bug-Module-Build@rt.cpan.org> wrote: Show quoted text
> Hi, > > perl Build.PL install_base=/home/sm9ac/Perl/v1 > > => > > [sm9ac@sec001d Module-Build-0.4224]$ perl Build.PL > install_base=/home/sm9ac/Perl/v1 > *** BOOTSTRAPPING Perl::OSType *** > *** BOOTSTRAPPING version *** > *** BOOTSTRAPPING Module::Metadata *** > Can't locate ExtUtils/Manifest.pm in @INC (@INC contains: t/lib t/bundled > lib /usr/local/lib64/perl5 /usr/local/share/perl5 > /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 > /usr/share/perl5 .) at lib/Module/Build/Base.pm line 1975. > These additional prerequisites must be installed: > requires: > ! Perl::OSType (we need version 1.00) > ! version (we need version 0.87) > ! Module::Metadata (we need version 1.000002) > -) Want to install DBI.pm .. MakeMaker.PL (=ExtUtils::MakeMaker) required > -) Want to install ExtUtils::MakeMaker ... "make test" requires > Test::Harness > -) Want to install Test::Harness ... =ExtUtils::MakeMaker required .. > funny (a requires b and vice versa - reported it) > -) Tried to build Test::Harness with Module::Build .. > -) Want to install Module-Build (see above) .. ExtUtils::Manifest required > -) Want to install ExtUtils::Manifest .. =ExtUtils::MakeMaker required > again ... > > Sorry - but I'm going round in circles .. > > So can someone explain how to install a module from cpan without circle > dependencies? > > I'm using RH 7.3 with Perl 5.16.3. >
By default Red Hat doesn't install all parts that usually ship with perl; what you're observing is a direct consequence of that unfortunate decision. If you install the perl-core package your problems should go away. Leon
Subject: AW: [rt.cpan.org #123588] Bug ... required modules going round in circles
Date: Fri, 10 Nov 2017 17:34:22 +0100
To: "bug-Module-Build [...] rt.cpan.org" <bug-Module-Build [...] rt.cpan.org>
From: Graf Robert 6318 sIT <Robert.Graf [...] s-itsolutions.at>
Thanks a lot, I will ask our OS people what they are installing in our bank ... Robert Show quoted text
-----Ursprüngliche Nachricht----- Von: Leon Timmermans via RT [mailto:bug-Module-Build@rt.cpan.org] Gesendet: Freitag, 10. November 2017 17:32 An: Graf Robert 6318 sIT Betreff: Re: [rt.cpan.org #123588] Bug ... required modules going round in circles <URL: https://rt.cpan.org/Ticket/Display.html?id=123588 > On Fri, Nov 10, 2017 at 5:26 PM, Graf Robert SECA sIT via RT < bug-Module-Build@rt.cpan.org> wrote:
> Hi, > > perl Build.PL install_base=/home/sm9ac/Perl/v1 > > => > > [sm9ac@sec001d Module-Build-0.4224]$ perl Build.PL > install_base=/home/sm9ac/Perl/v1 > *** BOOTSTRAPPING Perl::OSType *** > *** BOOTSTRAPPING version *** > *** BOOTSTRAPPING Module::Metadata *** > Can't locate ExtUtils/Manifest.pm in @INC (@INC contains: t/lib t/bundled > lib /usr/local/lib64/perl5 /usr/local/share/perl5 > /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 > /usr/share/perl5 .) at lib/Module/Build/Base.pm line 1975. > These additional prerequisites must be installed: > requires: > ! Perl::OSType (we need version 1.00) > ! version (we need version 0.87) > ! Module::Metadata (we need version 1.000002) > -) Want to install DBI.pm .. MakeMaker.PL (=ExtUtils::MakeMaker) required > -) Want to install ExtUtils::MakeMaker ... "make test" requires > Test::Harness > -) Want to install Test::Harness ... =ExtUtils::MakeMaker required .. > funny (a requires b and vice versa - reported it) > -) Tried to build Test::Harness with Module::Build .. > -) Want to install Module-Build (see above) .. ExtUtils::Manifest required > -) Want to install ExtUtils::Manifest .. =ExtUtils::MakeMaker required > again ... > > Sorry - but I'm going round in circles .. > > So can someone explain how to install a module from cpan without circle > dependencies? > > I'm using RH 7.3 with Perl 5.16.3. >
By default Red Hat doesn't install all parts that usually ship with perl; what you're observing is a direct consequence of that unfortunate decision. If you install the perl-core package your problems should go away. Leon


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.