Skip Menu |
 

This queue is for tickets about the Mylisp CPAN distribution.

Report information
The Basics
Id: 123184
Status: new
Priority: 0/
Queue: Mylisp

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.0
Fixed in: (no value)



Subject: Tests fail with Spp < 2.0
Download (untitled) / with headers
text/plain 1.3k
Tests fail with older Spp, e.g. 1.22, so the minimum prereq version needs to be adjusted: ... Bailout called. Further testing stopped: # Failed test 'use Mylisp;' # at t/00-load.t line 10. # Tried to use 'Mylisp'. # Error: "match_text" is not exported by the Spp module # "spp_to_ast" is not exported by the Spp module # Can't continue after import errors at /home/cpansand/.cpan/build/2017100309/Mylisp-2.0-0/blib/lib/Mylisp.pm line 11. # BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2017100309/Mylisp-2.0-0/blib/lib/Mylisp.pm line 11. # Compilation failed in require at t/00-load.t line 10. # BEGIN failed--compilation aborted at t/00-load.t line 10. # Failed test 'use Mylisp::Lint;' # at t/00-load.t line 15. # Tried to use 'Mylisp::Lint'. # Error: "to_end" is not exported by the Spp::Builtin module # Can't continue after import errors at /home/cpansand/.cpan/build/2017100309/Mylisp-2.0-0/blib/lib/Mylisp/Lint.pm line 12. # BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2017100309/Mylisp-2.0-0/blib/lib/Mylisp/Lint.pm line 12. # Compilation failed in require at t/00-load.t line 15. # BEGIN failed--compilation aborted at t/00-load.t line 15. # Testing Spp 1.22, Perl 5.026000, /usr/perl5.26.0p/bin/perl5.26.0 # Looks like you failed 2 tests of 7. FAILED--Further testing stopped. ...


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.