Skip Menu |
 

This queue is for tickets about the Log-Any-Adapter-LinuxJournal CPAN distribution.

Report information
The Basics
Id: 123181
Status: open
Priority: 0/
Queue: Log-Any-Adapter-LinuxJournal

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.172761
Fixed in: (no value)



Subject: Inconsistent prereq versions?
Download (untitled) / with headers
text/plain 655b
I see the following test failures: ... # Failed test 'Log/Any/Adapter/LinuxJournal.pm loaded ok' # at t/00-compile.t line 43. # got: '65280' # expected: '0' Log::Any::Adapter::Util version 1.700 required--this is only version 1.049 at /opt/perl-5.22.3D/lib/5.22.3/Exporter/Heavy.pm line 125. BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2017100306/Log-Any-Adapter-LinuxJournal-0.172761-p57EBm/blib/lib/Log/Any/Adapter/LinuxJournal.pm line 9. Compilation failed in require at -e line 1. # Looks like you failed 1 test of 1. t/00-compile.t ......... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests ...
Download (untitled) / with headers
text/plain 426b
The basic problem here is that this dist is relying on the Dist::Zilla [AutoPrereqs] plugin to set its prereqs, but the code includes the line use Log::Any::Adapter::Util '1.700'; This is not a normal version prereq, so AutoPrereqs doesn't catch it. It relies on a special case of Exporter.pm to work. Removing the quotes from the version prereq should allow it to work properly and for AutoPrereqs to see it properly.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.