Skip Menu |
 

This queue is for tickets about the List-MoreUtils-XS CPAN distribution.

Report information
The Basics
Id: 123130
Status: resolved
Priority: 0/
Queue: List-MoreUtils-XS

People
Owner: Nobody in particular
Requestors: alex.karelas [...] gmail.com
gortan [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 12:48:16 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 161b
This is cpanm's log from centos 4, while attempting to install List::MoreUtils (which apparently depends on List::MoreUtils::XS): https://pastebin.com/Nu4kdej7
Download (untitled) / with headers
text/plain 198b
What is the desired outcome of this ticket? Let List::MoreUtils::XS deal with ssize_t in sys/types.h for centos 4 or get List::MoreUtils installed regardless of such an issue in List::MoreUtils::XS?
Subject: Re: [rt.cpan.org #123130] AutoReply: can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 12:58:26 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 252b
Sorry, the previous message's pastebin entry will expire in 1 week. Here's a pastebin entry (with the same command repeated) that won't ever expire: https://pastebin.com/iWBGYqnM Please note that while I'm on CentOS 4 & 5, the perl version is 5.24.2
Download (untitled) / with headers
text/plain 517b
On Tue Sep 26 05:59:10 2017, alex.karelas@gmail.com wrote: Show quoted text
> Sorry, the previous message's pastebin entry will expire in 1 week. > > Here's a pastebin entry (with the same command repeated) that won't ever > expire: https://pastebin.com/iWBGYqnM > > Please note that while I'm on CentOS 4 & 5, the perl version is 5.24.2
You can easily append the log to this ticket - it will be handled as a "download". Additionally, please send me the config.log from /home/alexandrosk/.cpanm/work/1506418302.17095/ Thanks, Jens
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 13:17:33 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 691b
I would certainly be interested in having List::MoreUtils::XS be installed on Centos 4 & 5, since I'll be working on those servers for quite some more. But I have time, and I can wait for the right solution. If the right solution to fix this issue is by fixing Config::AutoConf (if it has a bug), I can wait for that. For now I'm just using a previous version of L::MU. On 26/09/2017 12:58 μμ, Jens Rehsack via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > What is the desired outcome of this ticket? Let List::MoreUtils::XS deal with ssize_t in sys/types.h for centos 4 or get List::MoreUtils installed regardless of such an issue in List::MoreUtils::XS?
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 13:26:49 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 716b
Here (attached) is the config log from the directory you requested: On 26/09/2017 01:01 μμ, Jens Rehsack via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > On Tue Sep 26 05:59:10 2017, alex.karelas@gmail.com wrote:
>> Sorry, the previous message's pastebin entry will expire in 1 week. >> >> Here's a pastebin entry (with the same command repeated) that won't ever >> expire: https://pastebin.com/iWBGYqnM >> >> Please note that while I'm on CentOS 4 & 5, the perl version is 5.24.2
> You can easily append the log to this ticket - it will be handled as a "download". Additionally, please send me the config.log from /home/alexandrosk/.cpanm/work/1506418302.17095/ > > Thanks, > Jens
Download config.log
text/x-log 30.8k

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 733b
On Tue Sep 26 06:27:33 2017, alex.karelas@gmail.com wrote: Show quoted text
> Here (attached) is the config log from the directory you requested:
That helps and shows precisely what I forgot. Please try following patch for LMU::XS List-MoreUtils-XS sno$ git diff diff --git a/inc/Config/AutoConf/LMU.pm b/inc/Config/AutoConf/LMU.pm index 312f2c7..0a93d6a 100644 --- a/inc/Config/AutoConf/LMU.pm +++ b/inc/Config/AutoConf/LMU.pm @@ -71,6 +71,7 @@ sub check_lmu_prerequisites my $self = shift->_get_instance(); $self->check_produce_loadable_xs_build() or die "Can't produce loadable XS module"; + $self->check_default_headers(); $self->check_all_headers(qw(time.h sys/time.h)); $self->check_funcs([qw(time)]); Cheers, Jens
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 15:32:14 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 1.2k
Please find attached the results of: tar xvfz LMU.tgz patch /opt/perl-5.24.2/bin/perl Makefile.pl make make test I didn't make install because I don't have local::lib yet. But the results already look a lot better than before. Do you think I should try to install as well? I wonder if there's a way to install it with carton (ie locally) On 26/09/2017 02:56 μμ, Jens Rehsack via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > On Tue Sep 26 06:27:33 2017, alex.karelas@gmail.com wrote:
>> Here (attached) is the config log from the directory you requested:
> That helps and shows precisely what I forgot. > > Please try following patch for LMU::XS > > List-MoreUtils-XS sno$ git diff > diff --git a/inc/Config/AutoConf/LMU.pm b/inc/Config/AutoConf/LMU.pm > index 312f2c7..0a93d6a 100644 > --- a/inc/Config/AutoConf/LMU.pm > +++ b/inc/Config/AutoConf/LMU.pm > @@ -71,6 +71,7 @@ sub check_lmu_prerequisites > my $self = shift->_get_instance(); > > $self->check_produce_loadable_xs_build() or die "Can't produce loadable XS module"; > + $self->check_default_headers(); > $self->check_all_headers(qw(time.h sys/time.h)); > $self->check_funcs([qw(time)]); > > > > Cheers, > Jens
Download attempt.txt
text/plain 4.7k

Message body is not shown because sender requested not to inline it.

Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 15:50:47 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 671b
I installed the patched version with carton. It worked. Carton produced an error message during installation: Successfully installed List-MU-XS-0.423 Successfully installed Exporter-Tiny-1.0000000000 Successfully installed List-MU-0.425 ! Installing the dependencies failed: Module './List-MoreUtils-XS-0.423.tar.gz' is not installed ! Bailing out the installation for /home/alexandrosk/temp/lmu. 3 distributions installed Maybe that's related to the fact that I asked it to: requires "./List-MoreUtils-XS-0.423.tar.gz"; rather than an ordinary module name I wrote a test that uses LMU and tries out the all function, and it worked. I think your patch works.
Download (untitled) / with headers
text/plain 951b
On Tue Sep 26 08:32:57 2017, alex.karelas@gmail.com wrote: Show quoted text
> Please find attached the results of: > > tar xvfz LMU.tgz > patch > /opt/perl-5.24.2/bin/perl Makefile.pl > make > make test > > I didn't make install because I don't have local::lib yet. > > But the results already look a lot better than before.
I do not see anything going wrong. So now proceed with your standard install procedure. If you have something like ~/local/prj/area - you can make install DESTDIR=... Show quoted text
> Do you think I should try to install as well? I wonder if there's a > way > to install it with carton (ie locally)
That's far beyond my knowledge. I regulary point people use something like pkgsrc, since I know how to apply patches there and that only runtime dependencies are installed during deployment - build time dependencies are on package build machine only. But if carton does it for you, keep going on it and ask how to install a distribution with a patch.
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 16:16:57 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 1.3k
I did make install DESTDIR=... and that worked, but when I tried then to make & make test the LMU (without XS), make test failed because it couldn't find LMU::XS and Exporter::Tiny. I tried setting-up PERL5LIB to the subdir of DESTDIR that ends in "lib", but that didn't change anything when I retried make test. What should I do? On 26/09/2017 03:56 μμ, Jens Rehsack via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > On Tue Sep 26 08:32:57 2017, alex.karelas@gmail.com wrote:
>> Please find attached the results of: >> >> tar xvfz LMU.tgz >> patch >> /opt/perl-5.24.2/bin/perl Makefile.pl >> make >> make test >> >> I didn't make install because I don't have local::lib yet. >> >> But the results already look a lot better than before.
> I do not see anything going wrong. So now proceed with your standard install procedure. If you have something like ~/local/prj/area - you can make install DESTDIR=... >
>> Do you think I should try to install as well? I wonder if there's a >> way >> to install it with carton (ie locally)
> That's far beyond my knowledge. I regulary point people use something like pkgsrc, since I know how to apply patches there and that only runtime dependencies are installed during deployment - build time dependencies are on package build machine only. > > But if carton does it for you, keep going on it and ask how to install a distribution with a patch. >
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 16:24:13 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
The people at #cpanm (who support carton) aren't responding, so not much progress from there either. On 26/09/2017 03:56 μμ, Jens Rehsack via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > On Tue Sep 26 08:32:57 2017, alex.karelas@gmail.com wrote:
>> Please find attached the results of: >> >> tar xvfz LMU.tgz >> patch >> /opt/perl-5.24.2/bin/perl Makefile.pl >> make >> make test >> >> I didn't make install because I don't have local::lib yet. >> >> But the results already look a lot better than before.
> I do not see anything going wrong. So now proceed with your standard install procedure. If you have something like ~/local/prj/area - you can make install DESTDIR=... >
>> Do you think I should try to install as well? I wonder if there's a >> way >> to install it with carton (ie locally)
> That's far beyond my knowledge. I regulary point people use something like pkgsrc, since I know how to apply patches there and that only runtime dependencies are installed during deployment - build time dependencies are on package build machine only. > > But if carton does it for you, keep going on it and ask how to install a distribution with a patch. >
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 16:42:49 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
I installed with: cpanm -L local bla.tgz and it succeeded (tests were included) my scripts ran successfully, as well. We are ready. On 26/09/2017 03:56 μμ, Jens Rehsack via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > On Tue Sep 26 08:32:57 2017, alex.karelas@gmail.com wrote:
>> Please find attached the results of: >> >> tar xvfz LMU.tgz >> patch >> /opt/perl-5.24.2/bin/perl Makefile.pl >> make >> make test >> >> I didn't make install because I don't have local::lib yet. >> >> But the results already look a lot better than before.
> I do not see anything going wrong. So now proceed with your standard install procedure. If you have something like ~/local/prj/area - you can make install DESTDIR=... >
>> Do you think I should try to install as well? I wonder if there's a >> way >> to install it with carton (ie locally)
> That's far beyond my knowledge. I regulary point people use something like pkgsrc, since I know how to apply patches there and that only runtime dependencies are installed during deployment - build time dependencies are on package build machine only. > > But if carton does it for you, keep going on it and ask how to install a distribution with a patch. >
Download (untitled) / with headers
text/plain 180b
Great. Maybe send a summary how you updated a patched module for carton bundles to give them a chance to update their documentation. Thank you very much for all your contribution.
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Tue, 26 Sep 2017 17:22:27 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 442b
I’ll send the summary you talk about to carton’s bug tracker. Thanks. Sent from my iPhone Show quoted text
> On 26 Sep 2017, at 4:49 PM, Jens Rehsack via RT <bug-List-MoreUtils-XS@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > Great. Maybe send a summary how you updated a patched module for carton bundles to give them a chance to update their documentation. > > Thank you very much for all your contribution.
Download (untitled) / with headers
text/plain 117b
0.425_001 is on it's way to CPAN. Try it, send test reports and sooner or later a release for the masses will be out.
Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Wed, 27 Sep 2017 18:31:53 +0300
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Alexander Karelas <alex.karelas [...] gmail.com>
Download (untitled) / with headers
text/plain 445b
"make test" succeeded - please check the attachment of this message I also installed your dev release together with LMU, and my simple scripts (checked the "all" function twice) worked. Works fine for me. On 27/09/2017 06:07 μμ, Jens Rehsack via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > 0.425_001 is on it's way to CPAN. Try it, send test reports and sooner or later a release for the masses will be out.
Download new.txt
text/plain 2.6k

Message body is not shown because sender requested not to inline it.

Subject: Re: [rt.cpan.org #123130] can't install on centos 4 & centos 5
Date: Wed, 27 Sep 2017 18:02:47 +0200
To: bug-List-MoreUtils-XS [...] rt.cpan.org
From: Jens Rehsack <rehsack [...] gmail.com>
Download (untitled) / with headers
text/plain 860b
Show quoted text
> Am 27.09.2017 um 17:32 schrieb Alexander Karelas via RT <bug-List-MoreUtils-XS@rt.cpan.org>: > > Queue: List-MoreUtils-XS > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > > > "make test" succeeded - please check the attachment of this message
I meant, install Task::CPAN::Reporter and report to cpantesters ;) Don't worry - this was more kidding than trying to force you into something :D Show quoted text
> I also installed your dev release together with LMU, and my simple > scripts (checked the "all" function twice) worked. > > Works fine for me. > > > On 27/09/2017 06:07 μμ, Jens Rehsack via RT wrote:
>> <URL: https://rt.cpan.org/Ticket/Display.html?id=123130 > >> >> 0.425_001 is on it's way to CPAN. Try it, send test reports and sooner or later a release for the masses will be out.
>
Cheers -- Jens Rehsack - rehsack@gmail.com
Download signature.asc
application/pgp-signature 801b

Message body not shown because it is not plain text.

Subject: List-MoreUtils-XS-0.423 fails to build on RHEL5/AMD64 with gcc 4.1.2
Download (untitled) / with headers
text/plain 555b
Building List-MoreUtils-XS-0.423 on my RHEL5 server fails with: XS.xs:144: error: conflicting types for ‘ssize_t’ /usr/include/sys/types.h:110: error: previous declaration of ‘ssize_t’ was here Red Hat Enterprise Linux Server release 5.10 (Tikanga) gcc version 4.1.2 20080704 (Red Hat 4.1.2-55) /proc/cpuinfo says: vendor_id : AuthenticAMD cpu family : 16 model : 9 model name : AMD Opteron(tm) Processor 6134 build.log is attached, let me know if you need further infos... I also tested 0.422, this compiles fine.
Subject: build.log
Download build.log
text/x-log 3.4k
cpanm (App::cpanminus) 1.7042 on perl 5.020002 built for x86_64-linux-thread-multi Work directory is /home/perl/.cpanm/work/1506698742.22747 You have make /usr/bin/make You have LWP 6.13 You have /bin/tar: tar (GNU tar) 1.15.1 You have /usr/bin/unzip Searching List::MoreUtils::XS () on cpanmetadb ... --> Working on List::MoreUtils::XS Fetching http://www.cpan.org/authors/id/R/RE/REHSACK/List-MoreUtils-XS-0.423.tar.gz -> OK Unpacking List-MoreUtils-XS-0.423.tar.gz Entering List-MoreUtils-XS-0.423 Checking configure dependencies from META.json Checking if you have IPC::Cmd 0 ... Yes (0.92) Checking if you have File::Spec 0 ... Yes (3.48_01) Checking if you have File::Copy 0 ... Yes (2.30) Checking if you have base 0 ... Yes (2.22) Checking if you have File::Basename 0 ... Yes (2.85) Checking if you have File::Path 0 ... Yes (2.15) Checking if you have Carp 0 ... Yes (1.3301) Checking if you have ExtUtils::MakeMaker 6.58 ... Yes (7.04) Configuring List-MoreUtils-XS-0.423 Running Makefile.PL Checking whether pureperl is required... no Checking for cc... cc Checking for cc... (cached) cc Checking whether perlapi is accessible... yes Checking for time.h... yes Checking for sys/time.h... yes Checking for time... yes Checking for size_t... yes Checking for ssize_t... no Checking for size of int... 4 Checking for size of long... 8 Checking for size of long long... 8 Checking for size of ptr... 8 Checking for builtin expect... no Checking for statement expression feature... yes Checking if your kit is complete... Looks good Have /appl/sw/perl-5.20.2-4/perl-5.20.2/lib/perl5/x86_64-linux-thread-multi Want /appl/sw/perl-5.20.2-4/perl-5.20.2/lib/5.20.2/x86_64-linux-thread-multi Your perl and your Config.pm seem to have different ideas about the architecture they are running on. Perl thinks: [x86_64-linux-thread-multi] Config says: [x86_64-linux-thread-multi] This may or may not cause problems. Please check your installation of perl if you have problems building this extension. Generating a Unix-style Makefile Writing Makefile for List::MoreUtils::XS Writing MYMETA.yml and MYMETA.json -> OK Checking dependencies from MYMETA.json ... Checking if you have Test::More 0.96 ... Yes (1.302096) Checking if you have XSLoader 0.22 ... Yes (0.24) Checking if you have Storable 0 ... Yes (2.49_01) Building and testing List-MoreUtils-XS-0.423 cp lib/List/MoreUtils/XS.pm blib/lib/List/MoreUtils/XS.pm Running Mkbootstrap for List::MoreUtils::XS () chmod 644 "XS.bs" "/appl/sw/perl-5.20.2-4/perl-5.20.2/bin/perl" "/appl/sw/perl-5.20.2-4/perl-5.20.2/lib/perl5/ExtUtils/xsubpp" -typemap "/appl/sw/perl-5.20.2-4/perl-5.20.2/lib/5.20.2/ExtUtils/typemap" XS.xs > XS.xsc && mv XS.xsc XS.c cc -c -I. -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/appl/sw/perl-5.20.2-4/db-6.1.19.NC/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"0.423\" -DXS_VERSION=\"0.423\" -fPIC "-I/appl/sw/perl-5.20.2-4/perl-5.20.2/lib/5.20.2/x86_64-linux-thread-multi/CORE" XS.c XS.xs:144: error: conflicting types for ‘ssize_t’ /usr/include/sys/types.h:110: error: previous declaration of ‘ssize_t’ was here XS.xs: In function ‘XS_List__MoreUtils__XS_samples’: XS.xs:2133: warning: passing argument 1 of ‘Perl_croak_nocontext’ from incompatible pointer type make: *** [XS.o] Error 1 -> FAIL Installing List::MoreUtils::XS failed. See /home/perl/.cpanm/work/1506698742.22747/build.log for details. Retry with --force to force install it.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.