Skip Menu |
 

This queue is for tickets about the Eval-WithLexicals CPAN distribution.

Report information
The Basics
Id: 123091
Status: patched
Priority: 0/
Queue: Eval-WithLexicals

People
Owner: Nobody in particular
Requestors: scop [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.003005
Fixed in: (no value)



Subject: Array slice with range does not work in tinyrepl
Download (untitled) / with headers
text/plain 242b
$ tinyrepl re.pl$ my @a = qw(1 2 3); 1 2 3 re.pl$ @a[0,1] 1 2 # all good here re.pl$ @a[0..1] "Error!" "String found where operator expected at (eval) line 6, near \"\$, '\$'\"\n" # oops, array slice with range not working? perl is v5.24.2
Download (untitled) / with headers
text/plain 377b
On Thu Sep 21 03:38:34 2017, SCOP wrote: Show quoted text
> $ tinyrepl > re.pl$ my @a = qw(1 2 3); > 1 > 2 > 3 > > re.pl$ @a[0,1] > 1 > 2 > # all good here > > re.pl$ @a[0..1] > "Error!" > "String found where operator expected at (eval) line 6, near \"\$, '\$'\"\n" > # oops, array slice with range not working? > > perl is v5.24.2
It fails with 5.22.4 as well, but works fine with 5.20.3.
Fixed in git.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.