Skip Menu |
 

This queue is for tickets about the Mylisp CPAN distribution.

Report information
The Basics
Id: 123004
Status: resolved
Priority: 0/
Queue: Mylisp

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.05
Fixed in: (no value)



Subject: Undeclared dependency Spp::LintParser
Tests fail without Spp::LintParser: Output from './Build test': Bailout called. Further testing stopped: # Failed test 'use Mylisp;' # at t/00-load.t line 10. # Tried to use 'Mylisp'. # Error: Can't locate Spp/LintParser.pm in @INC (you may need to install the Spp::LintParser module) (@INC contains: /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/lib /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/arch /opt/perl-5.26.1-RC1/lib/site_perl/5.26.1/x86_64-linux /opt/perl-5.26.1-RC1/lib/site_perl/5.26.1 /opt/perl-5.26.1-RC1/lib/5.26.1/x86_64-linux /opt/perl-5.26.1-RC1/lib/5.26.1) at /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/lib/Mylisp.pm line 20. # BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/lib/Mylisp.pm line 20. # Compilation failed in require at t/00-load.t line 10. # BEGIN failed--compilation aborted at t/00-load.t line 10. # Testing Spp 1.16, Perl 5.026001, /opt/perl-5.26.1-RC1/bin/perl # Looks like you failed 1 test of 6. FAILED--Further testing stopped.
Download (untitled) / with headers
text/plain 1.2k
On 2017-09-10 17:41:01, SREZIC wrote: Show quoted text
> Tests fail without Spp::LintParser: > > Output from './Build test': > > Bailout called. Further testing stopped: > > # Failed test 'use Mylisp;' > # at t/00-load.t line 10. > # Tried to use 'Mylisp'. > # Error: Can't locate Spp/LintParser.pm in @INC (you may need to > install the Spp::LintParser module) (@INC contains: > /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/lib > /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/arch > /opt/perl-5.26.1-RC1/lib/site_perl/5.26.1/x86_64-linux /opt/perl- > 5.26.1-RC1/lib/site_perl/5.26.1 /opt/perl-5.26.1- > RC1/lib/5.26.1/x86_64-linux /opt/perl-5.26.1-RC1/lib/5.26.1) at > /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/lib/Mylisp.pm > line 20. > # BEGIN failed--compilation aborted at > /home/cpansand/.cpan/build/2017091018/Mylisp-1.05-0/blib/lib/Mylisp.pm > line 20. > # Compilation failed in require at t/00-load.t line 10. > # BEGIN failed--compilation aborted at t/00-load.t line 10. > # Testing Spp 1.16, Perl 5.026001, /opt/perl-5.26.1-RC1/bin/perl > # Looks like you failed 1 test of 6. > FAILED--Further testing stopped.
Maybe resolved in later versions, I don't see the problem anymore.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.