This queue is for tickets about the HTML-Tree CPAN distribution.

Report information
The Basics
Id:
122199
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
SREZIC [...] cpan.org
Cc:
LEONT [...] cpan.org
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
5.06
Fixed in:
5.07



Subject: Can't locate inc/My_Build.pm in @INC (with perl 5.27.1)
Trying to install HTML-Tree for perl 5.27.1 with CPAN.pm fails on one of my systems (debian/jessie): $ /opt/perl-5.27.1/bin/cpan5.27.1 HTML::Tree ... KENTNL/HTML-Tree-5.06.tar.gz ./Build test -- OK Running Build install [sudo] password for eserte: Can't locate inc/My_Build.pm in @INC (you may need to install the inc::My_Build module) (@INC contains: /opt/perl-5.27.1/lib/site_perl/5.27.1/x86_64-linux /opt/perl-5.27.1/lib/site_perl/5.27.1 /opt/perl-5.27.1/lib/5.27.1/x86_64-linux /opt/perl-5.27.1/lib/5.27.1) at ./Build line 41. BEGIN failed--compilation aborted at ./Build line 41. KENTNL/HTML-Tree-5.06.tar.gz sudo ./Build install -- NOT OK However, this happens only on one of my four systems with 5.27.1, and unfortunately I don't see the difference here.
This could be a bug in older versions of Module::Build, I recall there's specific issues surrounding the combination of Module::Build, CPAN and sudo.

-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
On 2017-06-24 05:22:48, KENTNL wrote:
Show quoted text
> This could be a bug in older versions of Module::Build, I recall there's > specific issues surrounding the combination of Module::Build, CPAN and sudo.
Unfortunately the same version of Module::Build is installed on all these systems (0.4224). But sudo is indeed involved here --- only on the failing system the installation is done with sudo.
RT-Send-CC: LEONT@cpan.org
On 2017-06-24 06:27:58, SREZIC wrote:
Show quoted text
> On 2017-06-24 05:22:48, KENTNL wrote:
> > This could be a bug in older versions of Module::Build, I recall > > there's > > specific issues surrounding the combination of Module::Build, CPAN > > and sudo.
> > Unfortunately the same version of Module::Build is installed on all > these systems (0.4224). > But sudo is indeed involved here --- only on the failing system the > installation is done with sudo.
Probably you're referring to https://rt.cpan.org/Ticket/Display.html?id=121665 I tried to install the distributions mentioned there (Mouse & WWW-UrlEncoded) --- no problems. On the other hand, if I activate the "sudo env PERL_USE_UNSAFE_INC=1 ./Build" trick, then the installation of KENTNL/HTML-Tree-5.06.tar.gz works.
Can you test the attached .tar.gz and see if it resolves your issue? It should work with both PERL_USE_UNSAFE_INC=1 and PERL_USE_UNSAFE_INC=0

-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
Subject: HTML-Tree-5.07.tar.gz

Message body not shown because it is not plain text.

RT-Send-CC: LEONT@cpan.org
On 2017-08-29 20:01:27, KENTNL wrote:
Show quoted text
> Can you test the attached .tar.gz and see if it resolves your issue? > It should > work with both PERL_USE_UNSAFE_INC=1 and PERL_USE_UNSAFE_INC=0
Checked with 5.27.1 and 5.27.3, and with both PERL_USE_UNSAFE_INC settings --- works.

Should be fixed in the now published 5.07

 

Please re-open if it reappears.

-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
 



This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.