Skip Menu |
 

This queue is for tickets about the Mac-SystemDirectory CPAN distribution.

Report information
The Basics
Id: 121613
Status: resolved
Priority: 0/
Queue: Mac-SystemDirectory

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.10



Subject: Undeclared dependency ExtUtils::HasCompiled (0.07, 0.08)
Download (untitled) / with headers
text/plain 524b
See subject. Probably needs to be specified as configure_requires, otherwise the following happens: Can't locate ExtUtils/HasCompiler.pm in @INC (you may need to install the ExtUtils::HasCompiler module) (@INC contains: /var/tmp/cpansmoker-501/2017051115/CPAN-Reporter-lib-o4IE /opt/perl-5.24.1/lib/site_perl/5.24.1/darwin-2level /opt/perl-5.24.1/lib/site_perl/5.24.1 /opt/perl-5.24.1/lib/5.24.1/darwin-2level /opt/perl-5.24.1/lib/5.24.1 .) at Makefile.PL line 12. BEGIN failed--compilation aborted at Makefile.PL line 12.
Download (untitled) / with headers
text/plain 692b
On 2017-05-11 06:27:25, SREZIC wrote: Show quoted text
> See subject. Probably needs to be specified as configure_requires, > otherwise the following happens: > > Can't locate ExtUtils/HasCompiler.pm in @INC (you may need to install > the ExtUtils::HasCompiler module) (@INC contains: /var/tmp/cpansmoker- > 501/2017051115/CPAN-Reporter-lib-o4IE /opt/perl- > 5.24.1/lib/site_perl/5.24.1/darwin-2level /opt/perl- > 5.24.1/lib/site_perl/5.24.1 /opt/perl-5.24.1/lib/5.24.1/darwin-2level > /opt/perl-5.24.1/lib/5.24.1 .) at Makefile.PL line 12. > BEGIN failed--compilation aborted at Makefile.PL line 12.
ah yes, I meant to inline EUHC into the distribution, but then I forgot before releasing. fixed in 0.09!
Download (untitled) / with headers
text/plain 814b
On 2017-05-11 09:50:46, ETHER wrote: Show quoted text
> On 2017-05-11 06:27:25, SREZIC wrote:
> > See subject. Probably needs to be specified as configure_requires, > > otherwise the following happens: > > > > Can't locate ExtUtils/HasCompiler.pm in @INC (you may need to install > > the ExtUtils::HasCompiler module) (@INC contains: > > /var/tmp/cpansmoker- > > 501/2017051115/CPAN-Reporter-lib-o4IE /opt/perl- > > 5.24.1/lib/site_perl/5.24.1/darwin-2level /opt/perl- > > 5.24.1/lib/site_perl/5.24.1 /opt/perl-5.24.1/lib/5.24.1/darwin-2level > > /opt/perl-5.24.1/lib/5.24.1 .) at Makefile.PL line 12. > > BEGIN failed--compilation aborted at Makefile.PL line 12.
> > > ah yes, I meant to inline EUHC into the distribution, but then I > forgot before releasing. > > fixed in 0.09!
Unfortunately not, I still see the problem...
Download (untitled) / with headers
text/plain 956b
On 2017-05-11 10:03:03, SREZIC wrote: Show quoted text
> On 2017-05-11 09:50:46, ETHER wrote:
> > On 2017-05-11 06:27:25, SREZIC wrote:
> > > See subject. Probably needs to be specified as configure_requires, > > > otherwise the following happens: > > > > > > Can't locate ExtUtils/HasCompiler.pm in @INC (you may need to install > > > the ExtUtils::HasCompiler module) (@INC contains: > > > /var/tmp/cpansmoker- > > > 501/2017051115/CPAN-Reporter-lib-o4IE /opt/perl- > > > 5.24.1/lib/site_perl/5.24.1/darwin-2level /opt/perl- > > > 5.24.1/lib/site_perl/5.24.1 /opt/perl-5.24.1/lib/5.24.1/darwin-2level > > > /opt/perl-5.24.1/lib/5.24.1 .) at Makefile.PL line 12. > > > BEGIN failed--compilation aborted at Makefile.PL line 12.
> > > > > > ah yes, I meant to inline EUHC into the distribution, but then I > > forgot before releasing. > > > > fixed in 0.09!
> > Unfortunately not, I still see the problem...
use lib "inc" or something similar seems to be missing.
really fixed in 0.10.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.