Skip Menu |
 

This queue is for tickets about the GD CPAN distribution.

Report information
The Basics
Id: 12152
Status: resolved
Priority: 0/
Queue: GD

People
Owner: Nobody in particular
Requestors: deneb [...] gmx.net
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.23
Fixed in: (no value)



Subject: Polyline.pm, Simple.pm and qd.pl are not installed
Download (untitled) / with headers
text/plain 3.1k
GD-2.23 Hi I'm not sure if I did something wrong, but it seems that Polyline.pm, Simple.pm and qd.pl will not be installed. Is this a normal behavior? What do I have to do, to install these files? Thanks and regards Reto [apack1 GD-2.23]$ perl -v This is perl, v5.8.5 built for i386-linux-thread-multi Copyright 1987-2004, Larry Wall Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit. Complete documentation for Perl, including FAQ lists, should be found on this system using `man perl' or `perldoc perl'. If you have access to the Internet, point your browser at http://www.perl.com/, the Perl Home Page. [apack1 GD-2.23]$ uname -a Linux apack1 2.6.9-5.0.3.ELsmp #1 SMP Mon Feb 14 10:03:50 EST 2005 i686 i686 i386 GNU/Linux [apack1 GD-2.23]$ perl Makefile.PL PREFIX=/data/myperl/ Where is libgd installed? [/usr/lib] Please choose the features that match how libgd was built: Build JPEG support? [y] y Build PNG support? [y] y Build FreeType support? [y] y Build support for animated GIFs? [y] n Build XPM support? [y] y If you experience compile problems, please check the @INC, @LIBPATH and @LIBS arrays defined in Makefile.PL and manually adjust, if necessary. Writing Makefile for GD [apack1 GD-2.23]$ [apack1 GD-2.23]$ make /usr/bin/perl "-Iblib/arch" "-Iblib/lib" GD.pm.PLS GD.pm Extracting GD.pm (with variable substitutions) Skip blib/lib/GD.pm (unchanged) gcc -c -I/usr/include -I/usr/include/gd -D_REENTRANT -D_GNU_SOURCE -DDEBUGGING -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -m32 -march=i386 -mtune=pentium4 -DVERSION=\"2.23\" -DXS_VERSION=\"2.23\" -fPIC "-I/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE" -DHAVE_JPEG -DHAVE_FT -DHAVE_XPM -DHAVE_PNG GD.c Running Mkbootstrap for GD () chmod 644 GD.bs rm -f blib/arch/auto/GD/GD.so gcc -shared -L/usr/local/lib GD.o -o blib/arch/auto/GD/GD.so -L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/lib -lgd -lpng -lz -lfreetype -ljpeg -lm -lX11 -lXpm chmod 755 blib/arch/auto/GD/GD.so cp GD.bs blib/arch/auto/GD/GD.bs chmod 644 blib/arch/auto/GD/GD.bs cp bdf_scripts/bdf2gdfont.pl blib/script/bdf2gdfont.pl /usr/bin/perl "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/bdf2gdfont.pl Manifying blib/man1/bdf2gdfont.pl.1 Manifying blib/man3/GD.3pm [apack1 GD-2.23]$ [apack1 GD-2.23]$ make install Installing /data/myperl/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/GD/GD.so Installing /data/myperl/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/GD/GD.bs Files found in blib/arch: installing files in blib/lib into architecture dependent library tree Installing /data/myperl/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/GD.pm Installing /data/myperl/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/GD/autosplit.ix Installing /data/myperl/share/man/man1/bdf2gdfont.pl.1 Installing /data/myperl/share/man/man3/GD.3pm Installing /data/myperl/bin/bdf2gdfont.pl Writing /data/myperl//lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/GD/.packlist Appending installation info to /data/myperl//lib/perl5/5.8.5/i386-linux-thread-multi/perllocal.pod [apack1 GD-2.23]$
These bugs were fixed for some years already.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.