|Subject:||The name is very confusing|
Calling this "Moo::Google" when it is built on _Moose_ instead of _Moo_ is very confusing. That said, naming things after what they're built on is not a good practice. It's much better if the name describes what it does rather than what it is made of. So with that in mind maybe it's best to call it something like "WebService::Google::Base" or something along those lines.