Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 121491
Status: rejected
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: donna [...] allegro.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: possible build problem?
Date: Mon, 1 May 2017 15:40:04 -0600
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Donna Hofmeister <donna [...] allegro.com>
Download (untitled) / with headers
text/plain 771b
i tried to install (using cpan) IO::Socket::SSL on an hp-ux 11.31, itanium system running perl 5.10.1 (from the hp porting centre) and it failed. here's an example of the kind of errors I got: /usr/lib/hpux32/dld.so: Unsatisfied code symbol 'SSL_set1_param' in load module '/usr/local/lib/perl5/site_perl/5.10.1/IA64.ARCHREV_0/auto/Net/SSLeay/SSLeay.so'. (there's are thousands of similar lines....) i checked the above library and the SSL_set1_param routine is there. is this a problem with this module or is this related to my version of perl? - donna -- Donna Hofmeister Allegro Consultants, Inc. 408-252-2330 Visit us on Linkedin <https://www.linkedin.com/company/allegro-consultants-inc-> Like us on Facebook <http://www.facebook.com/allegroconsultantsinc>
Download (untitled) / with headers
text/plain 985b
Am Mo 01. Mai 2017, 17:40:54, donna@allegro.com schrieb: Show quoted text
> i tried to install (using cpan) IO::Socket::SSL on an hp-ux 11.31, > itanium > system running perl 5.10.1 (from the hp porting centre) and it failed. > here's an example of the kind of errors I got: > > /usr/lib/hpux32/dld.so: Unsatisfied code symbol 'SSL_set1_param' in > load > module > '/usr/local/lib/perl5/site_perl/5.10.1/IA64.ARCHREV_0/auto/Net/SSLeay/SSLeay.so'. > (there's are thousands of similar lines....)
These errors come from Net::SSLeay and not from IO::Socket::SSL. They are not a bug in IO::Socket::SSL. IO::Socket::SSL depends on a working Net::SSLeay module and this precondition is obviously not satisfied. I don't know what the exact cause of this error is in your case but I could imagine that Net::SSLeay was installed once and then OpenSSL upgraded without rebuilding Net::SSLeay. Such activity might Net::SSLeay to not work anymore and it needs to be rebuild with the currently installed OpenSSL.
CC: behroozi [...] www.pls.uni.edu
Subject: Re: [rt.cpan.org #121491] possible build problem?
Date: Tue, 2 May 2017 14:49:12 -0600
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Donna Hofmeister <donna [...] allegro.com>
On Tue, May 2, 2017 at 12:02 AM, Steffen Ullrich via RT < bug-IO-Socket-SSL@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=121491 > > > These errors come from Net::SSLeay and not from IO::Socket::SSL. > They are not a bug in IO::Socket::SSL. > IO::Socket::SSL depends on a working Net::SSLeay module and this > precondition is obviously not satisfied. > > I don't know what the exact cause of this error is in your case but I > could imagine that Net::SSLeay > was installed once and then OpenSSL upgraded without rebuilding > Net::SSLeay. Such activity might > Net::SSLeay to not work anymore and it needs to be rebuild with the > currently installed OpenSSL. >
Thank you for your timely and helpful reply! It was indeed an issue with OpenSSL. With all the involved bits updated, we're making progress again! :-) - donna -- Donna Hofmeister Allegro Consultants, Inc. 408-252-2330 Visit us on Linkedin <https://www.linkedin.com/company/allegro-consultants-inc-> Like us on Facebook <http://www.facebook.com/allegroconsultantsinc>


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.