Skip Menu |
 

This queue is for tickets about the HTML-TableParser CPAN distribution.

Report information
The Basics
Id: 121256
Status: resolved
Priority: 0/
Queue: HTML-TableParser

People
Owner: djerius [...] cpan.org
Requestors: KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.43



Subject: Tests fail when no '.' in @INC (Can't locate t/counts.pl in @INC )
When no '.' is in @INC on Perl 5.25.11 or newer ( the default when executing by hand, or when PERL_USE_UNSAFE_INC=0 is set in ENV )
Tests fail as follows:

PERL_DL_NONLAZY=1 "/home/kent/perl5/perlbrew/perls/5.25.11-nossp-sip13-nopmc-nodot/bin/perl5.25.11" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t
Show quoted text
# Testing HTML::TableParser 0.41, Perl 5.025011, /home/kent/perl5/perlbrew/perls/5.25.11-nossp-sip13-nopmc-nodot/bin/perl5.25.11
t/00-load.t .... ok
Can't locate t/counts.pl in @INC (@INC contains: /home/kent/.cpanm/work/1492702459.30721/HTML-TableParser-0.41/inc /home/kent/.cpanm/work/1492702459.30721/HTML-TableParser-0.41/blib/lib /home/kent/.cpanm/work/1492702459.30721/HTML-TableParser-0.41/blib/arch /home/kent/.cpanm/work/1492702459.30721/HTML-TableParser-0.41/inc /home/kent/.cpanm/work/1492702459.30721/HTML-TableParser-0.41/blib/lib /home/kent/.cpanm/work/1492702459.30721/HTML-TableParser-0.41/blib/arch /home/kent/perl5/perlbrew/perls/5.25.11-nossp-sip13-nopmc-nodot/lib/site_perl/5.25.11/x86_64-linux /home/kent/perl5/perlbrew/perls/5.25.11-nossp-sip13-nopmc-nodot/lib/site_perl/5.25.11 /home/kent/perl5/perlbrew/perls/5.25.11-nossp-sip13-nopmc-nodot/lib/5.25.11/x86_64-linux /home/kent/perl5/perlbrew/perls/5.25.11-nossp-sip13-nopmc-nodot/lib/5.25.11) at t/class.t line 5.
Show quoted text
# Looks like your test exited with 2 just after 1.



-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
Download (untitled) / with headers
text/plain 414b
On Thu Apr 20 11:34:58 2017, KENTNL wrote: Show quoted text
> When no '.' is in @INC on Perl 5.25.11 or newer ( the default when > executing by > hand, or when PERL_USE_UNSAFE_INC=0 is set in ENV ) > Tests fail as follows: >
Show quoted text
> -- > - CPAN kentnl@cpan.org > - Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
Thanks. Which version are you testing? I just uploaded a version (0.41) which I thought fixed that problem.
Download (untitled) / with headers
text/plain 617b
On Thu Apr 20 12:06:58 2017, DJERIUS wrote: Show quoted text
> On Thu Apr 20 11:34:58 2017, KENTNL wrote:
> > When no '.' is in @INC on Perl 5.25.11 or newer ( the default when > > executing by > > hand, or when PERL_USE_UNSAFE_INC=0 is set in ENV ) > > Tests fail as follows: > >
>
> > -- > > - CPAN kentnl@cpan.org > > - Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
> > > Thanks. Which version are you testing? I just uploaded a version > (0.41) which I thought fixed that problem.
Never mind; I've duplicated your error. The bigger question is why the 5.25.11 I'm testing with didn't lead to the error. Diab
Download (untitled) / with headers
text/plain 882b
On Thu Apr 20 13:22:10 2017, DJERIUS wrote: Show quoted text
> On Thu Apr 20 12:06:58 2017, DJERIUS wrote:
> > On Thu Apr 20 11:34:58 2017, KENTNL wrote:
> > > When no '.' is in @INC on Perl 5.25.11 or newer ( the default when > > > executing by > > > hand, or when PERL_USE_UNSAFE_INC=0 is set in ENV ) > > > Tests fail as follows: > > >
> >
> > > -- > > > - CPAN kentnl@cpan.org > > > - Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
> > > > > > Thanks. Which version are you testing? I just uploaded a version > > (0.41) which I thought fixed that problem.
> > Never mind; I've duplicated your error. The bigger question is why > the 5.25.11 I'm testing with didn't lead to the error.
Looks like the ExtUtils::MakeMaker bundled with 5.25.11 inserts a '.' into @INC during testing, which is why my runs(without PERL_USE_UNSAFE_INC=0 ) didn't pick up this failure. Thanks again.
On Thu Apr 20 16:47:03 2017, DJERIUS wrote: Show quoted text
> On Thu Apr 20 13:22:10 2017, DJERIUS wrote:
> > On Thu Apr 20 12:06:58 2017, DJERIUS wrote:
> > > On Thu Apr 20 11:34:58 2017, KENTNL wrote:
> > > > When no '.' is in @INC on Perl 5.25.11 or newer ( the default > > > > when > > > > executing by > > > > hand, or when PERL_USE_UNSAFE_INC=0 is set in ENV ) > > > > Tests fail as follows: > > > >
> > >
> > > > -- > > > > - CPAN kentnl@cpan.org > > > > - Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
> > > > > > > > > Thanks. Which version are you testing? I just uploaded a version > > > (0.41) which I thought fixed that problem.
> > > > Never mind; I've duplicated your error. The bigger question is why > > the 5.25.11 I'm testing with didn't lead to the error.
> > Looks like the ExtUtils::MakeMaker bundled with 5.25.11 inserts a '.' > into @INC during testing, which is why my runs(without > PERL_USE_UNSAFE_INC=0 ) didn't pick up this failure. > > Thanks again.
This has been resolved with 0.43. Thanks again for your report! Diab


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.