Skip Menu |
 

This queue is for tickets about the Alien-wxWidgets CPAN distribution.

Report information
The Basics
Id: 120887
Status: new
Priority: 0/
Queue: Alien-wxWidgets

People
Owner: Nobody in particular
Requestors: jkeenan [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: (no value)
Fixed in: (no value)



Subject: Alien-wxWidgets: ./Build fails with perl 5 blead: no dot by default in @INC
Download (untitled) / with headers
text/plain 1.2k
In Perl 5.26.0, '.' will no longer be found by default in @INC. Today I attempted to Build this library against Perl 5 blead. I had to apply the following patches to get 'blead-perl Build.PL' to complete successfully and for './Build' to start off successfully. ##### [Alien-wxWidgets-0.67] 563 $ diff -u Build.PL.orig Build.PL --- Build.PL.orig 2017-04-02 14:42:26.100526304 -0400 +++ Build.PL 2017-04-02 14:37:10.429239813 -0400 @@ -3,7 +3,7 @@ BEGIN { our $NO_INIT = 1 } use strict; -use lib "lib", "inc"; +use lib "./lib", "./inc"; use My::Build; use Config; [Alien-wxWidgets-0.67] 564 $ diff -u ./inc/My/Build/Base.pm.orig ./inc/My/Build/Base.pm --- ./inc/My/Build/Base.pm.orig 2017-04-02 14:40:01.864349238 -0400 +++ ./inc/My/Build/Base.pm 2017-04-02 14:38:16.561871556 -0400 @@ -10,6 +10,7 @@ use Data::Dumper; use File::Glob qw(bsd_glob); use Carp; +use lib '.'; # use the system version of a module if present; in theory this could lead to # compatibility problems (if the latest version of one of the dependencies, ##### For this library -- and for other CPAN distributions such as Wx which depend on this one -- a new CPAN release will be needed for perl-5.26.0 compatibility. Thank you very much. Jim Keenan


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.