Skip Menu |
 

This queue is for tickets about the List-MoreUtils-XS CPAN distribution.

Report information
The Basics
Id: 120796
Status: patched
Priority: 0/
Queue: List-MoreUtils-XS

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.418
Fixed in: (no value)



Subject: t/xs/Functions.t fails for perl 5.10..5.14
Download (untitled) / with headers
text/plain 464b
I see the following for perl 5.10 .. 5.14: ... # Failed test 'apply must be reasonable invoked' # at t/lib/LMU/Test/Functions.pm line 379. # '' # doesn't match '(?^:List\:\:MoreUtils\:\:XS\:\:apply\(code\,\ \.\.\.\))' # Looks like you failed 1 test of 3461. t/xs/Functions.t .. Dubious, test returned 1 (wstat 256, 0x100) Failed 1/3461 subtests (less 2 skipped subtests: 3458 okay) ... perl 5.8.9 or 5.16 and later passes all tests.
Download (untitled) / with headers
text/plain 559b
bump :-) On Wed Mar 29 18:19:16 2017, SREZIC wrote: Show quoted text
> I see the following for perl 5.10 .. 5.14: > > ... > # Failed test 'apply must be reasonable invoked' > # at t/lib/LMU/Test/Functions.pm line 379. > # '' > # doesn't match '(?^:List\:\:MoreUtils\:\:XS\:\:apply\(code\,\ > \.\.\.\))' > # Looks like you failed 1 test of 3461. > t/xs/Functions.t .. > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/3461 subtests > (less 2 skipped subtests: 3458 okay) > ... > > perl 5.8.9 or 5.16 and later passes all tests.
Download (untitled) / with headers
text/plain 739b
On Wed Jun 21 02:26:41 2017, ZHENYZ wrote: Show quoted text
> bump :-) > > > On Wed Mar 29 18:19:16 2017, SREZIC wrote:
> > I see the following for perl 5.10 .. 5.14: > > > > ... > > # Failed test 'apply must be reasonable invoked' > > # at t/lib/LMU/Test/Functions.pm line 379. > > # '' > > # doesn't match '(?^:List\:\:MoreUtils\:\:XS\:\:apply\(code\,\ > > \.\.\.\))' > > # Looks like you failed 1 test of 3461. > > t/xs/Functions.t .. > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/3461 subtests > > (less 2 skipped subtests: 3458 okay) > > ... > > > > perl 5.8.9 or 5.16 and later passes all tests.
> >
Thanks for bumping. https://travis-ci.org/perl5-utils/List-MoreUtils-XS looks better now :)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.