Skip Menu |
 

This queue is for tickets about the Git-Database CPAN distribution.

Report information
The Basics
Id: 120760
Status: resolved
Priority: 0/
Queue: Git-Database

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.008
Fixed in: 0.009



Subject: Minimum Git::Raw version?
Download (untitled) / with headers
text/plain 680b
It seems that at least Git::Raw 0.74 is required. Statistical analysis shows that there are no pass reports with Git::Raw 0.73 on my smokers: **************************************************************** Regression 'mod:Git::Raw' **************************************************************** Name Theta StdErr T-stat [0='const'] -0.0000 0.0966 -0.00 [1='eq_0.73'] 0.0000 0.1170 0.00 [2='eq_0.74'] 0.8500 0.1123 7.57 R^2= 0.748, N= 42, K= 3 **************************************************************** However, even with Git::Raw 0.74 there seem to be some test failures (Theta is not 1.0).
Download (untitled) / with headers
text/plain 771b
On Sun Mar 26 04:27:11 2017, SREZIC wrote: Show quoted text
> It seems that at least Git::Raw 0.74 is required. Statistical analysis > shows that there are no pass reports with Git::Raw 0.73 on my smokers:
This is documented here: https://metacpan.org/pod/release/BOOK/Git-Database-0.008/lib/Git/Database/Backend/Git/Raw/Repository.pm#CAVEAT I've also defined the requirements in the dist.ini Prereqs section: [Prereqs / TestRecommends] Git = Cogit = Git::PurePerl = Git::Raw = 0.74 Git::Repository = 1.300 Git::Sub = 0.163320 Git::Wrapper = The issue is that I don't want to make a hard requirement on any of the backends. I guess I should skip the backends from my tests if I know the requirements are not met. Thanks for the report, very useful and detailed, as always. -- BooK
Download (untitled) / with headers
text/plain 1.2k
On 2017-03-28 02:41:11, BOOK wrote: Show quoted text
> On Sun Mar 26 04:27:11 2017, SREZIC wrote:
> > It seems that at least Git::Raw 0.74 is required. Statistical > > analysis > > shows that there are no pass reports with Git::Raw 0.73 on my > > smokers:
> > This is documented here: https://metacpan.org/pod/release/BOOK/Git- > Database-0.008/lib/Git/Database/Backend/Git/Raw/Repository.pm#CAVEAT > > I've also defined the requirements in the dist.ini Prereqs section: > > [Prereqs / TestRecommends] > Git = > Cogit = > Git::PurePerl = > Git::Raw = 0.74 > Git::Repository = 1.300 > Git::Sub = 0.163320 > Git::Wrapper = > > The issue is that I don't want to make a hard requirement on any of > the backends. > > I guess I should skip the backends from my tests if I know the > requirements are not met. > > Thanks for the report, very useful and detailed, as always. > > -- BooK
An approach could be: if Git::Raw is already installed, then require an upgrade to 0.74, otherwise do nothing. In a dynamic setup one could write (untested): WriteMakefile(..., PREREQ_PM => { (eval { require Git::Raw; 1 } ? (Git::Raw => 0.74) : ()), ...); However I don't know if something like this is possible in a static (dzil) setup.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.