Skip Menu |
 

This queue is for tickets about the PAR CPAN distribution.

Report information
The Basics
Id: 120722
Status: resolved
Priority: 0/
Queue: PAR

People
Owner: Nobody in particular
Requestors: KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.983
Fixed in: (no value)



Subject: Reason for Module::Signature dependency unclear since 2008

As of 0.983, this dist has not shipped with any signature data:

https://metacpan.org/diff/file?target=SMUELLER/PAR-0.983/&source=SMUELLER/PAR-0.982/

I can also not spot any logic in this dist which would indicate a need for any of the cryptographic modules it tries to depend on in Makefile.PL

This version number is just incidentally within relative proximity of the split into PAR-Packer, which uses Module::Signature in PAR::Packer.pm

I suspect this could be simply a forgotten about dependency, or some misunderstanding I have made from not being lucky enough to find relevant documentation =).

( But the documentation I did read suggested signature generation was handled by PAR::Packer, and verified by cpansign, and PAR.pm had no involvement )



-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
 

Download (untitled) / with headers
text/plain 804b
On 2017-03-23 12:33:24, KENTNL wrote: Show quoted text
> As of 0.983, this dist has not shipped with any signature data: > > https://metacpan.org/diff/file?target=SMUELLER/PAR- > 0.983/&source=SMUELLER/PAR-0.982/ > > I can also not spot any logic in this dist which would indicate a need > for any > of the cryptographic modules it tries to depend on in Makefile.PL
First of all, these are only "recommends" (and e.g. Debian has chosen to ignore them as Build-Depends, cf. https://packages.debian.org/source/sid/libpar-perl). But you're right, PAR doesn't make use of Module::Signature. It may use Digest::SHA, though. So I "require" now (a non-broken version of) Digest::SHA and removed the other "recommends". Actually, this requirement is a non-issue, as Digest::SHA is in Perl core since 5.10.0. Cheers, Roderich


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.