Skip Menu |
 

This queue is for tickets about the Digest-CRC CPAN distribution.

Report information
The Basics
Id: 120669
Status: new
Priority: 0/
Queue: Digest-CRC

People
Owner: Nobody in particular
Requestors: KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Module <-> Package version missmatch

Downstream vendors have to rely on the version on the box in many places, and the version<->module version missmatch causes some confusion:

Digest::CRC                        0.20  O/OL/OLIMAUL/Digest-CRC-0.20.tar.gz
Digest::CRC                        0.21  O/OL/OLIMAUL/Digest-CRC-0.21.tar.gz
Digest::CRC                        0.21  O/OL/OLIMAUL/Digest-CRC-0.22.tar.gz
Digest::CRC                        0.22  O/OL/OLIMAUL/Digest-CRC-0.22.1.tar.gz
Digest::CRC                        0.22  O/OL/OLIMAUL/Digest-CRC-0.22.2.tar.gz

I'd also point out that "0.22.1" is smaller than "0.22" according to Perl's version rules, further adding to confusion:


 perl -MData::Dumper=Dumper -E ' say for sort { $a <=> $b } map { version->parse($_)} qw( 0.20 0.21 0.22 0.22.1 0.22.2 )'

0.22.1
0.22.2
0.20
0.21
0.22

"Why" becomes more obvious under normalisation:

perl -MData::Dumper=Dumper -E ' say $_->normal for sort { $a <=> $b } map { version->parse($_)} qw( 0.20 0.21 0.22 0.22.1 0.22.2 )'
v0.22.1
v0.22.2
v0.200.0
v0.210.0
v0.220.0

So the only request is:

1. That for the next release, you use a consistent internal and external version relationship
2. That the next release be logically larger than 0.220.0 ( ==  0.22  == 0.220 == 0.220000 )


-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
 



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.