Skip Menu |
 

This queue is for tickets about the Task-Weaken CPAN distribution.

Report information
The Basics
Id: 120412
Status: resolved
Priority: 0/
Queue: Task-Weaken

People
Owner: Nobody in particular
Requestors: KENTNL [...] cpan.org
Cc: PLICEASE [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 1.05



Subject: Fails install when no '.' in @INC

On 5.25.10 with -Ddefault_inc_excludes_dot

--> Working on Task::Weaken
Fetching http://cpan.metacpan.org/authors/id/A/AD/ADAMK/Task-Weaken-1.04.tar.gz ... OK
Fetching http://cpan.metacpan.org/authors/id/A/AD/ADAMK/CHECKSUMS ... OK
Configuring Task-Weaken-1.04 ... Can't locate inc/Module/Install.pm in @INC (you may need to install the inc::Module::Install module) (@INC contains: /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc-nodot/lib/site_perl/5.25.10/x86_64-linux /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc-nodot/lib/site_perl/5.25.10 /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc-nodot/lib/5.25.10/x86_64-linux /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc-nodot/lib/5.25.10) at Makefile.PL line 42.
BEGIN failed--compilation aborted at Makefile.PL line 42.
Configuring Task-Weaken failed.



-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
Download (untitled) / with headers
text/plain 1.2k
On Mon Feb 27 02:30:28 2017, KENTNL wrote: Show quoted text
> On 5.25.10 with -Ddefault_inc_excludes_dot > > --> Working on Task::Weaken > Fetching http://cpan.metacpan.org/authors/id/A/AD/ADAMK/Task-Weaken- > 1.04.tar.gz > ... OK > Fetching http://cpan.metacpan.org/authors/id/A/AD/ADAMK/CHECKSUMS ... > OK > Configuring Task-Weaken-1.04 ... Can't locate inc/Module/Install.pm in > @INC > (you may need to install the inc::Module::Install module) (@INC > contains: > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > nodot/lib/site_perl/5.25.10/x86_64-linux > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > nodot/lib/site_perl/5.25.10 > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > nodot/lib/5.25.10/x86_64-linux > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > nodot/lib/5.25.10) at > Makefile.PL line 42. > BEGIN failed--compilation aborted at Makefile.PL line 42. > Configuring Task-Weaken failed. > > > > -- > - CPAN kentnl@cpan.org > - Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
The patch attached should correct Makefile.PL and enable build and test. Also, I see that Test-Weaken has not had a new CPAN release in several years. Should you want to share COMAINT, please let me know. Thank you very much. Jim Keenan
Subject: Test-Weaken.20170330.diff
41a42 > use lib '.';
Download (untitled) / with headers
text/plain 1.5k
On Thu Mar 30 11:11:42 2017, JKEENAN wrote: Show quoted text
> On Mon Feb 27 02:30:28 2017, KENTNL wrote:
> > On 5.25.10 with -Ddefault_inc_excludes_dot > > > > --> Working on Task::Weaken > > Fetching http://cpan.metacpan.org/authors/id/A/AD/ADAMK/Task-Weaken- > > 1.04.tar.gz > > ... OK > > Fetching http://cpan.metacpan.org/authors/id/A/AD/ADAMK/CHECKSUMS ... > > OK > > Configuring Task-Weaken-1.04 ... Can't locate inc/Module/Install.pm > > in > > @INC > > (you may need to install the inc::Module::Install module) (@INC > > contains: > > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > > nodot/lib/site_perl/5.25.10/x86_64-linux > > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > > nodot/lib/site_perl/5.25.10 > > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > > nodot/lib/5.25.10/x86_64-linux > > /home/kent/perl5/perlbrew/perls/5.25.10-nossp-sdbm-nopmc- > > nodot/lib/5.25.10) at > > Makefile.PL line 42. > > BEGIN failed--compilation aborted at Makefile.PL line 42. > > Configuring Task-Weaken failed. > > > > > > > > -- > > - CPAN kentnl@cpan.org > > - Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
> > The patch attached should correct Makefile.PL and enable build and > test. > > Also, I see that Test-Weaken has not had a new CPAN release in several > years. Should you want to share COMAINT, please let me know. > > Thank you very much. > Jim Keenan
In yesterday's post I mistakenly referred to 'Test-Weaken' rather than 'Task-Weaken'. Attached is a better patch, in 'diff -u' format. Thank you very much. Jim Keenan
Subject: Task-Weaken-20170331.diff
--- Makefile.PL.orig 2017-03-30 11:06:38.156016772 -0400 +++ Makefile.PL 2017-03-30 11:06:52.887263612 -0400 @@ -39,6 +39,7 @@ # # Adam K +use lib '.'; use inc::Module::Install 1.00; all_from 'lib/Task/Weaken.pm';
Download (untitled) / with headers
text/plain 220b
This breaks the install of many things from installing easily on 5.26, including PPI, which means Dist::Zilla doesn't install. That's probably a small fraction of what's breaking. It'd be great to get a fix for this out.
use of Module::Install removed in 1.05.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.