Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the CGI-Application-Plugin-Config-Any CPAN distribution.

Report information
The Basics
Id: 120371
Status: open
Priority: 0/
Queue: CGI-Application-Plugin-Config-Any

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc: haarg [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.14
Fixed in: (no value)



CC: haarg [...] cpan.org
Subject: t/01-basic.t fails (with Config::Any 0.28?)
Download (untitled) / with headers
text/plain 1.1k
My smoker systems started to report the following failure: ... Error parsing ./t/basic.pl: Insecure dependency in require while running with -T switch at /home/cpansand/.cpan/build/2017022518/Config-Any-0.28-OtYQab/blib/lib/Config/Any/Perl.pm line 52. at /home/cpansand/.cpan/build/2017022518/CGI-Application-Plugin-Config-Any-0.14-UWVmQW/blib/lib/CGI/Application/Plugin/Config/Any.pm line 459. t/01-basic.t ...... skipped: (no reason given) ... Statistical analysis suggests that this happens with Config::Any 0.28: **************************************************************** Regression 'mod:Config::Any' **************************************************************** Name Theta StdErr T-stat [0='const'] 1.0000 0.0000 54337093588746184.00 [1='eq_0.26'] -0.0000 0.0000 -8.83 [2='eq_0.27'] -0.0000 0.0000 -10.48 [3='eq_0.28'] -1.0000 0.0000 -43762403261781768.00 R^2= 1.000, N= 92, K= 4 **************************************************************** Looking at the Changes file, it seems that this change could cause the problem: https://metacpan.org/changes/distribution/Config-Any#L6
Download (untitled) / with headers
text/plain 1.3k
On Sat Feb 25 14:52:55 2017, SREZIC wrote: Show quoted text
> My smoker systems started to report the following failure: > > ... > Error parsing ./t/basic.pl: Insecure dependency in require while > running with -T switch at > /home/cpansand/.cpan/build/2017022518/Config-Any-0.28- > OtYQab/blib/lib/Config/Any/Perl.pm line 52. > at /home/cpansand/.cpan/build/2017022518/CGI-Application-Plugin- > Config-Any-0.14-UWVmQW/blib/lib/CGI/Application/Plugin/Config/Any.pm > line 459. > t/01-basic.t ...... skipped: (no reason given) > ... > > > Statistical analysis suggests that this happens with Config::Any 0.28: > > **************************************************************** > Regression 'mod:Config::Any' > **************************************************************** > Name Theta StdErr T-stat > [0='const'] 1.0000 0.0000 54337093588746184.00 > [1='eq_0.26'] -0.0000 0.0000 -8.83 > [2='eq_0.27'] -0.0000 0.0000 -10.48 > [3='eq_0.28'] -1.0000 0.0000 -43762403261781768.00 > > R^2= 1.000, N= 92, K= 4 > **************************************************************** > > > Looking at the Changes file, it seems that this change could cause the > problem: > https://metacpan.org/changes/distribution/Config-Any#L6
I've fixed this in Config::Any in version 0.29.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.