Skip Menu |
 

This queue is for tickets about the Template-Plugin-JSON CPAN distribution.

Report information
The Basics
Id: 120156
Status: stalled
Priority: 0/
Queue: Template-Plugin-JSON

People
Owner: Nobody in particular
Requestors: peter.staab [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Build-test failure
Date: Thu, 9 Feb 2017 09:28:18 -0500
To: bug-Template-Plugin-JSON [...] rt.cpan.org
From: Peter Staab <peter.staab [...] gmail.com>
Download (untitled) / with headers
text/plain 4.1k
I just wanted report a bug in testing Template::Plugin::JSON. I have the code generated from cpanm below: I stumbled across http://www.perlmonks.org/?node_id=1083777 <http://www.perlmonks.org/?node_id=1083777> which may be relavant, that post in from 2014 and I notice that the current version of Template::Plugin::JSON is late 2015. Peter cpanm (App::cpanminus) 1.7042 on perl 5.018002 built for darwin-thread-multi-2level Work directory is /Users/pstaab/.cpanm/work/1486650100.39130 You have make /usr/bin/make You have LWP 6.05 You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3 You have /usr/bin/unzip Searching Template::Plugin::JSON () on cpanmetadb ... --> Working on Template::Plugin::JSON Fetching http://www.cpan.org/authors/id/N/NE/NEILB/Template-Plugin-JSON-0.07.tar.gz ... OK Unpacking Template-Plugin-JSON-0.07.tar.gz x Template-Plugin-JSON-0.07/ x Template-Plugin-JSON-0.07/Changes x Template-Plugin-JSON-0.07/lib/ x Template-Plugin-JSON-0.07/Makefile.PL x Template-Plugin-JSON-0.07/MANIFEST x Template-Plugin-JSON-0.07/MANIFEST.SKIP x Template-Plugin-JSON-0.07/META.json x Template-Plugin-JSON-0.07/META.yml x Template-Plugin-JSON-0.07/README x Template-Plugin-JSON-0.07/t/ x Template-Plugin-JSON-0.07/t/live.t x Template-Plugin-JSON-0.07/lib/Template/ x Template-Plugin-JSON-0.07/lib/Template/Plugin/ x Template-Plugin-JSON-0.07/lib/Template/Plugin/JSON.pm Entering Template-Plugin-JSON-0.07 Checking configure dependencies from META.json Checking if you have ExtUtils::MakeMaker 6.64 ... Yes (7.24) Running Makefile.PL Configuring Template-Plugin-JSON-0.07 ... Checking if your kit is complete... Looks good Generating a Unix-style Makefile Writing Makefile for Template::Plugin::JSON Writing MYMETA.yml and MYMETA.json JSON::XS is reccomended, you should probably install it for better performance. OK Checking dependencies from MYMETA.json ... Checking if you have Test::More 0 ... Yes (1.302075) Checking if you have Moose 0 ... Yes (2.1202) Checking if you have Template 2.20 ... Yes (2.26) Checking if you have Carp 0 ... Yes (1.38) Checking if you have ExtUtils::MakeMaker 0 ... Yes (7.24) Checking if you have JSON 2.12 ... Yes (2.90) Building and testing Template-Plugin-JSON-0.07 ... cp lib/Template/Plugin/JSON.pm blib/lib/Template/Plugin/JSON.pm Manifying 1 pod document PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/live.t .. 1/9 # Failed test 'use Template::Plugin::JSON;' # at t/live.t line 11. # Tried to use 'Template::Plugin::JSON'. # Error: Invalid version format (version required) at /Library/Perl/5.18/Module/Runtime.pm line 386. # BEGIN failed--compilation aborted at /Users/pstaab/.cpanm/work/1486650100.39130/Template-Plugin-JSON-0.07/blib/lib/Template/Plugin/JSON.pm line 6. # Compilation failed in require at t/live.t line 11. # BEGIN failed--compilation aborted at t/live.t line 11. # Failed test 'template processing' # at t/live.t line 13. plugin error - Attempt to reload Template/Plugin/JSON.pm aborted. Compilation failed in require at /Library/Perl/5.18/darwin-thread-multi-2level/Template/Plugins.pm line 206. # Failed test 'output seems OK' # at t/live.t line 23. # undef # doesn't match '(?^:\{\W*foo\W*:\W*bar\W*\})' # Failed test 'pretty output' # at t/live.t line 25. # undef # doesn't match '(?^:\n)' malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "(end of string)") at t/live.t line 27. # Looks like your test exited with 255 just after 4. t/live.t .. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 9/9 subtests Test Summary Report ------------------- t/live.t (Wstat: 65280 Tests: 4 Failed: 4) Failed tests: 1-4 Non-zero exit status: 255 Parse errors: Bad plan. You planned 9 tests but ran 4. Files=1, Tests=4, 1 wallclock secs ( 0.02 usr 0.00 sys + 0.24 cusr 0.04 csys = 0.30 CPU) Result: FAIL Failed 1/1 test programs. 4/4 subtests failed. make: *** [test_dynamic] Error 255 FAIL ! Installing Template::Plugin::JSON failed. See /Users/pstaab/.cpanm/work/1486650100.39130/build.log for details. Retry with --force to force install it.
Download (untitled) / with headers
text/html 25.5k

Message body is not shown because it is too large.

On 2017-02-09 06:28:43, peter.staab@gmail.com wrote: Show quoted text
> > I just wanted report a bug in testing Template::Plugin::JSON. I have > the code generated from cpanm below:
No, the problem is upstream, in your Moose installation. Please run `moose-outdated` and update everything it lists that is out of date. You should do this whenever you update Moose, and also pay attention to the output of its t/zzz-check-breaks.t test. I will include the relevant bits of the test output below that show where the error is coming from. Show quoted text
> # Failed test 'use Template::Plugin::JSON;' > # at t/live.t line 11. > # Tried to use 'Template::Plugin::JSON'. > # Error: Invalid version format (version required) at > /Library/Perl/5.18/Module/Runtime.pm line 386. > # BEGIN failed--compilation aborted at > /Users/pstaab/.cpanm/work/1486650100.39130/Template-Plugin-JSON- > 0.07/blib/lib/Template/Plugin/JSON.pm line 6. > # Compilation failed in require at t/live.t line 11. > # BEGIN failed--compilation aborted at t/live.t line 11.
stalling ticket until we confirm that the problem is resolved.
Subject: Re: [rt.cpan.org #120156] Build-test failure
Date: Thu, 9 Feb 2017 15:39:06 -0500
To: bug-Template-Plugin-JSON [...] rt.cpan.org
From: Peter Staab <peter.staab [...] gmail.com>
Download (untitled) / with headers
text/plain 4.7k
I’m not using Moose for anything (I am using Moo). I went ahead and did moose-outdated and upgraded, but they are all failing. Here’s the MooseX::Role::Parameterized output. related to t/zzz-check-breaks.t: Invalid version format (version required) at /Library/Perl/5.18/Module/Runtime.pm line 349. Compilation failed in require at /Library/Perl/5.18/Module/Runtime.pm line 317. Compilation failed in require at (eval 176) line 1. BEGIN failed--compilation aborted at (eval 176) line 1. at /Users/pstaab/.cpanm/work/1486672552.44408/MooseX-Role-WithOverloading-0.17/blib/lib/MooseX/Role/WithOverloading/Meta/Role/Composite.pm line 7. BEGIN failed--compilation aborted at /Users/pstaab/.cpanm/work/1486672552.44408/MooseX-Role-WithOverloading-0.17/blib/lib/MooseX/Role/WithOverloading/Meta/Role/Composite.pm line 7. Compilation failed in require at (eval 173) line 1. BEGIN failed--compilation aborted at (eval 173) line 1. at /Users/pstaab/.cpanm/work/1486672552.44408/MooseX-Role-WithOverloading-0.17/blib/lib/MooseX/Role/WithOverloading/Meta/Role.pm line 7. BEGIN failed--compilation aborted at /Users/pstaab/.cpanm/work/1486672552.44408/MooseX-Role-WithOverloading-0.17/blib/lib/MooseX/Role/WithOverloading/Meta/Role.pm line 7. Compilation failed in require at (eval 170) line 1. BEGIN failed--compilation aborted at (eval 170) line 1. at /Users/pstaab/.cpanm/work/1486672552.44408/MooseX-Role-WithOverloading-0.17/blib/lib/MooseX/Role/WithOverloading.pm line 9. BEGIN failed--compilation aborted at /Users/pstaab/.cpanm/work/1486672552.44408/MooseX-Role-WithOverloading-0.17/blib/lib/MooseX/Role/WithOverloading.pm line 9. Compilation failed in require at t/to_role.t line 32. BEGIN failed--compilation aborted at t/to_role.t line 32. # Tests were run but no plan was declared and done_testing() was not seen. # Looks like your test exited with 255 just after 1. t/to_role.t ................ Dubious, test returned 255 (wstat 65280, 0xff00) Failed 1/1 subtests t/zzz-check-breaks.t ....... Warning: MooseX::Method::Signatures did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. Warning: MooseX::Declare did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. Warning: MooseX::ClassAttribute did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. Warning: MooseX::Getopt did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. Warning: MooseX::Types did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. Warning: MooseX::Role::WithOverloading did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. Warning: MooseX::Storage did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. Warning: MooseX::Role::Parameterized did not compile at /System/Library/Perl/Extras/5.18/Dist/CheckConflicts.pm line 186. # Conflicts detected for Moose: # MooseX::ClassAttribute is version unknown, but must be greater than version 0.26 # MooseX::Declare is version unknown, but must be greater than version 0.35 # MooseX::Getopt is version unknown, but must be greater than version 0.56 # MooseX::Method::Signatures is version unknown, but must be greater than version 0.44 # MooseX::Role::Parameterized is version unknown, but must be greater than version 1.00 # MooseX::Role::WithOverloading is version unknown, but must be greater than version 0.07 # MooseX::Storage is version unknown, but must be greater than version 0.42 # MooseX::Types is version unknown, but must be greater than version 0.19 t/zzz-check-breaks.t ....... ok Show quoted text
> On Feb 9, 2017, at 1:30 PM, Karen Etheridge via RT <bug-Template-Plugin-JSON@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=120156 > > > On 2017-02-09 06:28:43, peter.staab@gmail.com wrote:
>> >> I just wanted report a bug in testing Template::Plugin::JSON. I have >> the code generated from cpanm below:
> > No, the problem is upstream, in your Moose installation. > > Please run `moose-outdated` and update everything it lists that is out of date. You should do this whenever you update Moose, and also pay attention to the output of its t/zzz-check-breaks.t test. > > > I will include the relevant bits of the test output below that show where the error is coming from. > >
>> # Failed test 'use Template::Plugin::JSON;' >> # at t/live.t line 11. >> # Tried to use 'Template::Plugin::JSON'. >> # Error: Invalid version format (version required) at >> /Library/Perl/5.18/Module/Runtime.pm line 386. >> # BEGIN failed--compilation aborted at >> /Users/pstaab/.cpanm/work/1486650100.39130/Template-Plugin-JSON- >> 0.07/blib/lib/Template/Plugin/JSON.pm line 6. >> # Compilation failed in require at t/live.t line 11. >> # BEGIN failed--compilation aborted at t/live.t line 11.
> >
Download (untitled) / with headers
text/html 15.6k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 318b
On 2017-02-09 12:39:24, peter.staab@gmail.com wrote: Show quoted text
> I’m not using Moose for anything (I am using Moo).
The module you're reporting the bug under (Template::Plugin::JSON) uses Moose. Show quoted text
> I went ahead and > did moose-outdated and upgraded, but they are all failing.
And what versions of Moo and Moose do you have?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.