Skip Menu |
 

This queue is for tickets about the Crypt-Twofish CPAN distribution.

Report information
The Basics
Id: 120087
Status: new
Priority: 0/
Queue: Crypt-Twofish

People
Owner: Nobody in particular
Requestors: KENTNL [...] cpan.org
TODDR [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.17
Fixed in: (no value)



Subject: Need support for . in @INC in Crypt::Twofish
Download (untitled) / with headers
text/plain 531b
Your generated Makefile will not run unless . is in @INC. As a result of CVE-2016-1238, In 5.26 it will be a build option to make a perl without . in @INC. This requires the script writer to be explicit if they want to load modules from relative paths. For more info you can also see https://rt.perl.org/Ticket/Display.html?id=130467 and https://rt.perl.org/Ticket/Display.html?id=127810 for core perl discussions. My doc is here http://blogs.perl.org/users/todd_rinaldo/2016/11/how-removing-from-inc-is-about-to-break-cpan.html
This patch should correct things.
Subject: Crypt-Twofish.patch
Download Crypt-Twofish.patch
text/x-diff 713b
From 9e864236afe097437e74ca9bf47384d362d93ade Mon Sep 17 00:00:00 2001 From: Todd Rinaldo <toddr@cpanel.net> Date: Fri, 8 Jan 2016 01:24:39 -0600 Subject: [PATCH] Add PERL_USE_UNSAFE_INC support --- Makefile.PL | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Makefile.PL b/Makefile.PL index 0fc3b99..f6b954c 100644 --- a/Makefile.PL +++ b/Makefile.PL @@ -49,7 +49,7 @@ open(F, ">platform.h") || die "platform.h: $!\n"; print F $text; close F; -sub MY::postamble { "tables.h: tab/tables.pl\n\t\$(PERL) tab/tables.pl\n" } +sub MY::postamble { "tables.h: tab/tables.pl\n\tPERL_USE_UNSAFE_INC=1 \$(PERL) tab/tables.pl\n" } WriteMakefile( NAME => 'Crypt::Twofish', -- 2.7.0

Attached is an alternative fix that won't attempt to use a workaround that is slated to be removed in Perl 5.30 ....

 

-- 
- CPAN kentnl@cpan.org
- Gentoo Perl Maintainer kentnl@gentoo.org ( perl@gentoo.org )
 

Subject: 0001-Fix-tab-tables.pl-for-Perl-5.26.patch
From 0906d6c153b3bedad2a91a19e8441b9633070e10 Mon Sep 17 00:00:00 2001 From: Kent Fredric <kentfredric@gmail.com> Date: Sun, 11 Jun 2017 15:29:53 +1200 Subject: [PATCH] Fix tab/tables.pl for Perl 5.26 Removal of "." from @INC means require $PATH no longer ever assumes a path relative to ".", and instead must be explicitly stated with a leading "./" Fixes RT#120087 Bug: https://rt.cpan.org/Ticket/Display.html?id=120087 --- tab/tables.pl | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tab/tables.pl b/tab/tables.pl index 2aa0c66..7bed411 100644 --- a/tab/tables.pl +++ b/tab/tables.pl @@ -3,7 +3,7 @@ # Copyright 2001 Abhijit Menon-Sen <ams@wiw.org> use strict; -require 'tab/misc.pl'; +require './tab/misc.pl'; my ($qtab, $mtab) = ([], []); -- 2.13.1


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.