Skip Menu |
 

This queue is for tickets about the libwww-perl CPAN distribution.

Report information
The Basics
Id: 120072
Status: resolved
Priority: 0/
Queue: libwww-perl

People
Owner: Nobody in particular
Requestors: MZIESCHA [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 6.17
Fixed in: (no value)



Subject: Alpine combined with docker is not able to unpack
Download (untitled) / with headers
text/plain 681b
Since 6.17, alpine linux is not able to unpack this module. My Dockerfile: FROM alpine RUN apk add --update perl make curl g++ gcc wget perl-dev openssl openssl-dev \ && curl -L https://cpanmin.us | perl - App::cpanminus \ && cpanm LWP::UserAgent --> Working on LWP::UserAgent Fetching http://www.cpan.org/authors/id/O/OA/OALDERS/libwww-perl-6.17.tar.gz ... OK gzip: stdin: unexpected end of file /usr/bin/tar: Child returned status 1 /usr/bin/tar: Error is not recoverable: exiting now ! Failed to unpack libwww-perl-6.17.tar.gz: no directory ! Failed to fetch distribution libwww-perl-6.17 if I'm using cpanm LWP::UserAgent@6.16 everything works fine
On Thu Feb 02 13:02:34 2017, MZIESCHA wrote: Show quoted text
> Since 6.17, alpine linux is not able to unpack this module. > > My Dockerfile: > > FROM alpine > > RUN apk add --update perl make curl g++ gcc wget perl-dev > openssl openssl-dev \ > && curl -L https://cpanmin.us | perl - App::cpanminus \ > && cpanm LWP::UserAgent > > --> Working on LWP::UserAgent > Fetching http://www.cpan.org/authors/id/O/OA/OALDERS/libwww-perl- > 6.17.tar.gz ... OK > > gzip: stdin: unexpected end of file > /usr/bin/tar: Child returned status 1 > /usr/bin/tar: Error is not recoverable: exiting now > ! Failed to unpack libwww-perl-6.17.tar.gz: no directory > ! Failed to fetch distribution libwww-perl-6.17 > > if I'm using cpanm LWP::UserAgent@6.16 everything works fine
It looks like there's a sync issue with CPAN? You can work around this for the time being by using the MetaCPAN mirror: cpanm http://cpan.metacpan.org/authors/id/O/OA/OALDERS/libwww-perl-6.17.tar.gz I'll see if the root cause can be addressed as well.
Download (untitled) / with headers
text/plain 1.1k
On Thu Feb 02 14:35:59 2017, OALDERS wrote: Show quoted text
> On Thu Feb 02 13:02:34 2017, MZIESCHA wrote:
> > Since 6.17, alpine linux is not able to unpack this module. > > > > My Dockerfile: > > > > FROM alpine > > > > RUN apk add --update perl make curl g++ gcc wget perl-dev > > openssl openssl-dev \ > > && curl -L https://cpanmin.us | perl - App::cpanminus \ > > && cpanm LWP::UserAgent > > > > --> Working on LWP::UserAgent > > Fetching http://www.cpan.org/authors/id/O/OA/OALDERS/libwww-perl- > > 6.17.tar.gz ... OK > > > > gzip: stdin: unexpected end of file > > /usr/bin/tar: Child returned status 1 > > /usr/bin/tar: Error is not recoverable: exiting now > > ! Failed to unpack libwww-perl-6.17.tar.gz: no directory > > ! Failed to fetch distribution libwww-perl-6.17 > > > > if I'm using cpanm LWP::UserAgent@6.16 everything works fine
> > It looks like there's a sync issue with CPAN? You can work around > this for the time being by using the MetaCPAN mirror: > > cpanm http://cpan.metacpan.org/authors/id/O/OA/OALDERS/libwww-perl- > 6.17.tar.gz > > I'll see if the root cause can be addressed as well.
Actually, I think this is better: cpanm --mirror http://cpan.metacpan.org LWP::UserAgent
Download (untitled) / with headers
text/plain 1.4k
On Thu Feb 02 14:40:01 2017, OALDERS wrote: Show quoted text
> On Thu Feb 02 14:35:59 2017, OALDERS wrote:
> > On Thu Feb 02 13:02:34 2017, MZIESCHA wrote:
> > > Since 6.17, alpine linux is not able to unpack this module. > > > > > > My Dockerfile: > > > > > > FROM alpine > > > > > > RUN apk add --update perl make curl g++ gcc wget perl-dev > > > openssl openssl-dev \ > > > && curl -L https://cpanmin.us | perl - App::cpanminus \ > > > && cpanm LWP::UserAgent > > > > > > --> Working on LWP::UserAgent > > > Fetching http://www.cpan.org/authors/id/O/OA/OALDERS/libwww-perl- > > > 6.17.tar.gz ... OK > > > > > > gzip: stdin: unexpected end of file > > > /usr/bin/tar: Child returned status 1 > > > /usr/bin/tar: Error is not recoverable: exiting now > > > ! Failed to unpack libwww-perl-6.17.tar.gz: no directory > > > ! Failed to fetch distribution libwww-perl-6.17 > > > > > > if I'm using cpanm LWP::UserAgent@6.16 everything works fine
> > > > It looks like there's a sync issue with CPAN? You can work around > > this for the time being by using the MetaCPAN mirror: > > > > cpanm http://cpan.metacpan.org/authors/id/O/OA/OALDERS/libwww-perl- > > 6.17.tar.gz > > > > I'll see if the root cause can be addressed as well.
> > Actually, I think this is better: > > cpanm --mirror http://cpan.metacpan.org LWP::UserAgent > >
It looks like it is indeed a sync issue with cpan.org, so I'm closing this ticket. Using the --mirror option as I suggested above is hopefully a workable solution for you right now. Olaf


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.