Skip Menu |
 

This queue is for tickets about the Dancer2-Logger-Fluent CPAN distribution.

Report information
The Basics
Id: 119920
Status: resolved
Priority: 0/
Queue: Dancer2-Logger-Fluent

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.05



Subject: pod coverage test fails
Download (untitled) / with headers
text/plain 467b
pod-coverage.t test fails: # Failed test 'Pod coverage on Dancer2::Logger::Fluent' # at /usr/perl5.16.3t/lib/site_perl/5.16.3/Test/Pod/Coverage.pm line 133. # Coverage for Dancer2::Logger::Fluent is 66.7%, with 5 naked subroutines: # has_buffer_limit # has_buffer_overflow_handler # has_fluent # has_prefer_integer # has_timeout # Looks like you failed 1 test of 1. t/pod-coverage.t ....... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests
Download (untitled) / with headers
text/plain 1.1k
On 2017-01-19 22:12:29, SREZIC wrote: Show quoted text
> pod-coverage.t test fails: > > # Failed test 'Pod coverage on Dancer2::Logger::Fluent' > # at /usr/perl5.16.3t/lib/site_perl/5.16.3/Test/Pod/Coverage.pm line 133. > # Coverage for Dancer2::Logger::Fluent is 66.7%, with 5 naked subroutines: > # has_buffer_limit > # has_buffer_overflow_handler > # has_fluent > # has_prefer_integer > # has_timeout > # Looks like you failed 1 test of 1. > t/pod-coverage.t ....... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests
While this test failure is indeed an issue that should be corrected, please don't allow pod, critic, coverage or kwalitee tests to run for normal user installs, as they make the installation fail unnecessarily when newer versions of the tester module introduces errors that you cannot anticipate. Also spelling tests are dependent on what dictionaries are installed locally, and critic tests use all plugins that are installed, neither of which can be predicted in advance. Either move these tests to xt/, or guard them with: plan skip_all => "These tests are for authors only!" unless $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING};
RT-Send-CC: ether [...] cpan.org
Download (untitled) / with headers
text/plain 1.4k
On Fri Jan 20 14:44:20 2017, ETHER wrote: Show quoted text
> On 2017-01-19 22:12:29, SREZIC wrote:
> > pod-coverage.t test fails: > > > > # Failed test 'Pod coverage on Dancer2::Logger::Fluent' > > # at /usr/perl5.16.3t/lib/site_perl/5.16.3/Test/Pod/Coverage.pm > > line 133. > > # Coverage for Dancer2::Logger::Fluent is 66.7%, with 5 naked > > subroutines: > > # has_buffer_limit > > # has_buffer_overflow_handler > > # has_fluent > > # has_prefer_integer > > # has_timeout > > # Looks like you failed 1 test of 1. > > t/pod-coverage.t ....... > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/1 subtests
> > > While this test failure is indeed an issue that should be corrected, > please don't allow pod, critic, coverage or kwalitee tests to run for > normal user installs, as they make the installation fail unnecessarily > when newer versions of the tester module introduces errors that you > cannot anticipate. Also spelling tests are dependent on what > dictionaries are installed locally, and critic tests use all plugins > that are installed, neither of which can be predicted in advance. > > Either move these tests to xt/, or guard them with: > > plan skip_all => "These tests are for authors only!" unless > $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING};
Thank you so much for pointing this out Slaven, and for the advice, Karen! MUCH appreciated! :) I'll fix this by guarding these tests with for author/release testing only, as adviced. Thanks again! Arnold
Download (untitled) / with headers
text/plain 1.5k
On Sat Jan 21 02:25:01 2017, ATANCASIS wrote: Show quoted text
> On Fri Jan 20 14:44:20 2017, ETHER wrote:
> > On 2017-01-19 22:12:29, SREZIC wrote:
> > > pod-coverage.t test fails: > > > > > > # Failed test 'Pod coverage on Dancer2::Logger::Fluent' > > > # at /usr/perl5.16.3t/lib/site_perl/5.16.3/Test/Pod/Coverage.pm > > > line 133. > > > # Coverage for Dancer2::Logger::Fluent is 66.7%, with 5 naked > > > subroutines: > > > # has_buffer_limit > > > # has_buffer_overflow_handler > > > # has_fluent > > > # has_prefer_integer > > > # has_timeout > > > # Looks like you failed 1 test of 1. > > > t/pod-coverage.t ....... > > > Dubious, test returned 1 (wstat 256, 0x100) > > > Failed 1/1 subtests
> > > > > > While this test failure is indeed an issue that should be corrected, > > please don't allow pod, critic, coverage or kwalitee tests to run for > > normal user installs, as they make the installation fail > > unnecessarily > > when newer versions of the tester module introduces errors that you > > cannot anticipate. Also spelling tests are dependent on what > > dictionaries are installed locally, and critic tests use all plugins > > that are installed, neither of which can be predicted in advance. > > > > Either move these tests to xt/, or guard them with: > > > > plan skip_all => "These tests are for authors only!" unless > > $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING};
> > Thank you so much for pointing this out Slaven, and for the advice, > Karen! MUCH appreciated! :) > > I'll fix this by guarding these tests with for author/release testing > only, as adviced. > > Thanks again! > Arnold


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.