Skip Menu |
 

This queue is for tickets about the Math-BigInt-FastCalc CPAN distribution.

Report information
The Basics
Id: 119413
Status: resolved
Priority: 0/
Queue: Math-BigInt-FastCalc

People
Owner: Nobody in particular
Requestors: ppisar [...] redhat.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.5005
Fixed in: 0.5006



Subject: Math::BigInt::Calc version specified as a string
Download (untitled) / with headers
text/plain 444b
lib/Math/BigInt/FastCalc.pm uses Math::BigInt::Calc like this: use Math::BigInt::Calc '1.999801'; I think the single quotes around the version is not what you want: $ perl -e 'use Math::BigInt::Calc q{1.999801}' $ perl -e 'use Math::BigInt::Calc q{2.999801}' $ perl -e 'use Math::BigInt::Calc 2.999801' Math::BigInt::Calc version 2.999801 required--this is only version 1.999715 at -e line 1. BEGIN failed--compilation aborted at -e line 1.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.